Unable to set Sonos Era 100 as Alexa-enabled device in room/group using Alexa app


Userlevel 1

Today I’ve upgraded my two Sonos Ones with Sonos Era 100s. After adding Alexa to the speakers, I tried to go into the Alexa app to associate them with their respective rooms. I’m able to add them as the room speaker, but I am unable to set them as the Alexa device for that room (allowing for room-specific commands like “Alexa, turn off the lights”, etc).

What’s weird is my Era 100s will show up under the Echo & Alexa devices section in the Alexa app, but they do not show up under Alexa-enabled devices when editing a room/group (see attached screenshots).

I’ve reached out to Alexa support and they were largely unhelpful, they claimed that from their resources Alexa isn’t supported on the Sonos Era 100 (maybe their documentation hasn’t been updated since this is a brand new product?). So they left the conversation there even after showing them that Sonos clearly states Alexa built-in support for the Era 100.

Has anyone else experienced this issue? Seems like a bug in the Alexa app, and their support team is unwilling to report the issue up their chain.

 

Corry P 10 months ago

Hi Everyone

If you are still experiencing this issue (which we believed had stopped happening outside of Germany) please submit a support diagnostic and post the given number along with a screenshot of the Alexa app showing a lack of Era units under “Alexa-enabled Devices”, as above. Thank you.

View original

101 replies

Userlevel 4
Badge +1

Alexa is broken after the version 15.2 app update. Doesn't work on my Beam.

Userlevel 7
Badge +20

Alexa is broken after the version 15.2 app update. Doesn't work on my Beam.

Please first disable then enable the Sonos skill in the Alexa App.  If the problem persists then have a look at my article: Tips & Tricks - Resolving random issues impacting Sonos devices.. | Sonos Community

Userlevel 7
Badge +20

Today I’ve upgraded my two Sonos Ones with Sonos Era 100s. After adding Alexa to the speakers, I tried to go into the Alexa app to associate them with their respective rooms. I’m able to add them as the room speaker, but I am unable to set them as the Alexa device for that room (allowing for room-specific commands like “Alexa, turn off the lights”, etc).

What’s weird is my Era 100s will show up under the Echo & Alexa devices section in the Alexa app, but they do not show up under Alexa-enabled devices when editing a room/group (see attached screenshots).

I’ve reached out to Alexa support and they were largely unhelpful, they claimed that from their resources Alexa isn’t supported on the Sonos Era 100 (maybe their documentation hasn’t been updated since this is a brand new product?). So they left the conversation there even after showing them that Sonos clearly states Alexa built-in support for the Era 100.

Has anyone else experienced this issue? Seems like a bug in the Alexa app, and their support team is unwilling to report the issue up their chain.

 

Can you open the Sonos App>Settings>Services & Voice>Amazon Alexa and ensure that your two new Era 100’s are shown as enabled.  If they are not in the list then please select + Add to Another Product.

Userlevel 4
Badge +1

Alexa is broken after the version 15.2 app update. Doesn't work on my Beam.

Please first disable then enable the Sonos skill in the Alexa App.  If the problem persists then have a look at my article: Tips & Tricks - Resolving random issues impacting Sonos devices.. | Sonos Community

 

This hasn't helped and it's actually worse now because I can't reconnect my Beam to Alexa (see screenshot). Why is Sonos so unreliable?

 

Userlevel 4
Badge +1

 

Userlevel 4
Badge +1

 

Finally connected but Alexa and all music services are inoperable in the Sonos app with version 15.2…

 

Why do we need a computer degree to operate Sonos??

Badge

Today I’ve upgraded my two Sonos Ones with Sonos Era 100s. After adding Alexa to the speakers, I tried to go into the Alexa app to associate them with their respective rooms. I’m able to add them as the room speaker, but I am unable to set them as the Alexa device for that room (allowing for room-specific commands like “Alexa, turn off the lights”, etc).

What’s weird is my Era 100s will show up under the Echo & Alexa devices section in the Alexa app, but they do not show up under Alexa-enabled devices when editing a room/group (see attached screenshots).

I’ve reached out to Alexa support and they were largely unhelpful, they claimed that from their resources Alexa isn’t supported on the Sonos Era 100 (maybe their documentation hasn’t been updated since this is a brand new product?). So they left the conversation there even after showing them that Sonos clearly states Alexa built-in support for the Era 100.

Has anyone else experienced this issue? Seems like a bug in the Alexa app, and their support team is unwilling to report the issue up their chain.

 

Having the exact same issue here! Received new Era speakers today, had Ones before. Removed Sonos skill in Alexa, deleted all Sonos devices, re-enrolled everything, but didn’t help. My remaining Sonos One can be added to a room, all new Era speakers cannot.

 

If anyone has a solution for this, highly appreciated!

I sat through 35 mins on to Sonos support. Whilst patient, utterly useless advice - deleted all skills, started from scratch twice and it just doesn’t work. 

Pretty poor releasing a product that clearly doesn’t do what it is supposed to do. Although, I don’t doubt  that Amazon also have their grubby mitts over not making this work either. 

Ideas welcome especially if it doesn’t involve deleting everything and starting again….again!

Userlevel 7
Badge +20

Alexa is broken after the version 15.2 app update. Doesn't work on my Beam.

Please first disable then enable the Sonos skill in the Alexa App.  If the problem persists then have a look at my article: Tips & Tricks - Resolving random issues impacting Sonos devices.. | Sonos Community

 

This hasn't helped and it's actually worse now because I can't reconnect my Beam to Alexa (see screenshot). Why is Sonos so unreliable?

 

Did you follow both the skill and the steps within the article linked?  (At this stage, we don’t know if this is a Sonos or Amazon issue, from the description you’ve described.)

Hi

The Era 100 are wonderful……….Alexa not supported is rubbish, it is.   You are correct. Had more or less the same problem. Upgraded my Sonos Ones first generation to a pair of Era 100.  Could assign them to the room however Alexa would not play game.  I changed the room name I was using on my previous Sonos ones and the problem was sorted. 

 

Userlevel 6
Badge +11

Have a look here at the steps I followed, I came to conclusion an issue with Alexa discovery:

https://en.community.sonos.com/speakers-229128/new-era-100s-cannot-setup-alexa-6881415

I also replaced some P1’s & Alexa Echo device with single ERA 100.

I did rename the room with the P1s & echo in Sonos App before I added new ERA100 to Sonos ina new room with the old name.

eg rename ‘Bedroom’ in Sonos App to ‘OLD Bedroom’, add new ERA100 to ‘Bedroom’ and forced rediscover on Alexa by disabling/enabling Sonos Skill.

Same problem here with Era 300.

Works basically well with Alexa, but adding to a group is not possible.

Badge

Today I’ve upgraded my two Sonos Ones with Sonos Era 100s. After adding Alexa to the speakers, I tried to go into the Alexa app to associate them with their respective rooms. I’m able to add them as the room speaker, but I am unable to set them as the Alexa device for that room (allowing for room-specific commands like “Alexa, turn off the lights”, etc).

What’s weird is my Era 100s will show up under the Echo & Alexa devices section in the Alexa app, but they do not show up under Alexa-enabled devices when editing a room/group (see attached screenshots).

I’ve reached out to Alexa support and they were largely unhelpful, they claimed that from their resources Alexa isn’t supported on the Sonos Era 100 (maybe their documentation hasn’t been updated since this is a brand new product?). So they left the conversation there even after showing them that Sonos clearly states Alexa built-in support for the Era 100.

Has anyone else experienced this issue? Seems like a bug in the Alexa app, and their support team is unwilling to report the issue up their chain.

 

 

I am having the same problem with my Era 100 and Beam Gen 2’s. They are not appearing as “Alexa-enabled devices” per the OP’s second screenshot, and cannot be added to the group on Alexa. The Era 100 was a recent addition to my Sonos System. The Beam Gen 2’s had been around for a while but recently dropped out from “Alexa-enabled devices”. I have tried renaming speakers on both Sonos and Alexa apps, reinstalled Alexa on the Era 100, and reinstalled the skill on Alexa, but nothing works. My Arc and Move remain unaffected as “Alexa-enabled devices”, so I can only conclude that something is wrong with the Era 100, and a recent update broke the Beam Gen 2’s.

 

EDIT: I observed the Beam Gen 2’s dropping out randomly and then going back into their Alexa groups. I’m not sure why. Hopefully it doesn’t drop out again. The Era 100 is still not working with Alexa.

Similar discussion in the German forum:

https://de.community.sonos.com/amazon-alexa-und-sonos-223393/era-300-alexa-gruppe-hinzufuegen-6755294

It occurs to me, Era 100/300 have the same Alexa-bug.

According to this thread concerning Beam gen2 authorization by amazon might be missing?

 

Got two Era 100 today and seeing the same thing.

Userlevel 2
Badge

I’ve got the exact same issue.

Had a brand new Era 100 delivered today, and can’t seem to add them to a group as an Alexa enabled device.

 

Has anyone managed to resolve this? Or can anyone confirm that their own Era 100 is working as expected and the can get it work?

 

Trying to work out it this is a global product issue or  isolated to our particular setup.

It appears to be a global issue and from what I understand is this is something Amazon needs to fix, no idea if they are aware of this however and if Sonos are working with then to do that

Same thing here. I’m in the beta programme and got the tech support people there to look into it - result “it’s an Alexa issue”.

Badge

Either way, it needs to be fixed. It’s the only thing stopping me from buying three Era 300’s to replace what I have around the house.

Also having the exact same issue here. I got a new Sonos Era 100 to replace one of my Sonos Ones and can’t add it as an Alexa-enabled device to a group. Please fix this!

Based on past experience, it’s usually some weeks, or even a couple of months, after the release of a new Sonos product before Amazon certify them as an Alexa Group ‘enabling’ (controlling) device. I’m not sure what that certification process involves, but clearly each new device has to be tested by them. It clearly hasn’t happened yet. I recall it took quite a while post-release before the Roam became certified for enabling a group, but these Era products can still be used with an Alexa group, they just cannot control/enable the group at this time.

Heres hoping the Amazon certification occurs sooner, rather that later.🤞

I’m having the same issue with new Era 300

Has Sonos responded with anything about this issue?

This is a very irritating issue for a new Sonos user. I bought these to replace some cheap Dots that have very poor sound quality. Not being able to talk to the speaker about things in the room/group breaks a basic functionality of the Alexa system. Not sure if it is Amazon or Sonos to blame, but it super sucks. 

Reply