Answered

Struggling to add Alexa to Sonos

  • 9 January 2021
  • 2 replies
  • 35 views

Trying very hard to connect sonos 1 to alexa . It used to work . Then stopped . Alexa worked but would not plsy sonos 1 speaker . HAve reset speaker . deleted / restored app both sonos and alexa .  (all speakers work on the sonos app) . Now alexa wont work at all . Alexa app says it is enabled . Sonos shpows speaker . In Sonos services i cannot find voice / alexa option . 6 hours on this . HATE IT . 

 

icon

Best answer by Ken_Griffiths 9 January 2021, 22:55

Try these three quick steps to ‘hopefully’ fix your issue..

  1. Remove the Sonos ‘skill’ in the Amazon Alexa App skills section.
  2. Remove the Alexa Assistant from your speaker(s) in the Sonos App under "Settings/Services & Voice/Amazon Alexa"
  3. Log into Amazon account online and ‘deregister’ all your Sonos devices under the “Manage Content & Devices” section of your account (devices tab). The link to devices is something similar to the URL shown below, but you ‘may’ need to adjust the link to point to your own country/account: https://www.amazon.co.uk/hz/mycd/digital-console/alldevices

Then go back to the Sonos App and start by adding your Alexa voice assistant to your speaker and follow the on-screen instructions and all being well, Alexa should then work fine.

View original

2 replies

Try these three quick steps to ‘hopefully’ fix your issue..

  1. Remove the Sonos ‘skill’ in the Amazon Alexa App skills section.
  2. Remove the Alexa Assistant from your speaker(s) in the Sonos App under "Settings/Services & Voice/Amazon Alexa"
  3. Log into Amazon account online and ‘deregister’ all your Sonos devices under the “Manage Content & Devices” section of your account (devices tab). The link to devices is something similar to the URL shown below, but you ‘may’ need to adjust the link to point to your own country/account: https://www.amazon.co.uk/hz/mycd/digital-console/alldevices

Then go back to the Sonos App and start by adding your Alexa voice assistant to your speaker and follow the on-screen instructions and all being well, Alexa should then work fine.

Ken 

thanks. Had tried all of that . I then deleted the Sonos app and reinstalled it and all worked .  Wish I had done it earlier . All working now . tks Hilary 

Reply