Tips & Tricks

Step by Step Guide to Play BBC radio station via Voice Control

  • 4 January 2020
  • 33 replies
  • 5257 views

Userlevel 7
Badge +20

There have been a lot of threads and questions asking how to initiate the playing of BBC Radio Stations after the BBC removed voice control of their stations from within TuneIn. So I thought I would bring all of the recommended steps together in one thread.

  1. Open the Sonos App and click on the Search icon and then select ‘Stations’ below the Search Text box;
  2. Type into the Search Text box, the name of the BBC radio station that you want to listen to and against the station in the list below click on the three vertical buttons and then select ‘Add to My Radio Stations’. Then click ‘Done’ (For the purposes of this example, I will use Radio 2);
  3. Open www.IFTTT.com and either create an account or log-in to your existing account;
  4. If using a Web Browser, click on your profile picture in the top right hand corner of the screen, to the left of the Explore button, and select ‘Create’;
  5. Click on the ‘+’ symbol and enter ‘Alexa’ in the Search Text Box, then select the Amazon Alexa icon;
  6. Select ‘Say a Specific Phase’ and enter ‘play radio two’ before clicking ‘Create trigger’;
  7. Click on the newly positioned ‘+’ symbol and enter ‘Sonos’ in the Search Text Box, then select the Sonos icon;
  8. Choose the Action ‘Play Favorite’ from the list displayed;
  9. Select BBC Radio 2 from the Favorites list and then choose which Sonos Device and what Group of Sonos Players to include.  Then click ‘Create trigger’ and Finish;

This will now work with the Alexa command ‘Alexa, Trigger Play Radio Two’

If you don’t want to introduce the additional ‘Trigger’ Command within the Alexa phrase, then in addition please:

  1. Open the Alexa App and select the three vertical lines in the top left of your screen and select ‘Routines’;
  2. Select the ‘+’ symbol in the top right-hand screen to create a new Routine;
  3. Click ‘Enter routine name’ and type in ‘play radio two’ and then ‘Next’ in the top right-hand of your screen;
  4. Click ‘When this happens’ and ‘Voice’ and then type ‘play radio two’ and then ‘Next’ in the top right-hand of your screen;
  5. Now select ‘Add action’ and select ‘IFTTT’.  You will now see all of the SONOS applets that you have created within IFTTT, please select ‘play radio two’ and then select ‘Next’ in the top right hand of your screen;
  6. Now click ‘Save’ in the top right hand of your screen

This will now work with the command ‘Alexa, Play Radio Two’

EDIT:

Just repeat the instructions for different Radio Stations or different Sonos Rooms.


33 replies

Userlevel 2

Awesome. Thanks for this.

 

One limitation of the method is that you have to tell IFTT what room  is to play in. Do you know if it’s possible to create multiple IFTT rules? Ie. ‘play radio 6 in the bedroom’, ‘play radio 6 in the kitchen’.

I’m new to IFTT and I can’t see a way of duplicating the applet in IFTT.

 

Cheers,

Chris.

Yes I have multiple  rules.  In 'My Applets' hit the '+' symbol

 

Userlevel 7
Badge +20

Awesome. Thanks for this.

 

One limitation of the method is that you have to tell IFTT what room  is to play in. Do you know if it’s possible to create multiple IFTT rules? Ie. ‘play radio 6 in the bedroom’, ‘play radio 6 in the kitchen’.

I’m new to IFTT and I can’t see a way of duplicating the applet in IFTT.

 

Cheers,

Chris.

Hi Chris

 

In addition to the comments from @John B, just follow the instructions multiple times for each room. I’ve now amended the instructions above to include this additional information.

Userlevel 2

Thanks. It was easy in the end. Great instructions!

Badge

UK Media, thats brilliant, thank you. I had been trying for weeks to get BBC radio back on my Sonos via Alexa. I have just done the above and it works perfectly. Easy to do as well once you have done if a couple of times. Thank you.

There is now an alternative which seems to work and is more flexible. With an Alexa group set up consisting of an Echo device and a Sonos speaker, with ‘preferred speaker’ set to the Sonos speaker, just say:

‘Alexa, play Radio 6 Music from the BBC’ (for example)

it will play on the Sonos speaker.

If you say ‘Alexa, play BBC Radio 6 Music’, it will play on the Echo device.

So I just use the first formulation now.  

You cannot direct this to another Sonos speaker, but I don’t find this a problem in practice.

If you have more than one preferred speaker, they do not seem to group for play as they normally would.  I don’t know how Alexa decides which speaker to use.

I hope that helps.  I did not discover this, but saw it on a recent thread.  I am pretty sure this wasn’t an option originally.

Badge

Thanks so much for this. Never used IFTTT before but followed your instructions and now just have to say play radio 4 in bathroom and IT WORKS! I have been very frustrated by the BBC removing the old system but now it is all back thanks to you - a v grateful listener.

There have been a lot of threads and questions asking how to initiate the playing of BBC Radio Stations after the BBC removed voice control of their stations from within TuneIn. So I thought I would bring all of the recommended steps together in one thread.

  1. Open the Sonos App and click on the Search icon and then select ‘Stations’ below the Search Text box;
  2. Type into the Search Text box, the name of the BBC radio station that you want to listen to and against the station in the list below click on the three vertical buttons and then select ‘Add to My Radio Stations’. Then click ‘Done’ (For the purposes of this example, I will use Radio 2);
  3. Open www.IFTTT.com and either create an account or log-in to your existing account;
  4. If using a Web Browser, click on your profile picture in the top right hand corner of the screen, to the left of the Explore button, and select ‘Create’;
  5. Click on the ‘+’ symbol and enter ‘Alexa’ in the Search Text Box, then select the Amazon Alexa icon;
  6. Select ‘Say a Specific Phase’ and enter ‘play radio two’ before clicking ‘Create trigger’;
  7. Click on the newly positioned ‘+’ symbol and enter ‘Sonos’ in the Search Text Box, then select the Sonos icon;
  8. Choose the Action ‘Play Favorite’ from the list displayed;
  9. Select BBC Radio 2 from the Favorites list and then choose which Sonos Device and what Group of Sonos Players to include.  Then click ‘Create trigger’ and Finish;

This will now work with the Alexa command ‘Alexa, Trigger Play Radio Two’

If you don’t want to introduce the additional ‘Trigger’ Command within the Alexa phrase, then in addition please:

  1. Open the Alexa App and select the three vertical lines in the top left of your screen and select ‘Routines’;
  2. Select the ‘+’ symbol in the top right-hand screen to create a new Routine;
  3. Click ‘Enter routine name’ and type in ‘play radio two’ and then ‘Next’ in the top right-hand of your screen;
  4. Click ‘When this happens’ and ‘Voice’ and then type ‘play radio two’ and then ‘Next’ in the top right-hand of your screen;
  5. Now select ‘Add action’ and select ‘IFTTT’.  You will now see all of the SONOS applets that you have created within IFTTT, please select ‘play radio two’ and then select ‘Next’ in the top right hand of your screen;
  6. Now click ‘Save’ in the top right hand of your screen

This will now work with the command ‘Alexa, Play Radio Two’

EDIT:

Just repeat the instructions for different Radio Stations or different Sonos Rooms.

This is totally brilliant. It works. Thanks so much for this! :)

I've been trying this for Google assistant / Sonos but no matter what trigger phase I enter on IFTTT, it says " this phrase is reserved for the Google assistant. Please rephrase". Has anyone else been able to get BBC stations working with Google assistant?

Userlevel 7
Badge +20

I've been trying this for Google assistant / Sonos but no matter what trigger phase I enter on IFTTT, it says " this phrase is reserved for the Google assistant. Please rephrase". Has anyone else been able to get BBC stations working with Google assistant?

Hi

 

Try a phrase without Play in it. e.g. Start Radio Two.

Legend, thank you

Badge

There is now an alternative which seems to work and is more flexible. With an Alexa group set up consisting of an Echo device and a Sonos speaker, with ‘preferred speaker’ set to the Sonos speaker, just say:

‘Alexa, play Radio 6 Music from the BBC’ (for example)

it will play on the Sonos speaker.

If you say ‘Alexa, play BBC Radio 6 Music’, it will play on the Echo device.

So I just use the first formulation now.  

You cannot direct this to another Sonos speaker, but I don’t find this a problem in practice.

If you have more than one preferred speaker, they do not seem to group for play as they normally would.  I don’t know how Alexa decides which speaker to use.

I hope that helps.  I did not discover this, but saw it on a recent thread.  I am pretty sure this wasn’t an option originally.


Maybe this loophole has arisen out of the recent changes whereby a smart home device group with multiple echos can act as a multi room music group if the preferred speaker setting hasn’t been used - the timing is perhaps too coincidental…

This same loophole appears to have been used by the Alexa MyMedia skill to provide multi room support for it too...

Badge

In response to not being able to ask Alexa to stop playing a radio station started in the above manner (if that’s still an issue), I have suggested elsewhere  creating  another  IFTTT  applet  called  “sonos  pause”  triggered  by  that  same  phrase  in  Alexa  in  the  IF  part,  with the ’then’  part  being  the  Sonos  pause  action (since it doesn’t seem to have a stop action)
You  can  then ask  “Alexa,  trigger   Sonos pause”,  or  to  make  it  tidier,  create an  Alexa routine  with  the   voice phrase “sonos pause”  and  a  routine  ifttt  action  using  the  “sonos  pause”  applet.  Then, “Alexa,  sonos  pause”  will do  the  same  and   sound a  bit  more  natural.

This works for normal stations but not for stations that are added to favourites in url format - as far as I can see… Any suggestions? Thank you.

Userlevel 7
Badge +20

This works for normal stations but not for stations that are added to favourites in url format - as far as I can see… Any suggestions? Thank you.

What URL are you trying to play?

I am trying to play  http://icecast.radiofrance.fr/fip-midfi.mp3

I have mixed success with saying (play) fip as a word but alexa does not seem to understand F I P as separate letters

Thanks

I am trying to play  http://icecast.radiofrance.fr/fip-midfi.mp3

I have mixed success with saying (play) fip as a word but alexa does not seem to understand F I P as separate letters

Thanks

This seems off-topic as this thread is about playing BBC radio stations to cope with BBC dropping TuneIn, while Alexa uses Tunein.

All the same, maybe trying calling it something else when you add it, like ‘My FIP’, or ‘Mabel’ or whatever.  But this will only work if you are using IFTTT, and if you are using ‘Play’ as a command rather than ‘trigger’ then your question has nothing to do with IFTTT either.

This works really well and a welcome solution to my little first world problem of not being able to play 6 music on my Sonos via Alexa. I needn’t send the little speaker back now, thank you OP.

Badge

Whatever I try, I just get “Sorry, I don’t see that IF(TTT) trigger”. Really frustrating.

Userlevel 7
Badge +20

That's strange 🤔 If you run the routine within the Alexa App/Routines and they press the play icon for the correct routine, does that work?

Badge

I don’t have any routines listed in my Android alexa app. Should something I set up on the IFTTT web page appear in toutines?

Badge

Update. I have made a routine on my phone that calls the IFTTT applet to play BBC Radio 2 on my Sonos system and that works if I play it from the phone routine list. However, if I say “Alexa trigger play radio two” then I get the “Sorry...” response again. There is something silly missing, but I can’t work out what!

However, if I just say “Alexa play radio 2” it works and I get radio two on my sonos system.

Does your applet require the phrase 'play radio 2' or just 'radio 2'?

Your  final comment makes me wonder why you are bothering with IFTTT.

Badge

Thanks for the replies

The applet requires “play radio 2” but I have just made another with just “radio 2” and the result is the same.

My wording of the “last comment” is a bit ambiguous. Things work the way I would like after I have embedded the IFTTT applet in an alexa routine called “play radio two”. So, I say “Alexa play radio 2” and I get the response “OK” and a second or so later radio 2 starts playing on my sonos speaker. A direct call of the IFTTT applet using the trigger command fails.

Userlevel 7
Badge +20

Thanks for the replies

The applet requires “play radio 2” but I have just made another with just “radio 2” and the result is the same.

My wording of the “last comment” is a bit ambiguous. Things work the way I would like after I have embedded the IFTTT applet in an alexa routine called “play radio two”. So, I say “Alexa play radio 2” and I get the response “OK” and a second or so later radio 2 starts playing on my sonos speaker. A direct call of the IFTTT applet using the trigger command fails.

As per part two of the steps listed, this is now working as intended. 😁

Reply