Sonos One and Alexa - can't connect

  • 1 November 2017
  • 5 replies

I have brought a new Sonos One, and I can’t connect it to Alexa. I have tried everything I can think of. Please can someone help?? All it shows is amazon products on the Alexa app and not the Sonos One?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7
Step 1.Verify that the Sonos One shows in the Sonos App. In not unplug the Sonos One and set it up again
Step 2. If all is good verify that the LED on top of the Sonos One just below the Microphone icon is on. If not tap the Microphone icon to turn it on.

Note: The next step may require you to re-setup devices and groups manually. You can skip it and go to Step 4 and come back to Step 3 if Step 4 proves unsuccessful.

Step 3 Delete the Alexa app and reinstall it.
Step 4 Now speak to the Sonos One by saying "Alexa Discover Devices".
Step 5 Repeat Step 4 if you had to employ Step 3.
Thank you for your help. I have tried this all and the Sonos One is still not showing on the Alexa app when I ask to discover devices. Do you have a step by step to set up the Alexa app?
Userlevel 7
Badge +21
Userlevel 7
Badge +20

Open the Sonos app on iOS or Android (not PC app) and select Settings>Room Settings>Your Sonos 1. Under Voice control, disable Voice Control and then Enable.
I had a similar issue and none of the suggestions above worked for me. What worked was following:
0. Make sure that your Sonos setup is done (network + all devices are connected and work with your Sonos app).
1. Go to your Alexa app on your mobile device. (you don't have to reinstall it).
2. Go to your skills and specifically your Sonos skill.
3. Disable the skill.
4. Enable the skill again. The flow will ask you to:
4.1 Authenticate again with Sonos.
4.2 Discover the devices.
4.3 All your connected Sonos devices will appear and can be controlled through Alexa (even those that don't have the mic).
5. That's it!

This issue happened to me because of following (don't know exactly which individual step or combo):
1. I've changed to new wifi/mesh network.
2. I've changed name/position of existing speakers.
3. I've added new speakers to the network.

After these changes Alexa got totally confused and refused to identify any device.

Hope this helps!