Answered

Smart Plugs working from Alexa app on Android but not from Sonos One

  • 27 December 2018
  • 8 replies
  • 491 views

I think this is a recurring theme but haven't seen a topic that actually solves my issue so hoping an expert will be able to help here.

We've a couple of Sonos Ones just installed. They are working fine using WIFI and have elements such as Spotify set-up and they've been paired together, so basic config seems OK. Alexa seems to be working OK on it too. The speakers are visible from my phone such that I can direct streams to them, turn them on/off etc.

We also installed a pair of Smart Life UP111 sockets to have a go using these devices via Alexa. I can control them using Alexa on my phone and from an Echo Dot but The Sonos speakers can't see them. I don't see anything in the Sonos config that I need to change and am stuck. Is it obvious to you what I have done wrong? Pretty sure the Alexa on the Sonos is meant to be able to control this kind of device?

Thanks
icon

Best answer by UKMedia 27 December 2018, 12:56

If you open the Alexa App>Smart Home>Devices can you see your Smart Plugs listed? If yes, can you make sure that there are no duplicate device names? It's very easy to name the Kitchen Sonos and Kitchen Echo Dot both Kitchen, I use the naming standard Room Name + Device Type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos etc.

This may seem long-winded but with the new support for Alexa groups, (https://en.community.sonos.com/amazon-alexa-and-sonos-229102/an-overview-and-explanation-of-the-new-support-for-alexa-grouping-6817788) you don't need to remember Sonos device names much any more.
View original

8 replies

Userlevel 7
Badge +20
If you open the Alexa App>Smart Home>Devices can you see your Smart Plugs listed? If yes, can you make sure that there are no duplicate device names? It's very easy to name the Kitchen Sonos and Kitchen Echo Dot both Kitchen, I use the naming standard Room Name + Device Type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos etc.

This may seem long-winded but with the new support for Alexa groups, (https://en.community.sonos.com/amazon-alexa-and-sonos-229102/an-overview-and-explanation-of-the-new-support-for-alexa-grouping-6817788) you don't need to remember Sonos device names much any more.
Thanks for that. Yes, they do appear in the Alexa app, at the moment imaginatively called Lights One and Lights Two. From the Echo and app they can be turned on/off. From Sonos we get an error to say that "Couldn't find a device named Lights One".
Userlevel 7
Badge +20
That's strange. A couple of things to try:

1/ Please open the Alexa App>Settings>History and check that Alexa heard you correctly;
2/ Please try renaming them to a single word and then ask 'Alexa, Discover devices'
Thanks. Hmm, looking at the Alexa app history on my phone I only see the history for commands to the dot and to the phone, not to Sonos. Not sure if it is also a clue, I have connected to my premium spotify account but Soon insists on using Amazon even though in the app I have set Spotify to take preference and get an error message about needing to connect a premium spotify account - this is fine on the dot.
Userlevel 7
Badge +20
Hi

Sorry for another long post but this type of issue is normally down to one of three things:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a Browser (https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the Browser version has this functionality.)

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please log out of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (Browser version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app , select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.

Let us know how you get on.
Hi

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and 2.3/ If the problem still persists, please log out of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (Browser version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;


Thank you very much for my help. I'm being very slow I think. I have been through 1 and have only Kitchensonos, Near and Far as devices (Kitchensonos renamed from Kitchen to make distinct from the room Kitchen assuming this is needed).

On 2, "log out of all Amz accounts" - you mean from within the Sonos App? I think I have done this, disabled and re-enabled, powered down and all back up but with the same result, although it does now know my account name although it has lost my Spotify link again which I will try to figure out. It can't find any devices still (can see/control them on my phone).

On 3, I am not sure where I should be for 3.2 - the browser version of the Alexa app? I have only an android app. I'm missing the point on that I think.


I think I might have a clue to the problem which you have eluded to though. In my Alexa android app->music settings, I can see that Amazon Music is showing my work email address (I first set-up an echo for the office using this phone). I don't want Amazon Music service as have Spotify (which is showing my personal login). Sonos Alexa refuses to play Spotify as it says I need to sign-up and sign-in - which I have. If I go to Sonos Android App->Add Music services, Spotify is there and I can choose one of my playlists and it plays on the Sonos....Something is very confused. I guess this means flatten everything and complete stage 3?

Thanks for your time.
Userlevel 7
Badge +20
Hi

Thank you very much for my help. I'm being very slow I think. I have been through 1 and have only Kitchensonos, Near and Far as devices (Kitchensonos renamed from Kitchen to make distinct from the room Kitchen assuming this is needed).


Unless that's a typo, it would be best to call the device 'Kitchen Sonos' rather than Kitchensonos' as Alexa may not understand otherwise. Have you asked 'Alexa, Discover Devices'?

On 2, "log out of all Amz accounts" - you mean from within the Sonos App? I think I have done this, disabled and re-enabled, powered down and all back up but with the same result, although it does now know my account name although it has lost my Spotify link again which I will try to figure out. It can't find any devices still (can see/control them on my phone).


You need to log out of ALL Amazon related Apps on your Android device. e.g. Amazon Shopping etc.

On 3, I am not sure where I should be for 3.2 - the browser version of the Alexa app? I have only an android app. I'm missing the point on that I think.


Please select the Internet or Chrome App on your Android device and then enter either (https://alexa.amazon.co.uk or https://alexa.amazon.com)

I think I might have a clue to the problem which you have eluded to though. In my Alexa android app->music settings, I can see that Amazon Music is showing my work email address (I first set-up an echo for the office using this phone). I don't want Amazon Music service as have Spotify (which is showing my personal login). Sonos Alexa refuses to play Spotify as it says I need to sign-up and sign-in - which I have. If I go to Sonos Android App->Add Music services, Spotify is there and I can choose one of my playlists and it plays on the Sonos....Something is very confused. I guess this means flatten everything and complete stage 3?

Thanks for your time.


You need to add Spotify to your Alexa App as well as the Sonos App, as per this article: https://www.amazon.co.uk/gp/help/customer/display.html?nodeId=201628770

You should be able access the Spotify App from Alexa App> Settings>Music>Spotify once set-up correctly.
...simple in the end. I thin, as you suggested, the Alexa app was connected to another login. Logging out of Alexa on Android (no other Amazon apps on my phone) and then logging in again asked me to go through the device set-up again. This time, everything found. Working!

Thanks very much.

Reply

    Cookie policy

    We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

    Accept cookies Cookie settings