Answered

Preferred speaker function in Alexa no longer working after latest Sonos update


The preferred speaker function in the Alexa app no longer works after the latest Sonos update. It has always worked perfectly. I have disabled and reabled the Sonos function in the Alexa app and that didn’t work.
icon

Best answer by cbinwnc 8 May 2019, 13:40

Well, magically, it started working again just fine. I made no changes, and it just started working again. Interestingly enough, I got an email from Sonos (in the app) explaining this "new" functionality yesterday, even though I've been using it for months. Something was definitely up with the update. All is OK now. Thanks for the replies.
View original

29 replies

Can you clarify what's not working? Are you unable to add a Sonos room as a preferred speaker in the app? The preferred speaker is setup, but voice commands aren't working properly?

If it's the former, logging out of your Alexa app and logging back in might help. If it's the latter, it sounds more like an issue on Amazon's side of things. Sonos can't play the music if it never gets the command from Alexa. You could submit a diagnostic
https://support.sonos.com/s/article/141?language=en_US after reproducing the error, post it here, and a Sonos employee will come along and tell you what they see on the back end.
In the Alexa app, I have groups set up so I can use the preferred speaker feature which allows you to say, "Alex, play _____" and it plays through the preferred speaker I set up - my Sonos speakers. Now I have to say, "Alexa, play ____ in the living room" to make it play through the living room Sonos unit. It's supposed to automatically play through the preferred speaker without having to call it by name at the end of the command. Since this functionality was added a few months back, it has always worked perfectly. After the latest Sonos update, it does not. Now, it plays music through the Alexa device unless you tell it to play through a different speaker (Sonos). This was a nice addition when they added it, and I can't figure out why it's not working now.
So I would submit a diagnostic. You could try logging out of the Alexa app, but I'm doubtful that will fix the issue.
Working fine for me. Anything changed in your network? Alexa may need to refresh the connections.
Working fine for me also.
Badge +2
This functionality stopped working since the 10.1 update a month ago. It's fine if you don't change anything in an existing group however if for any reason you re-discover devices you can no longer set a Sonos device as the Alexa enabled device in a group and therefore have to specify room name + lights, more information here

https://en.community.sonos.com/smart-home-integrations-229108/10-1-broken-alexa-groups-6822701
In the Alexa app, I have groups set up so I can use the preferred speaker feature which allows you to say, "Alex, play _____" and it plays through the preferred speaker I set up - my Sonos speakers. Now I have to say, "Alexa, play ____ in the living room" to make it play through the living room Sonos unit. It's supposed to automatically play through the preferred speaker without having to call it by name at the end of the command. Since this functionality was added a few months back, it has always worked perfectly. After the latest Sonos update, it does not. Now, it plays music through the Alexa device unless you tell it to play through a different speaker (Sonos). This was a nice addition when they added it, and I can't figure out why it's not working now.You perhaps need to “enable” the Alexa group with the device that you are speaking to, aswell as ‘preferring’ the speakers you wish to use. It’s definitely working here for me, as mentioned by others in this thread.
Well, magically, it started working again just fine. I made no changes, and it just started working again. Interestingly enough, I got an email from Sonos (in the app) explaining this "new" functionality yesterday, even though I've been using it for months. Something was definitely up with the update. All is OK now. Thanks for the replies.
Well, magically, it started working again just fine. I made no changes, and it just started working again. Interestingly enough, I got an email from Sonos (in the app) explaining this "new" functionality yesterday, even though I've been using it for months. Something was definitely up with the update. All is OK now. Thanks for the replies. Ah that’s good news.? thanks for the update, we just need to now get mark@scan sorted with his Groups and all will be well.
Preferred speaker has broken for me also - much more than 3 months ago. I can’t say is was due to an update or not. I have delete the Group and recreated. I removed the Sonos app and restored. I have rebooted the Echo Dot and the Sonos. I did not delete / reinstall Alexa app on my phone. Suggestions?
-A2
Preferred speaker has broken for me also - much more than 3 months ago. I can’t say is was due to an update or not. I have delete the Group and recreated. I removed the Sonos app and restored. I have rebooted the Echo Dot and the Sonos. I did not delete / reinstall Alexa app on my phone. Suggestions?
-A2

Can you perhaps post a screenshot of your 'Alexa enabled group' and your Amazon devices list and I will see if I can maybe assist.
Attached pics show the “Bedroom” is a Sonos device and “Bedroom” is a group with Bedroom as the preferred speaker. OK not real creative, but it had worked wonderfully in the past. Thanks

for any suggestions you might have.
-A2
A_Squared

You need to go onto set your Echo Dot (whatever that is called) to 'enable' /'control' the Bedroom Group in the Alexa App .. it’s missing from the top part of the group.

Hope that assists.
Ken,
Bingo! So much for not reading the instructions beforehand. Thank you for straightening me out.
-A2
Ken,
Bingo! So much for not reading the instructions beforehand. Thank you for straightening me out.
-A2

Good to hear your all sorted a2.
Badge +2
I've had this problem numerous times (every time there is a SONOS/Alexa update) and it either sorts itself out or I have to disable/delete/reinstall etc... to get it working. I've spent nearly an hour today trying to get Alexa groups and SONOS to play nicely and managed to get 5 out of 6 SONOS speakers working as preferred speakers but one speaker refuses to become a preferred speaker and I can't be bothered to spend more time on it.

But I'm really getting fed up of having to do this and my days of buying SONOS are over (just deleted the SONOS Move from my xmas list). I will either replace everything with Amazon speakers (I'm not an audiophile so the quality is more than good enough for me) or Bose as I already have some of their stuff.
mvosloo,

I think your matter could likely be easily resolved by adding your Sonos devices IP addresses to your routers DHCP Reservation table.

Hope that works for you.
Badge +2
mvosloo,

I think your matter could likely be easily resolved by adding your Sonos devices IP addresses to your routers DHCP Reservation table.

Hope that works for you.


Thanks. I had that suggestion from someone else so I have just set that up - but I think I have tried that before with no success. I'll let you know if it works this time.

But for a lot of people IP address and DCHP Reservation tables might as well be a foreign language and it shouldn't need this level of knowledge to work. Prior to Alexa groups, this was never an issue which sort of points to Alexa as the cause of the problem, but its the SONOS updates that always break groups.
Yes, I guess you can say the same about a lot of technology, but a little bit of reading, or maybe watching a YouTube video these days, can soon solve a lot of things.

Reserving an IP address for a local network device is not exactly rocket science and most router manuals can often explain it quite easily, in one, or two pages. A bit like reserving the same table at a restaurant, the device is simply given the same network address so that it stays put and is easy to find.
Badge +2
Yes, I guess you can say the same about a lot of technology, but a little bit of reading, or maybe watching a YouTube video these days, can soon solve a lot of things.

Reserving an IP address for a local network device is not exactly rocket science and most router manuals can often explain it quite easily, in one, or two pages. A bit like reserving the same table at a restaurant, the device is simply given the same network address so that it stays put and is easy to find.


I think you over estimate most people's ability or patience..... My wife wouldn't have a clue how to do any of this and would have no interest or inclination to find out how to - as she said, she would just use the Bose even though she knows how to use the SONOS app.

And I'm reasonably tech savvy but have never had to fix IP addresses before. My understanding is that you have to set the static IP address on the device outside of the IP range on your router - but the SONOS app and desktop software don't allow you to set an IP address. So I have assigned a fixed IP address on my BT Smart Hub and rebooted.

But having done this I realised that I should have probably assigned a fixed IP address outside of my hub's normal range eg 192.168.1.63 and powered off the SONOS devices first before rebooting the router? But I can't do that now because I can't access my router after rebooting it...

So you see even for someone who started using computers when the x86 was state-of-the-art, built my own computers and is an early adopter, I'm struggling a little bit...

EDIT - from what I have found, The BT Smart Hub is fairly 'sticky' in allocating IP addresses and tends to match the same address to the same MAC every time. Not sure how true this is.
I just set mine starting with the Sonos Boost set at 192.168.7.200 and the rest I then set in sequence 201, 202, 203 etc... I have 21 Sonos devices in all, so it takes me longer than most to set things up, but once done then that’s it and I “back-up” (export) the router settings to a protected file, just in case I have to ever reset the device and that saves me ever having to do it again, well until I decide to upgrade the router, that is.

I found reserving the addresses has sorted a good many issues with Sonos updates.

My wife perhaps would not have an interest to do these things either, but then again I wouldn’t have a clue to do some of the things that she does with sewing machines, or washing machines, etc, well not without reading their manual, at least.

It’s a case though if say a sewing machine wasn’t working correctly for me, I would at least try to read and find out some of the answers for myself first, before complaining, or giving up on it. I don’t think I would let it defeat me, particularly if other users were telling me that their sewing machines were working okay for them.

My Sonos devices, with Alexa groups, are certainly working okay here for me with the latest App updates.
Badge +2
It's taken 2 days but.....

Unfortunately BT Smart Hub 2 is very tempermental about setting 'reserved' IP addresses. I managed to move 5 out of 7 devices out of the server address range but 2 remained stubbornly within and 1 still wants to stay with DHCP.

To do even this I had to make the SONOS network wireless (previously the SONOS Beam was wired so the whole network was wired).

I set up everything again in Alexa (deleted relevant groups, set up groups again with no SONOS devices, deleted all SONOS devices (except SONOS Beam which won't let you delete it), deleted SONOS skill, enabled SONOS skill, added speakers, set preferred speakers etc etc numerous times

I also renamed all the speakers again just in case.

Along the way, speakers got lost, reappeared and generally misbehaved

However, this didn't seem to solve the problem....

I did once manage to get things working but it all fell apart again, but what I did notice is that it fell apart after I said 'Alexa, play BBC Radio 2 in the living room' - and you have to say 'in the living room' as otherwise Alexa uses the BBC skill and plays BBC Radio 2 on the Amazon device instead of the preferred speakers (stupid but you can't change it apparently).

This made me wonder... So I renamed the Alexa group 'Living Room' to 'Sitting Room' and suddenly it all started working as it should. I wonder if there is a legacy issue when I had lots of smart devices named or categorised as 'Living Room' from pre-Alexa groups...

Anyway it works for now although no doubt it will probably fall apart again tomorrow. I will let you know.
mvosloo,

Firstly, I’m really pleased to hear you have now got things sorted and I’m sure you have learned a lot and gained some great experience along the way as to how the Alexa Groups and Sonos work together,

I personally found a good “rule of thumb” with my own Alexa 'enabled' groups for my own setup...and that was, if there is just one Sonos Room held in an Alexa Group, it can have the same name as the Group... so a 'Kitchen' stereo pair, can be in a group also called 'Kitchen' and will often work fine, but it also may depend on the names of other smart-home devices (lights/plugs etc.) in the same group.

But ...

Wherever I have two (or more) “Sonos Rooms” in the same 'physical' room in our home, then I found it it was best to give all 'unique' names. So my Alexa 'Lounge' Group, which has 4 sets of Sonos Rooms (in the same physical room), just as an example, are each differently named as follows:
  • Media Room
  • Family Room
  • Fireplace
  • Portable
That “unique naming” for multiple devices, has always worked well here for me and this is just one example of many such multiple Groups around our home

I’m having a preferred speaker glitch which I think is the fault of the Echo/Alexa not Sonos.

 

Saying, ‘Alexa, play [music]’ works fine, the Echo device [Dot or Show] plays on the preferred speaker [sonos] in that room [Kitchen or Lounge].

 

But if you say ‘Alexa, play [music] everywhere’, the preferred speaker is not chosen and music plays directly from the Echo Dot in the Lounge (not the Sonos system setup as preferred). But still plays from the Sonos system in the Kitchen (not from the Echo Show).

 

So it would seem to be setup correctly but the preferred speaker is bypassed by using the Alexa Multi-Room speaker group.

I’m having a preferred speaker glitch which I think is the fault of the Echo/Alexa not Sonos.

 

Saying, ‘Alexa, play [music]’ works fine, the Echo device [Dot or Show] plays on the preferred speaker [sonos] in that room [Kitchen or Lounge].

 

But if you say ‘Alexa, play [music] everywhere’, the preferred speaker is not chosen and music plays directly from the Echo Dot in the Lounge (not the Sonos system setup as preferred). But still plays from the Sonos system in the Kitchen (not from the Echo Show).

 

So it would seem to be setup correctly but the preferred speaker is bypassed by using the Alexa Multi-Room speaker group.

I think that is working as designed as the ‘everywhere’ part of the Alexa instruction is a keyword for Echo devices. You could get around this by creating an ‘Everywhere on Sonos’ Alexa group and add all your Sonos speakers to that group as ‘preferred’ and then say “Alexa, Play Music Everywhere on Sonos”. I think that will solve the matter and Music will play to all Sonos speakers instead.. (hopefully 🤞).

Reply