No multi tasking - Sonos Beam and Amazon Alexa

  • 13 February 2023
  • 2 replies

My Beam Gen 2 cannot seem to process more than one command without staying quiet for a while…If I ask it to turn on the tv it does then ask it to turn on the lights it does but it will not accept an immediate third command and stays quiet for some time….then the sound comes back to normal and the beam is ready to accept a new command. Anyone else have this issue


Best answer by Corry P 14 February 2023, 10:58

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7
Badge +18

Hi @Jim.h 

Welcome to the Sonos Community!

I was unable to reproduce this behaviour on my Sonos One, so I asked a colleague with a Beam to try and they were also unable to reproduce the behaviour you describe.

If you haven’t rebooted the Beam by unplugging if from power for a few moments, I recommend trying it.

Failing that, you could try removing Alexa from the Beam and adding it again:

Using the Sonos app for iOS or Android:

  • From the Settings tab, press Services & Voice.
  • Under Voice, press the voice service you wish to remove.
  • Press the Sonos product that’s using the voice service, then press Remove.

I hope this helps.

Hi Cory and thanks for your response. I had previously tried removing and then reactivating voice services but that didn’t seem to make a difference…tried a soft reset but still had the same issue. 
I cancelled Alexa follow up Mode and I think there is an improvement……perhaps Alexa was waiting for new instructions.

Thanks again