Answered

"Here is Spotify on Sonos. Sorry on Sonos is offline."

  • 28 August 2019
  • 1 reply
  • 122 views

I have an Echo Dot and two Sonos Play:1s, all registered to me, my apps and my phone, all online, same wifi, etc. I have a 'Living Room' group in Alexa.app with "Kitchen Echo Dot" and "Sonos" in it. Sonos is set as default music speaker in Alexa.app and the Sonos Skill is enabled.

The problem is when I say "Alexa Play Spotify" I get "Here is Spotify on Sonos. Sorry on Sonos is offline." I can play Spotify on the Sonos using Spotify Connect or the Sonos app, but can't get Alexa to control it. Help?

icon

Best answer by Ryan S 28 August 2019, 21:11

Hi Dozens, if you open the Sonos app, is the name of the speaker in there just "Sonos"? Can you try changing it to something else under Settings > Room Settings, and then ask Alexa to discover devices?

Are you able to use any other Alexa commands to Sonos? When you have music playing, can you pause, skip or even change the volume?
View original

1 reply

Userlevel 7
Badge +26
Hi Dozens, if you open the Sonos app, is the name of the speaker in there just "Sonos"? Can you try changing it to something else under Settings > Room Settings, and then ask Alexa to discover devices?

Are you able to use any other Alexa commands to Sonos? When you have music playing, can you pause, skip or even change the volume?

Reply