Question

Error discovering devices in Alexa app

  • 23 October 2017
  • 23 replies
  • 23272 views

Hi,

As part of trying to resolve issues I was having getting Alexa to play my flash briefing, I de-registered all my Sonos devices with Amazon. Unfortunately, Alexa now can't "discover" the devices with the Sonos smart home skill. I get the helpful message "There was an error discovering your devices". I've tried:
- disabling/enabling the Sonos skill.
- re-installing the Alexa app.
- cycling the power on all sonos devices.

Nothing works, my devices cannot be discovered and I can't control anything with Alexa. Control of the speakers through the Sonos app works as normal.

Any help to get everything working would be much appreciated.

Thanks!

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

23 replies

After a lot of messing around I worked out how to fix this. In case anyone else is having the same problem, here's how to resolve it.

- Open your Sonos app.
- Go to Settings/Rooms.
- Click on "Amazon Alexa" under "Voice Services".
- Click on "Remove Amazon Alexa from this room".
- Use the options under "Voice Services" to re-add Alexa to the room.

That should fix it. Hope this saves somebody the couple of hours of farting around in the Alexa and Sonos apps that it took me to find a solution. 😉
thanks - this is helpful. however, not sure which app you're talking about (as i'm having trouble finding these settings)? desktop app? ios? android? thanks for any assistance. alexa finds my speakers (play 1) but not my connects or connect amp.
I was using the IOS app. The setting is under Settings - Rooms - . Here's a screenshot of the settings for my kitchen. You can see the Alexa option at the top.

Userlevel 4
Badge +13
After a lot of messing around I worked out how to fix this. In case anyone else is having the same problem, here's how to resolve it.

- Open your Sonos app.
- Go to Settings/Rooms.
- Click on "Amazon Alexa" under "Voice Services".
- Click on "Remove Amazon Alexa from this room".
- Use the options under "Voice Services" to re-add Alexa to the room.

That should fix it. Hope this saves somebody the couple of hours of farting around in the Alexa and Sonos apps that it took me to find a solution. ;)


On my iPad, followed the above, but in Settings / Rooms only get my three rooms listed. Nothing else! Where is Voice Services and then Amazon Alexa? Selecting a particular room doesn’t bring them up! So where are they please?
Userlevel 4
Badge +13
[quote=biffta]After a lot of messing around I worked out how to fix this. In case anyone else is having the same problem, here's how to resolve it.

- Open your Sonos app.
- Go to Settings/Rooms.
- Click on "Amazon Alexa" under "Voice Services".
- Click on "Remove Amazon Alexa from this room".
- Use the options under "Voice Services" to re-add Alexa to the room.

That should fix it. Hope this saves somebody the couple of hours of farting around in the Alexa and Sonos apps that it took me to find a solution. ;)


On my iPad, followed the above, but in Settings / Rooms only get my three rooms listed. Nothing else! Where is Voice Services and then Amazon Alexa? Selecting a particular room doesn’t bring them up! So where are they please?
Also in my Alexa App all my rooms have been discovered and are listed. In settings however, although the three rooms are listed, when I select any one of them a message flashes up at the top “Ooops something went wrong, please try again”
This is the same message I am now constantly getting from my Dot when I try to play through any of my devices.
I just don’t know what’s going on or why?
Anyone?
Click on one of the rooms. You should see the option at the top then.
I have tried what has been advised with no success very disappoint with this and think only solution is to return my new Sonos One and get my money back! Very poor of sonas:?
I am having the same problem. I am getting an error when discovering devices and no devices are discovered I have 6 sonos speakers including the brand new Sonos One. I have tried uninstalling everything. Removing Alexa in the sonos app as mentioned above and no luck what so ever. If anyone has run into this I would love some help too!
I am having the same problem. I am getting an error when discovering devices and no devices are discovered I have 6 sonos speakers including the brand new Sonos One. I have tried uninstalling everything. Removing Alexa in the sonos app as mentioned above and no luck what so ever. If anyone has run into this I would love some help too!
I am having the same problem. I am getting an error when discovering devices and no devices are discovered I have 6 sonos speakers including the brand new Sonos One. I have tried uninstalling everything. Removing Alexa in the sonos app as mentioned above and no luck what so ever. If anyone has run into this I would love some help too!

Me too... I'm dead in the water and my patience has worn thin.
Userlevel 7
Badge +20
Hi

Just to confirm this setting is only available within iOS and the Android app (not PC). If you select 'Settings' then your Sonos 1 you should see voice services in the top of your screen.

If this doesn't work leave the voice service removed and select 'Add a player or sub' and add the Sonos 1 again. It's worth the effort 🙂
I finally sorted things out by completely deleting the Alexa App off of the iphone. Had to do this process twice before the Alexa app would properly "discover devices". So, not only do I have Sonos going finally, but also my Smartthings hub, and hue lights. All, being controlled through the Sonos One. Not an easy process, but the end result can be achieved! Wish I could index and ask to play from my local storage... oh well.
Userlevel 7
Badge +26
Glad you're all set, dhansel. If anyone is still having trouble, I'd recommend that you give us a call on our support line. We're happy to help you get your Sonos One's all set up or discover other devices that are missing.

If you're unable to find any device, we've seen some trouble if you have multiple Amazon accounts and you're signed in with the wrong one on your mobile device in a different app, compared with what you're using on the Sonos side of things.
Good point Ryan, I think I may have compounded my install issues in the beginning by inadvertently using my wife's amazon account on the Alexa side and my account on the Sonos side.
Userlevel 1
Badge
After a lot of messing around I worked out how to fix this. In case anyone else is having the same problem, here's how to resolve it.

- Open your Sonos app.
- Go to Settings/Rooms.
- Click on "Amazon Alexa" under "Voice Services".
- Click on "Remove Amazon Alexa from this room".
- Use the options under "Voice Services" to re-add Alexa to the room.

That should fix it. Hope this saves somebody the couple of hours of farting around in the Alexa and Sonos apps that it took me to find a solution. ;)


So curious, can you actually get flash briefing? All three of my Ones just say "Flash briefing is not supported on this device"
I am not able to get flash briefing as of last night either..Odd, since I didn't t think this had anything to do with Sonos per se.
I had the same problem with Alex being unable to discover my Sonos One. This meant that Alexa "worked" (for time, weather, etc.) but it couldn't play any music. It kept telling me to enable the Sonos skill in the Alexa app.

It turns out that I had the Sonos account under my name but the Alexa app on my iPhone was signed on to Amazon under my wife's name.

I deleted the Alexa app, reinstalled it and signed in using my own Amazon account. After that, Alexa was able to discover my Sonos One and I'm now able to play music through Alexa.
@jlee 's suggestion to delete the Alexa app and reinstall it fixed it for me! However I didn't have the same confusion between accounts, only one Sonos account and only one Amazon account.
Userlevel 7
Badge +20
The advice here was helpful -- thanks.

I also had a naming issue, as discussed in:
https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-showing-as-two-devices-in-alexa-app-6792846

Up and running now without _too_ much messing about.
Userlevel 2
Guys, was having the same problem not being able to discover sonos device from alexa app... I have somehow resolved it by redo the adding echo dot setup procedure...

The problem could be due to echo device is connecting to a different witeless network from your sonos device.

After setting the echo dot again... all are good. Discovering all Sonos device in all different rooms just in seconds.

Hope this helps... good luck!

Kim.
Awesome solution. Thanks for the help!!!!
I had the same frustrating issue. I resolved this by disabling the Sonos skill in the Alexa app (iOS), then re-enabling. This forces me to reconnect my accounts (password etc) but it did the trick 100%.
Eventually this worked for me too! I disabled the Sonos skill then reenabled and all works just fine. Thank you for the suggestion.