Answered

Ducking not entirely working yet?


Userlevel 1
Badge +2

So as I understand the new ducking possibilies which rolled out some months ago, all speakers within an Alexa group should duck.

I have the following speakers:

  • 1x Play One SL stereo pair
  • 1x Play:5 stereo pair
  • 1x Play One
  • 1x Echo Dot 2nd Gen

All three Sonos are in a group, and also selected as “Preferred Speaker”

The Sonos One and the Echo Dot are selected as Alexa enabled devices.

 

When I talk to the Dot all speakers duck, when I talk to the Sonos One only the Sonos One ducks?

That does not seem right. Due to another bug i have undergone a full factory reset of all speakers, so it probably is an issue everyone is having? Can anyone confirm?

icon

Best answer by Ryan S 2 May 2020, 03:11

Just to update you, the expected behavior is as I mentioned, that the One should cause the other devices to drop in volume as well. Seems there’s a bug preventing that from happening correctly and the team is looking into it now. I’ll let you know when I hear more.

View original

41 replies

Userlevel 1
Badge +2

So nobody else has this issue?

Is the Sonos One and Echo Dot in the same room, both with mics on?  Perhaps the logic that determines which device hears you and processes the request overrrides ducking?  What happens if you turn off the mic on the Sonos One...will it duck then?

 

I have a room with a echo show and a beam, where the beam is the preferred speaker...but the beam mic is always off and it always ducks.

Userlevel 1
Badge +2

Is the Sonos One and Echo Dot in the same room, both with mics on?  Perhaps the logic that determines which device hears you and processes the request overrrides ducking?  What happens if you turn off the mic on the Sonos One...will it duck then?

 

I have a room with a echo show and a beam, where the beam is the preferred speaker...but the beam mic is always off and it always ducks.

When I disable the mic on the DOT the One will listen, nothing ducks then.

When I disable the mic on the One the DOT will listen, all speakers in the group duck then.

 

What happens when you mute your show and speak to the beam, will the Show duck?

When I disable the mic on the One the DOT will listen, all speakers in the group duck then.

 

What is there about this that doesn’t achieve what you want?  (I am just trying to understand the exact setup and requirement.)

Userlevel 1
Badge +2

The issue is that the Sonos speakers inside an Alexa group should reduce the volume when talking to the Sonos One (with Alexa). This does not happen, while it does when using an Amazon Echo Dot.

 

It has been communicated that it should work, but a reset or any other ways to solve this does not make it funcion as advertised. So I am wondering if this is a general bug or limited to me.

But I am trying to understand what it is in practice that makes this a problem.  If they are all in the same physical room why do you need two devices to hear you?  Leaving aside the theoretical considerations of whether or not it should do it, what about this is giving you a practical issue?

 

Userlevel 1
Badge +2

But I am trying to understand what it is in practice that makes this a problem.  If they are all in the same physical room why do you need two devices to hear you?  Leaving aside the theoretical considerations of whether or not it should do it, what about this is giving you a practical issue?

 

Oh this is a misunderstanding. I am using the Echo Dot additionally because the ducking functionality does not work with the Sonos One. So I have muted the microphones on the Sonos Ones for now. The issue occurs too if i entirely remove the Echo Dot from the group. I was just mentioning it to make clear that the issue is not the configuration I use in the Alexa app, since the Echo dot and the Sonos One are configured the same there, and not any other issues preventing the other speakers from ducking.

 

Unrelated but answering you question: Apart from that, a use for two Alexa enabled devices would be a better chance that one speaker hears you.

Here is what I think you can do.  In either case, all Sonos speakers will duck.

Either:

Setup 1 - single Alexa group

Sonos One (your only Alexa-enabled Sonos device) is the controlling device, obviously with mic switched on and Alexa enabled in the Sonos app.

In the same group you have the One SLs and the Play:5

The preferred speakers are the One, One SLs and Play:5

There is no role for the Dot here.

OR

Setup 2 - single Alexa group

Controlling device is the Dot

All Sonos speakers are in the group, and all are preferred speakers.  The Sonos One has mic off (or possibly needs to have Alexa removed in the Sonos app)

Do you believe anything else has been promised?  

What do you mean by ‘the ducking functionality does not work with the Sonos One’?

Here’s a third option.  Single Alexa group.

Alexa-Enabled device - echo dot, Sonos One

Devices (for ducking) - One, One SL,  Play:5

Preferred Speaker - One, One SL,  Play:5

Then go to the settings for the echo dot specifically under ‘CONNECTED DEVICES’, change the Speaker.  Under WI_FI SPEAKERS, select your Sonos One (Preferred Speaker). This setting will mean that all Alexa responses that your dot hears will come from the Sonos One. 

If you’re Sonos One is doing all the talking, then it is ducking by default.  I’ve done some testing with this feature, but not really to resolve the issue you’re looking to address.  It may end up causing other issues, not sure. I also know that for echo show, you can’t have another speaker do it’s speaking for it, presumably because it can’t sync video.  It may also be that you need to create 2 Alexa groups, one for the echo dot as the enabled device and one with the One as the enabled device.

 

As far as changing the feature so that the Sonos One can both listen and receive duck commands at the same time...I don’t know if that’s really a bug and something that can be fixed, or something that’s necessary for other features to work properly.  

Having done a few experiments I am not convinced my ‘Setup 1’ does work as described.  At the moment it is only ducking the Alexa-enables speaker that is the control device.

Setup 2 works as described on my system.

Userlevel 1
Badge +2

Here is what I think you can do.  In either case, all Sonos speakers will duck.

Either:

Setup 1 - single Alexa group

Sonos One (your only Alexa-enabled Sonos device) is the controlling device, obviously with mic switched on and Alexa enabled in the Sonos app.

In the same group you have the One SLs and the Play:5

The preferred speakers are the One, One SLs and Play:5

There is no role for the Dot here.

OR

Setup 2 - single Alexa group

Controlling device is the Dot

All Sonos speakers are in the group, and all are preferred speakers.  The Sonos One has mic off (or possibly needs to have Alexa removed in the Sonos app)

Do you believe anything else has been promised?  

What do you mean by ‘the ducking functionality does not work with the Sonos One’?

 

Setup 1:

Configured exactly as you wrote it, result when you speak to the One:

Sonos One ducks, Play:5s and OneSLs do NOT!

Setup 2:

Configured as you write, result when you talk to the Dot:

All speakers, One/SL/Play:5 duck

 

Here’s a third option.  Single Alexa group.

Alexa-Enabled device - echo dot, Sonos One

Devices (for ducking) - One, One SL,  Play:5

Preferred Speaker - One, One SL,  Play:5

Then go to the settings for the echo dot specifically under ‘CONNECTED DEVICES’, change the Speaker.  Under WI_FI SPEAKERS, select your Sonos One (Preferred Speaker). This setting will mean that all Alexa responses that your dot hears will come from the Sonos One. 

If you’re Sonos One is doing all the talking, then it is ducking by default.  I’ve done some testing with this feature, but not really to resolve the issue you’re looking to address.  It may end up causing other issues, not sure. I also know that for echo show, you can’t have another speaker do it’s speaking for it, presumably because it can’t sync video.  It may also be that you need to create 2 Alexa groups, one for the echo dot as the enabled device and one with the One as the enabled device.

 

As far as changing the feature so that the Sonos One can both listen and receive duck commands at the same time...I don’t know if that’s really a bug and something that can be fixed, or something that’s necessary for other features to work properly.  

This is the setup I currently have. However, when the Sonos One is receiving the mic input the One SL and Play:5 do not duck, despite being configured exactly as you wrote. The Sonos One does duck in all configurations, no matter if you talk to the Sonos One or the Echo Dot.

 

I think there is either a bug, or some weird configuration issue which can not be cleared by a factory reset?

 

Userlevel 1
Badge +2

Having done a few experiments I am not convinced my ‘Setup 1’ does work as described.  At the moment it is only ducking the Alexa-enables speaker that is the control device.

Setup 2 works as described on my system.

Okay so you’ve posted while I was writing the answer to your previous post.

That actually confirms my expectations.

This would all come down to the following issue:

Non Alexa enabled Sonos speakers do NOT duck when the user talks to an Alexa enabled Sonos speaker, even if they are placed in the same group.

 

Is that what you observed? I unfortunately can not test this with a Beam.

Userlevel 1
Badge +2

Okay, so i’ve done some more test including two Sonos One inside a group.

If I talk to either one, the other one won’t duck.

 

My guess would be: Sonos Alexa enabled speakers so not send out the ducking command at all? Could that be? I’d be very surprised, that would affect many people.

I would be very surprised if the Beam and Sonos One behaved differently.  

I can only comment on how my own system works, because I can’t be sure I have set it up correctly.  But yes, on my system it is true that when I speak the wake word to my Alexa-enabled Sonos device, the non-Alexa Sonos speakers in the same group do not duck.

I am not sure if Sonos has stated otherwise.  I found this article that seems to confirm that this is how it is (or was in early 2019).

https://www.the-ambient.com/how-to/sonos-speakers-amazon-echo-ducking-volume-mute-issue-1211

Okay, so i’ve done some more test including two Sonos One inside a group.

If I talk to either one, the other one won’t duck.

 

My guess would be: Sonos Alexa enabled speakers so not send out the ducking command at all? Could that be? I’d be very surprised, that would affect many people.

 

No, my Beam ducks just fine.  Again, I have it’s mic off typically.  But just tried it with mic own.  Still ducked. I don’t know it if it was ducking because it was listening (although it didn’t respond, my echo Show did) or because it received a ducking command.  Taking a look at the Alexa group, the Show and Beam are listed as Alexa devices, The Beam is the preferred speaker.  I don’t even have the Beam listed as a smart device...which I thought was what made a speaker duck.

Incidentally, Sonos factory resets never cure anything, and Sonos recommends against trying them for troubleshooting.

Userlevel 1
Badge +2

Okay, so i’ve done some more test including two Sonos One inside a group.

If I talk to either one, the other one won’t duck.

 

My guess would be: Sonos Alexa enabled speakers so not send out the ducking command at all? Could that be? I’d be very surprised, that would affect many people.

 

No, my Beam ducks just fine.  Again, I have it’s mic off typically.  But just tried it with mic own.  Still ducked. I don’t know it if it was ducking because it was listening (although it didn’t respond, my echo Show did) or because it received a ducking command.  Taking a look at the Alexa group, the Show and Beam are listed as Alexa devices, The Beam is the preferred speaker.  I don’t even have the Beam listed as a smart device...which I thought was what made a speaker duck.


The issue is a different one. When you speak to the beam, other Sonos speakers in that group won’t duck. For example your rears. The device you talk to always ducks as it seems.

Okay, so i’ve done some more test including two Sonos One inside a group.

If I talk to either one, the other one won’t duck.

 

My guess would be: Sonos Alexa enabled speakers so not send out the ducking command at all? Could that be? I’d be very surprised, that would affect many people.

 

No, my Beam ducks just fine.  Again, I have it’s mic off typically.  But just tried it with mic own.  Still ducked. I don’t know it if it was ducking because it was listening (although it didn’t respond, my echo Show did) or because it received a ducking command.  Taking a look at the Alexa group, the Show and Beam are listed as Alexa devices, The Beam is the preferred speaker.  I don’t even have the Beam listed as a smart device...which I thought was what made a speaker duck.

But if its mic is off it isn’t acting as the controller for the group - that’s not the situation we are talking about, unless I am misunderstanding something.

Userlevel 1
Badge +2

Incidentally, Sonos factory resets never cure anything, and Sonos recommends against trying them for troubleshooting.


I can tell you this is actually wrong. I had an issue where Sonos speakers were not able to skip songs anymore last week. The factory reset did really work. You can read it up in the thread from last week.

 

Regarding the article you posted. @Ryan S posted a while later here, that a change was made:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-echo-dot-group-ducking-6830792

From https://support.sonos.com/s/article/3169?language=en_US

 

To me it sounds that what we two just tried to do should work?

Userlevel 1
Badge +2

@melvimbe 

I suspect you can reproduce it like this:

  • Put the Show and the Beam into a group, both as controllers
  • Set the Show as preferred speaker
  • Mute the Shows mic and activate the Beams mic
  • Start music on the Show
  • Speak to the Beam, if we are right the Show won’t lower the volume, but it kinda should….

Incidentally, Sonos factory resets never cure anything, and Sonos recommends against trying them for troubleshooting.


I can tell you this is actually wrong. I had an issue where Sonos speakers were not able to skip songs anymore last week. The factory reset did really work. You can read it up in the thread from last week.

 

Regarding the article you posted. @Ryan S posted a while later here, that a change was made:

https://en.community.sonos.com/amazon-alexa-and-sonos-229102/sonos-one-echo-dot-group-ducking-6830792

From https://support.sonos.com/s/article/3169?language=en_US

 

To me it sounds that what we two just tried to do should work?

Ryan’s comments seem to me to refer to using Amazon devices for control, not Alexa-enabled Sonos devices, so i don’t think anything we have found contradicts what he said.

But I think in the third bullet point above the intended meaning of ‘Alexa-enabled device’ is ‘Amazon device’, because it is contrasted with ‘Sonos devices’.  But that is not what it strictly says.

 

Userlevel 1
Badge +2

Ryan’s comments seem to me to refer to using Amazon devices for control, not Alexa-enabled Sonos devices, so i don’t think anything we have found contradicts what he said.

But I think in the third bullet point above the intended meaning of ‘Alexa-enabled device’ is ‘Amazon device’, because it is contrasted with ‘Sonos devices’.

 

I am not sure what you are trying to say. Do you mean they wrote “Alexa-enabled device” but meant “Amazon device” instead?

I was sure I purchased an “Alexa-enabled device” when buying the Sonos One, so I’d expect this feature to work as described in the knowledge base.

@melvimbe

I suspect you can reproduce it like this:

  • Put the Show and the Beam into a group, both as controllers
  • Set the Show as preferred speaker
  • Mute the Shows mic and activate the Beams mic
  • Start music on the Show
  • Speak to the Beam, if we are right the Show won’t lower the volume, but it kinda should….

 

I did a slightly modified test. 

  1. Added a nearby Sonos room (pair of Sonos Ones) to the group (Show, Beam, Ones) - preferred speaker.
  2. Turn off mics on the Show and Ones
  3. Music playing on Beam and Ones
  4. Gave voice command, and the Beam responded, but the Ones did NOT duck.

That seems to confirm what you’re saying.  Sonos devices can receive ducking commands but are not sending them out.

 

Assuming this is actually what’s happening, I can see it as a bug, but also as a low priority feature. The majority of people who have a Sonos speaker (or stereo pair, etc) in a physical room are going to have music play from that speaker only, or at least not at the same time as an echo other Sonos speaker in the same room.  Thus ducking would rarely be needed.

Userlevel 1
Badge +2

@melvimbe

I suspect you can reproduce it like this:

  • Put the Show and the Beam into a group, both as controllers
  • Set the Show as preferred speaker
  • Mute the Shows mic and activate the Beams mic
  • Start music on the Show
  • Speak to the Beam, if we are right the Show won’t lower the volume, but it kinda should….

 

I did a slightly modified test. 

  1. Added a nearby Sonos room (pair of Sonos Ones) to the group (Show, Beam, Ones) - preferred speaker.
  2. Turn off mics on the Show and Ones
  3. Music playing on Beam and Ones
  4. Gave voice command, and the Beam responded, but the Ones did NOT duck.

That seems to confirm what you’re saying.  Sonos devices can receive ducking commands but are not sending them out.

 

Assuming this is actually what’s happening, I can see it as a bug, but also as a low priority feature. The majority of people who have a Sonos speaker (or stereo pair, etc) in a physical room are going to have music play from that speaker only, or at least not at the same time as an echo other Sonos speaker in the same room.  Thus ducking would rarely be needed.

Thanks for your test, at least it’s confirmed now.

Would this not be an issue if you added two One SL as rear speakers to your beam now?
I’d expect them to duck too, but as it seems they won’t?

Thanks for your test, at least it’s confirmed now.

Would this not be an issue if you added two One SL as rear speakers to your beam now?
I’d expect them to duck too, but as it seems they won’t?

 

No, rear speakers are bonded to the Beam and will always do whatever the Beam is doing.So when the Beam ducks, they will as well.  Same for bonded Sub.  I have play:1s as rears and Sub with my Beam, so easily confirm this.

 

However, it’s worth noting that when a Beam (or playbar/playbase/Sonos Amp) is playing TV audio, it will never duck.  I can see where users may not want this, but it would be a nice option.  

Reply