Answered

Can't enable Alexa Skill - you have to register device first to Sonos error

  • 23 January 2024
  • 5 replies
  • 183 views

I was able to link Spotify and Voice Assistant Alexa through the Alexa App.

 

However, I can’t play Spotify through “Alexa, play __ in Spotify”. It will respond, “Ok Playing...”, but then there’ll be nothing playing.

 

I found a Sonos support page to try to disable Sonos Skill in Alexa and then re-enable it again. I tried that, but after click on Enable, I get this error from Sonos API page:

 

Register your speakers

You need to link speakers to your _____ Sonos account before you can add this skill.

 

But I have already linked my speakers to my Sonos account and I can see it on the Sonos app.

 

 

Sonos Era 100

icon

Best answer by kingp0dd 24 January 2024, 03:31

View original

5 replies

Just check that the Sonos App login credentials are the same as those you are using to link the Sonos skill to your Amazon Alexa account. In fact I would logout the Sonos App and then login again just to ensure they are the same credentials …and ensure that your Alexa App is logged into the same Amazon account as the one that you added the Spotify music service to… Also note that the Spotify service must be a ‘subscription’ service rather than the ‘free’ (advertisiments) version to use with Alexa on Sonos devices.

Also just to add the Spotify music service needs to be set as the default music service in the Amazon Alexa App …and the Spotify service (with same login credentials) needs to also be installed in the Sonos App. Check that those credentials are the same in both Apps aswell.

Also just to add the Spotify music service needs to be set as the default music service in the Amazon Alexa App …and the Spotify service (with same login credentials) needs to also be installed in the Sonos App. Check that those credentials are the same in both Apps aswell.

Just check that the Sonos App login credentials are the same as those you are using to link the Sonos skill to your Amazon Alexa account. In fact I would logout the Sonos App and then login again just to ensure they are the same credentials …and ensure that your Alexa App is logged into the same Amazon account as the one that you added the Spotify music service to… Also note that the Spotify service must be a ‘subscription’ service rather than the ‘free’ (advertisiments) version to use with Alexa on Sonos devices.

 

These are the emails used:

Sonos & Amazon - same

Spotify - different

 

I am assuming that it shouldn’t matter?

In my Sonos app:

  • Spotify linked successfuly
  • Voice Assistant Amazon linked successfuly

In Alexa app:
-  Spotify linked successfully

 

So far:

  • I can play Spotify on Sonos through the Sonos app.
  • I can play Spotify on my other devices in Alexa through the Alexa app.
  • I can’t play Spotify on Sonos Era through Alexa app. It says I need to enable Sonos skill. But when I enable it, I get the error  i mentioned in my first post.

@kingp0dd,

In that case it maybe best to reproduce the issue and then immediately submit a Sonos system diagnostic report from within the Sonos App, note it’s reference and then contact/chat with Sonos Support Staff via this LINK and see what the Staff can perhaps suggest to resolve the matter.

I don’t know if this is what fixed it, but I said on the Era 100: “Alexa, discover devices.” Then I was able to use Spotify commands afterwards.

 

 

Reply