Question

Alexa Won't Resume Sonos

  • 31 August 2019
  • 12 replies
  • 523 views

A few days ago, Alexa stopped resuming my Sonos system. I used to be able to say, "Alexa, resume the (Sonos name)," and she would resume that Sonos and all Sonos units grouped with it. Now, nothing happens. I've tried simply saying "Alexa resume," and that works for a short period of time, but if the Sonos has been paused for more than a few minutes, that won't work either. Alexa also no longer tells me what's playing, simply saying, "I don't have information on what's playing on Sonos." The one thing it does still do correctly is pause the music when I say, "Alexa, pause the (Sonos name)," or "Alexa pause." Anyone else having these issues or have a solution?

My configuration: 6 Echo Dots grouped into 4 Alexa groups with 6 Sonos units of various types associated with the different Alexa groups. I group the Sonos units for playback across Alexa groups using the Sonos app.

12 replies

Userlevel 7
Badge +20
As a first step, can you please open the Alexa App>Skills>Your Skills and Disable then Enable the Sonos skill. Please let us know how you get on.
Thanks for the advice, UKMedia! I’ve disabled and re-enabled the skill but am still having issues. Alexa still doesn’t know what’s playing on Sonos, and I’m still having issues with resume.

One *important point* I forgot to include in my original post (and can’t figure out how to add there), is that I primarily stream Pandora, and when this issue first started, Alexa kept resuming the last thing that had been played via Amazon Music - regardless of what was last played on the Sonos. Example: my son asks Alexa to stream something from Amazon Music. Then, I later use the app to stream something from Pandora. If I asked Alexa to pause the Pandora stream and then later asked it resume, it would resume the Amazon Music stream instead of the Pandora stream, which was the last thing played. I tried to get around this by setting the Alexa app to use Pandora as its primary streaming service, and that’s when it just stopped responding to resume commands.
Userlevel 7
Badge +20
Sounds more like a Pandora issue, which I can't help with, sorry as I'm in the UK.
Thanks for trying, UKMedia! I think it's a communication issue between Sonos and Amazon. Today, I'm able to resume the music by saying "Alexa, resume the (Sonos name)," but Alexa still doesn't know what's playing on the Sonos. Hopefully, whatever it is will resolve itself with time and patience. 🙂
Userlevel 7
Badge +20
Sorry for the long post but this type of issue is normally down to one of three things, it's worth trying section 2:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please In the Sonos app, select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
1.4/ In the Alexa app, select the Alexa Icon in the centre of the row of Icons at the bottom of the screen and ask ‘Alexa, Discover Devices’.
1.5/ Here is a link to my naming standards: https://en.community.sonos.com/amazon-alexa-and-sonos-229102/best-practices-for-naming-of-devices-6819283/index1.html

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app, select ‘Devices>All Devices'. Now select each Sonos Device in turn and click the Trash Can in the top right of the screen;
3.3/ In the Sonos app, select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app, select the Alexa Icon in the centre of the row of Icons at the bottom of the screen and ask ‘Alexa, Discover Devices’. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to carry out step 3.8 again.

Let us know how you get on.
Thanks, UKMedia! Since I've got most of the functionality back that I need, I've decided not to play with fire and potentially break something. I've copied this awesome list down, though, and will use it if things degrade again. Thanks so much for all your help!
Userlevel 2
Badge +1
Pause and Resume are fine, but Alexa no longer knows what's playing. Worked fine up to a few days ago.
Hi Tom! My resume issue has resolved, but I'm still having issues with Alexa not knowing what's playing on my Sonos. I've just tested it using Pandora, Amazon Music, and my local music library (on a Mac), and Alexa couldn't tell me what was playing regardless of source. Are you experiencing the same thing, or is your issue specific to a particular source/streaming service? My issues started about a week ago, and the resume feature began functioning again about 2 days ago.
Userlevel 2
Badge +1
Only using my local music, so don't know whether she's as clueless about the other services.

Made sure the files were fully tagged, no characters that could cause problems, music is stored on different drives, used the app from iPhone, Win 10, and an old mac book.
Thanks for the info, Tom. She's still clueless for me, too. May need to start a new thread and see if anyone of import takes notice.
Userlevel 2
Badge +1
The trick seems to be having something playing when I disabled then re-enabled the skill from the Alexa app. Now the songs are announced fine.

I’m having the same issue. 
 

What I’d like is the ability to pause and resume playback, just like I had pressed the pause/play on any of my Sonos speakers. 

Reply