Answered

Alexa Won't Play Music

  • 2 February 2019
  • 8 replies
  • 9857 views

Starting roughly Dec '18, Alexa stopped playing music on my Sonos One. It acknowledges that it's going to play music, but then nothing; silence. I've logged out of Amazon on all account and on the web, and I've removed Alexa from the Sonos app, then reinstalled and logged in, but that didn't work. Today, I logged out of Amazon on all devices and the web, uninstalled both the Sonos and Alexa apps on both of my devices, and factory reset my Sonos One; still the same issue exists. I used to play Amazon music, but I also tried adding iHeartRadio, but Alexa still acknowledges the request but doesn't play music.

I'm getting so frustrated that this is an issue in the first place, and that it's so difficult to come up with a solution. I'd greatly appreciate any advice I can get to get Alexa playing music again.
icon

Best answer by UKMedia 3 February 2019, 10:47

Sorry for the long post but this type of issue is normally down to one of three things:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a Browser (https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the Browser version has this functionality.)
1.4/ Here is a link to my naming standards: https://en.community.sonos.com/amazon-alexa-and-sonos-229102/best-practices-for-naming-of-devices-6819283/index1.html

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (Browser version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app, select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.

Let us know how you get on.
View original

8 replies

Userlevel 7
Badge +20
Sorry for the long post but this type of issue is normally down to one of three things:

1/ Duplicate device names - Alexa prefers that names for Devices, Groups and Scenes are unique,
1.1/ Please open up the Alexa App>Smart Home and make a note of any duplicate device names;
1.2/ You can then change them in the source app. e.g. Use the Sonos App to change the name of Sonos players. (I personally use the naming standard Room Name + Device type. e.g. Kitchen Sonos, Kitchen Echo Dot, Lounge Sonos, etc)
1.3/ Once you have changed any duplicate names then please open the Alexa App on a Browser (https://alexa.amazon.co.uk or https://alexa.amazon.com)>Smart Home>Devices and select 'Forget All' followed by 'Discover'. NOTE: This will remove ALL Actions from ALL Alexa Routines! (Only the Browser version has this functionality.)
1.4/ Here is a link to my naming standards: https://en.community.sonos.com/amazon-alexa-and-sonos-229102/best-practices-for-naming-of-devices-6819283/index1.html

2/ Some form of Account Linking or Authorisation has not completed successfully. There are a number of causes for this and it's best to try these steps 1 at a time and test before moving on to the next step if the problem persists:
2.1/ Open the Alexa App>Skills>Your Skills>Sonos and 'Disable' followed by 'Enable';
2.2/ Ensure that you don't have multiple Amazon accounts logged into different Apps on your device, as this can confuse the Amazon Authorisation. If yes, then please log out of the other accounts and then complete step 2.1 again;
2.3/ If the problem still persists, please logout of all Amazon accounts then select the Alexa App>Skills>Your Skills>Sonos and 'Disable. Now power down all Sonos devices for 10 secs, allowing for any wired devices to boot before booting the remaining Sonos players. Now log back into the Alexa App>Skills>Sonos and 'Enable'

3/ If the problem persists then an entire reset of the Authorisation & Account Linking process is required:
3.1/ In the Alexa app, select Skills>Your Skills>Sonos and then 'Disable';
3.2 In the Alexa app (Browser version), select 'Smart Home>Devices'. Now select 'Forget All' at the bottom of the screen;
3.3/ In the Sonos app (Android or iOS), select Settings>Room Settings and for each of the Sonos One's sign into 'Voice Services' and select 'Remove Amazon Alexa from this Room';
3.4/ If you have any wired Sonos devices, please power down for 10 secs and then switch on and wait for it to boot;
3.5/ Now power down all other Sonos Players for 10 secs then switch them back on and wait for them to boot;
3.6/ In the Sonos app, Select Manage>Add a player or sub' and add the Sonos One's again. This will complete the set-up process again;
3.7/ In the Alexa app, select Skills>Your Skills and ensure the Sonos skill is 'Enabled', if not please 'Enable';
3.8/ In the Alexa app, select Smart Home>Devices>Discover. Ensure that your Sonos One's are displayed correctly and not shown as 'Off Line'.
3.9/ Also check one last time that there are no devices with the same name. Remember, if there is a need to rename any then you'll need to select 'Discover' again.

Let us know how you get on.
Thank you so much for the reply. Your second answer is the trick that did it.
Badge +1
Great instructions for fixing!

It is just a shame that this process is required so frequently.

My main issue is with Spotify not playing via Alexa... i must factory reset my whole system 2-3 times per month! It is totally unacceptable to have to do this so frequently.

It does seem to be less so now I have all speakers connected via sonos web, but randomly it just fails and Alexa does not play Spotify... it can be working the day before and stop working overnight!
Userlevel 7
Badge +20
Great instructions for fixing!

It is just a shame that this process is required so frequently.

My main issue is with Spotify not playing via Alexa... i must factory reset my whole system 2-3 times per month! It is totally unacceptable to have to do this so frequently.

It does seem to be less so now I have all speakers connected via sonos web, but randomly it just fails and Alexa does not play Spotify... it can be working the day before and stop working overnight!


I wonder if this is more due to duplicate IP addresses which can occur if you boot your router. I recommend that Sonos players are always allocated a reserved IP address in your router set-up page. I use the range 192.168.0.200 to 192.168.0.244 for my Sonos devices and haven't had any stability issues for years - let's hope that's not tempting fate! 😉
Badge +1
I will look into this thanks.

Usualky when it goes wrong it seems to be pinpointed to spotify, in brief:

Alexa will call up and play tunein

Alexa will call up but not play spotify

I've started a diary to detail my history!!!
Thank You!!! I got to 2.1 and it worked. Thanks!!!
UK Media, I signed up to the forum just to thank you! OMFG was I frustrated. But your duplicate names suggestion fixed me up!
Userlevel 7
Badge +20
UK Media, I signed up to the forum just to thank you! OMFG was I frustrated. But your duplicate names suggestion fixed me up!
Great news 🙂

Reply