alexa slow to reply on sonos one but fast on echo dot on same network


Hi, I've 2 sonos one, configured in a room. On same network i've 2 echo dot.

Alexa is so sloooooow to respond from sonos one,barely unusable. On amazon echo dot, connected on same wifi is working correctly.

Anyone else has noted this issue or have any suggestion or workaround?

Thanks

3 replies

Yeah I have the same with my Sonos beam ! Soooo slow to respond! I really hope Google is faster whenever they release it !!!!

Anyone know how to fix Alexa?
Badge
I’m having the same issue just over the last week or so. I’ve had the Sonos Ones for over a year and never had this issue. Google mini on same network responds normally. I’ve restarted the Ones and the playbar. Not sure what else to do.
Try unplugging your Sonos One (and any other Sonos device you have), and while they're unplugged, reboot the router. Then plug them back in and test.

That kind of delay is often indicative of wifi interference causing your Sonos (and the associated Echo connection) to not be able to contact the cloud where the Echo commands are processed. You might occasionally hear interruptions in your music, but there's no guaranty on that, as each stream handles delays differently.

My suggestion above would handle a case of duplicate IP addresses, which can happen in your router when the Sonos updates its software. The process forces the router to refresh itself during the reboot, and then the Sonos will ask for a new IP address when you plug it in.

Cookie policy

We use cookies to enhance and personalize your experience. If you accept you agree to our full cookie policy. Learn more about our cookies.

Accept cookies Cookie settings