Answered

Alexa on Sonos: Spotify vs BBC Sounds & Global Player

  • 23 December 2022
  • 6 replies
  • 182 views

Hi

I’ve recently noticed that Alexa will not play music from Spotify despite acknowledging and saying ‘This is … from Spotify’. Also, while Alexa will launch BBC Sounds to play Radio 2, or Global Player to play Heart, and Sleep Sounds, Icannot stop those services with Alexa either.

I have logged out of my Amazon, Sonos and Spotify accounts and back in and disabled the Spotify skill, but to no effect.

What else should I be doing?

Diagnostics report: 638462361

icon

Best answer by Mr. T 1 January 2023, 16:06

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Userlevel 7
Badge +20

Hi

 

Please have a look at my post here.

No dice, I’m afraid. I’ve rebooted the router and Eero mesh system. There was no issue until the last update to the app on 16 December.

Userlevel 7
Badge +20

No dice, I’m afraid. I’ve rebooted the router and Eero mesh system. There was no issue until the last update to the app on 16 December.

Did you also look at the last link: Tips & Tricks - Resolving random issues impacting Sonos devices.. | Sonos Community

Just tried this. Still no dice.

Userlevel 7

You could try the following steps:

  1. In the Sonos app, remove all instances of Alexa from your Sonos system
    • From the Settings tab, press Services & Voice

    • Under Voice, tap Alexa

    • Press the Sonos product that’s using the voice service, then press Remove.

    • Repeat until no Sonos rooms have Alexa
  2. In the Alexa app, find the Sonos skill and disable it
    • More » Skills & Games » Search icon » Sonos » Disable Skill
  3. In the Amazon website, log in to the same account used for Alexa and remove links to Sonos devices
    • go to Account » Devices & Content » Devices. De-register all entries relating to Sonos devices.
  4. In the Sonos app, add Alexa to the rooms you’d like it in. This will remake all the links intentionally broken in steps 1, 2 and 3
    • Tap the Settings tab. select Services & Voice > Under Voice, Add a Voice Assistant > Amazon Alexa

You could try the following steps:

  1. In the Sonos app, remove all instances of Alexa from your Sonos system
    • From the Settings tab, press Services & Voice

    • Under Voice, tap Alexa

    • Press the Sonos product that’s using the voice service, then press Remove.

    • Repeat until no Sonos rooms have Alexa
  2. In the Alexa app, find the Sonos skill and disable it
    • More » Skills & Games » Search icon » Sonos » Disable Skill
  3. In the Amazon website, log in to the same account used for Alexa and remove links to Sonos devices
    • go to Account » Devices & Content » Devices. De-register all entries relating to Sonos devices.
  4. In the Sonos app, add Alexa to the rooms you’d like it in. This will remake all the links intentionally broken in steps 1, 2 and 3
    • Tap the Settings tab. select Services & Voice > Under Voice, Add a Voice Assistant > Amazon Alexa

This seems to have worked. Thanks!