Alexa Not Recognizing Sonos One (Gen 1) Speakers

  • 16 March 2024
  • 26 replies
  • 1353 views

Userlevel 1
Badge

Known bug (on Sonos support page) that with the March 14, 2024 Alexa App and Sonos 1 app updates, Alexa voice does not work on the Sonos One (Gen 1) speakers. When I look at devices in the Alexa app it says my 2 Sonos One speakers are unresponsive and offline. I’ve tried to clean out or log out of all apps to get my Sonos speakers to work with Alexa without success but have further data to support that the latest Alexa app (updated 3/14/2024) is recognizing my Sonos One FIRST Edition speakers as SECOND Edition speakers and that explains why they are not working. See screen shot below of my devices in the Alexa app for that corroboration.

i tried to email this to Sonos (support@sonos.com) but got a reply saying that address is not monitored. A support link for posting was provided but that is the generic support page with phone and chat but no way to submit any info except here. Hence this post to share with Sonos and the community. As mentioned, I have Sonos One GEN 1 (first edition) but Alexa is seeing my speakers as GEN 2 which is why they won’t work any longer.

 

 

Corry P 4 months ago

Hi @SkipperGreg 

We have released an update for S1 that we believe addresses this issue. Please check your system for updates and test. If you continue to see this issue after updating, we recommend you get in touch with our technical support team for assistance.

Thank you for your patience.

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

26 replies

My Sonos One speakers stopped responding the Alexa voice commands on 3-14 or 3-15. The Sonos site has a notice dated 3-15-24 that they have a problem with Alexa voice controls following an update and the are working on a fix with Alexa.

Userlevel 1
Badge

Yes - the screen shot was diagnostic info to help fix the problem since there is no longer any way to get info like this to Sonos other than calling or chatting. Email to support no longer works.

Same with me😫

This is not the first time this has happened. I’ve lost faith in Sonos tech people. Time to change to a better brand speaker.

Userlevel 1
Badge

This is not the first time this has happened. I’ve lost faith in Sonos tech people. Time to change to a better brand speaker.

I’ve been using Sonos for 19 years, have never had a problem, always had good experience with support, and am impressed with the engineering of their tech. The fact that they eliminated their support@sonos.com email address and the link provided to submit a problem didn’t have a form to do so is troubling. Regarding this bug, it may be Amazon Alexis at fault not Sonos. The underlying problem is Alexa’s latest app recognizes gen 1 as gen 2. Maybe that’s on Sonos. I don’t know. But at least Sonos is trying to support old gen 1 tech. Most vendors would force you to upgrade to the latest or lose the features. 

Amazon Alexa doesn’t just upgrade their app as a surprise. There’s testing by third party users, to allow them get on board with the changes. Whether this is Sonos or Amazon to blame doesn’t really matter to me, this is a major disruption my service’s when I rely on voice control for so many smart home services. I now have to look for something more reliable.

I have the same problem.

Is there a fix? I tried the deleting and re adding on both the sonos and amazon side but no luck. 

I’m in Canada. Using the Sonos 1 app.  

Userlevel 1
Badge

I have the same problem.

Is there a fix? I tried the deleting and re adding on both the sonos and amazon side but no luck. 

I’m in Canada. Using the Sonos 1 app.  

Complain to both Amazon and Sonos and wait for them to update the app! It’s in queue but the squeaky wheel gets the grease.

I have the same problem.

Is there a fix? I tried the deleting and re adding on both the sonos and amazon side but no luck. 

I’m in Canada. Using the Sonos 1 app.  

Complain to both Amazon and Sonos and wait for them to update the app! It’s in queue but the squeaky wheel gets the grease.

Greg - Can you share links to complain? Are you suggesting twitter or a support forum, or a ticket? 

My Sonos One speakers stopped responding the Alexa voice commands on 3-14 or 3-15. The Sonos site has a notice dated 3-15-24 that they have a problem with Alexa voice controls following an update and the are working on a fix with Alexa.

where did you see this? 

 

I tried these steps but no luck.

https://support.sonos.com/en-us/article/alexa-commands-not-working-on-sonos

Userlevel 1
Badge

I have the same problem.

Is there a fix? I tried the deleting and re adding on both the sonos and amazon side but no luck. 

I’m in Canada. Using the Sonos 1 app.  

Complain to both Amazon and Sonos and wait for them to update the app! It’s in queue but the squeaky wheel gets the grease.

Greg - Can you share links to complain? Are you suggesting twitter or a support forum, or a ticket? 

For Alexa, I called Amazon support. In the Alexa app, add a device, select speaker, select Sonos. It will fail. Click try again. It will fail again and give you a link to contact support. You can call them and complain. For Sonos, there is no longer any email or web form. But if you go to the Sonos support webpage there is a chat and support telephone number. Sonos used to have a support email address (support@Sonos.com) but you now get a reply saying it’s no longer monitored with a link to “submit information.” That link is the standard Sonos support page and I saw no form, just the phone number and chat. Ugh.

Userlevel 1
Badge

My Sonos One speakers stopped responding the Alexa voice commands on 3-14 or 3-15. The Sonos site has a notice dated 3-15-24 that they have a problem with Alexa voice controls following an update and the are working on a fix with Alexa.

where did you see this? 

 

I tried these steps but no luck.

https://support.sonos.com/en-us/article/alexa-commands-not-working-on-sonos

See my comment below for the Sonos outage notice.

Userlevel 1
Badge

The Sonos notice of Alexa Voice Outage is at the link below:

Sonos Voice Response Outage Notice

The Sonos notice of Alexa Voice Outage is at the link below:

Sonos Voice Response Outage Notice

Thanks, I saw this today also.  So annoying.  It is probably an API certificate signing issue and the person responsible has left the company!   

Userlevel 7
Badge +18

Hi @SkipperGreg 

We have released an update for S1 that we believe addresses this issue. Please check your system for updates and test. If you continue to see this issue after updating, we recommend you get in touch with our technical support team for assistance.

Thank you for your patience.

Not working for me!

Not working for me either.  I just put a second alexa puck by my Sonos One for now.  

Got it working now!

I had to update the Sonos controller 4 times, deregister Alexa devices several times, remove Alexa from Sonos controller 3 more times, rename the devices and eventually the update worked.

First thing you’ll see in Alexa device section is the devices being back online.

My system seemed to resist the update which is definitely glitchy during the process but it eventually gave in and worked,

I hope it works for you.

Confirming that the issue existed, the patch just released (do a proactive update via:  settings system, system updates, check for updates) has been applied today across the s1 network and Alexa has resumed working on the Sonos one speaker. 

Thank you so much for this! Sending sincere thanks from London.

I have version 11.14

Checking for updates tells me 

Your System is up to date 

 

Still no Alexa available

Userlevel 1
Badge

Hi @SkipperGreg 

We have released an update for S1 that we believe addresses this issue. Please check your system for updates and test. If you continue to see this issue after updating, we recommend you get in touch with our technical support team for assistance.

Thank you for your patience.

Yes it is fixed. Thank you.

Userlevel 1
Badge

My Sonos One speakers are fixed (meaning Alexa voice is working again). I didn’t do anything. It just worked today. Neither the Sonos S1 app or the Alexa app were updated so there must have been a Sonos system update last night that implemented the fix as stated above by @Corry P. In viewing my system info, I am running v11.14 build 572151190. I checked updates am up to date. I have a Sonos Connect, 2 ZP100s, and 2 Sonos Ones. Both speakers are voice enabled now. When I go into the ALEXA app I saw that the 2 speakers are now online (in contrast to my screen shot from before today when they were unresponsive or offline as shown above). For some reason the new version since this problem began is creating 2 speakers for each Sonos One as shown in my screen shot in the original post above. One with a speaker icon for the correct room (eg Kitchen) and one saying “Greg’s Sonos One Speaker…Sonos 2”.  Perhaps new Sonos 2 functionality is interfering with backward compatibility for Sonos 1 devices? In any event, I changed that name to “Kitchen” but it wouldn’t stick so I changed it to “Kitchen Alexa” and it worked. None of this has to do with functional voice response. That was working already.

Good luck to those not online yet  

 

Mine is also fixed.  Thanks Sonos support. and  @SkipperGreg  

Hey all

Huge thanks to @SkipperGreg. I’ve been following this post for a while and then gave up but tried again just now and my Sonos One & Alexa is working again! 

 

I have the latest version install

11.14

I am using the S1 Controller

I also spotted that my Sonos One speaker had the odd title “Sonos One Second Generation” within the Alexa App. I tried to rename it and all the speakers and devices disappeared. 
 

  1. I removed the voice service from Sonos S1 Controller
  2. I logged out and back in to the Alexa App
  3. On the Sonos S1 app I added voice services, and went through the screens. My Sonos One chimed and said it was connected, but when I tried to wake it, it didn’t respond. 
  4. I went to the Alexa App - located the device named “Claire’s Sonos One Second Generation” > renamed it to Kitchen Alexa. 
    My Sonos One was appearing twice as Kitchen and “Claire’s Sonos One etc etc” & just like Greg duplicating the name didn’t work, kitchen Alexa did. 
  5. Boom! Alexa started to respond again. 
     

After you rename the speaker you may have to log in and out again or add/remove service.
For whatever reason the speaker gets named incorrectly in Alexa and once that was amended it was happy again. 
 

I hope that also helps for anyone experiencing this unique problem. 
I should upgrade my Sonos Play:5 and thus move to the S2 Controller as well, but I don’t want to be wasteful, the speakers are in excellent working order. But super happy to find a fix. Sad there is no proper Sonos support otherwise than this forum.