• 1 January 2021
  • 1 reply

I changed router and had to set Sonos speaker up again.After set-up I said Alexa play 98.1 the bull.She said playing 97.1 the bull but no music??

1 reply

Userlevel 6
Badge +17

Hi @Cardfile69.

Welcome to the Sonos community and thanks for bringing this to our attention. Allow me to help you by sharing some information.

Allow me to recommend the following guides and please do follow accordingly.

  1. Log out of ALL Amazon-related apps which are and not limited to the following. (Amazon Prime, Amazon Shopping, Amazon Alexa, etc.) 
  2. Open the Amazon Alexa app and disable the Sonos Skill.
  3. De-register any Sonos product on the Alexa App.
  4. Open the Sonos App.
  5. Remove the Alexa Voice service.
  6. Force close Sonos app.
  7. Force close the Alexa App.
  8. Reopen the Sonos App. Add Alexa as a voice service.
  9. Open Alexa app Add Sonos as skill
  10. Register Sonos speaker
  11. Add music service.
  12. Test to check if it works.
  13. Submit a diagnostic to capture all information performed on the Sonos devices.

Please let me know how it goes and keep us posted here in the community.

Thanks and Happy New year,