Sonos and the Spanning Tree Protocol

  • 10 June 2010
  • 60 replies
  • 158412 views

Userlevel 1
I wanted to post a few clarifications regarding SONOS and Spanning Tree Protocol that have been raised in this thread.

SONOS ZonePlayers use 802.1D Spanning Tree (STP) for loop prevention between wired ZonePlayers and the wireless SonosNet Mesh Network. The Spanning Tree running on ZonePlayers is compliant with IEEE 802.1D and can inter-operate with other IEEE 802.1D and IEEE 802.1w compliant devices. Note: IEEE 802.1w is an updated version of the Spanning Tree protocol called Rapid Spanning Tree. The two types of STP protocols are compatible and 802.1w should revert to inter-operate with 802.1D devices (such as Sonos). Therefore, 802.1w Ethernet switches will work with Sonos ZonePlayers.

SONOS ZonePlayers CAN be connected to Ethernet switches that do NOT support Spanning Tree as long as the Ethernet switches do not interfere with the STP BPDU packets transmitted between ZonePlayers. This is typically never the case and these switches pass the BPDU packets like any other packet.

If the Ethernet switches that Sonos ZonePlayers are wired to DOES support Spanning Tree, the Spanning Tree on those switches must be configured properly. Ethernet switches that support Spanning Tree typically have their STP settings disabled. This also typically means that these switches will block/discard the BPDUs coming from the ZonePlayers. When the ZonePlayers are not able to see BPDUs, they cannot detect there is a shared transmission medium between the Zones and this will typically result in loops in the network. The solution to allow the use of these switches with Sonos is to enable and configure the Spanning Tree on the Ethernet switches. The configuration settings on each switch are different and the appropriate documentation for those products should be consulted. Note: Some switches have a setting that is called Pass BPDUs or equivalent. This setting when present allows the BPDUs between the ZonePlayers to pass freely through the switch without actually enabling STP on the the switch. Typically, setting this function also works, but again please review the switches product documentation.

A good guideline for Ethernet switches is if the switch says it supports Spanning Tree, either 802.1D or 802.1w, then its configuration settings and user documentation should be examined before wiring multiple ZonePlayers to the switch. If the switch does not state it supports Spanning Tree, 802.1D, or 802.1w, it will probably work fine with Sonos.

SONOS ZonePlayers do NOT require a connection to the same Ethernet switch. Different ZonePlayers can be connected to different Ethernet switches which are in turn connected to each other. The only requirement is that Sonos ZonePlayers must be able to actively participate in 802.1D Spanning Tree and not have BPDU transmission blocked between them. There is no Sonos limitation that prevents wiring multiple ZonePlayers to multiple Ethernet switches.

IEEE 802.1D has a recommended bridge span limitation of 7 bridges. This means that the total number of connected bridges from one end of the network to the other should not exceed 7 bridges. This typically only comes into play when daisy chaining Sonos ZonePlayers together by wiring one ZonePlayer to the next. In this case, the guidelines is when daisy chaining ZonePlayers, do not exceed 7 ZonePlayers wired together. If wiring multiple ZonePlayer to a single Ethernet switch, typically the number of spans will only be 3 or 4 (I.e. much less than 7). Except in the daisy-chain configuration, this limit of 7 bridges/7 ZonePlayers, is rarely ever hit.

A number of comments have used the term router and switch interchangeably in regards to this topic. Sonos ZonePlayers in the same HouseHold MUST be connected to the same routed network. A Spanning Tree cannot span two or more routed networks. In addition all Sonos ZonePlayers and Controllers must be on the same routed IP network in order to properly communicate and function. Typically, two or more routed networks are not seen in the household environment except by accident (Example. A carrier provides a new router in a network that already had a router and the original router was not removed).

Hopefully this information has clarified a number of items and not added additional confusion.

Regards, Todd

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

60 replies

Userlevel 2
Badge
Sorry to drag this up again but I'm pulling what little hair I have left out!!:@

I've just spent over 2 hours on the phone with support and got nowhere. In fact they changed some settings and the system was worse. Here's a summary of the issues and setup.

I have a Netgear GS748TP switch which is the main switch in the house. I have two additional unmanaged switches in two outbuildings hardwired back to the main switch. I have seven SONOS players and a Boost. One SONOS is in one outbuilding and a second in a separate outbuilding. One is hard wired (via unmanaged switch in outbuilding back to main switch in house), the other uses SONOSNet off the other - it has to as it can't connect to any players in the main house. The rest of the players are in the main house. Two on the ground floor with a Boost. They are separated by around 15ft between each player and the Boost. Another player is on the first floor and the final two are on the second floor next to each other. Within the main house, the Boost is hardwired via ethernet back to the GS748TP. Likewise one of the players on the second floor is hard wired to the GS748TP.

The problem is one of the players on the ground floor (Connect:Amp) is dropping off the network. Only a recent problem as the system has been running for nearly 10 years without problems. No changes have been made to the network except adding a Beam and another Connect:Amp recently. I've also been experiencing network problems with slow access. I was advised to swap the problem unit for another and see how that went. I did this and all seemed well but support advised there was still considerable interference in the system. At this stage the swapped unit had been running for several days with no dropouts. Support then changed various settings on the switch which caused the swapped player to dropout again! I've changed things back and the player came back on the network. However I'm not sure where my settings on the GS748TP should be. I've attached a few screenshots. Can anyone help to solve this??
The GS748TP settings look okay. Intermittent dropping of a single unit off the network is not usually a symptom of STP configuration. Interference sounds like a more likely candidate. Even possibly hardware issues if it's an old unit. At 10 years old a 'Connect:Amp' is surely an early ZP120, or is it actually a ZP100?
Userlevel 2
Badge
Hi Ratty. Sorry for delayed reply, I didn't receive email notifications of replies.

Anyway, yes it's a ZP120 but I swapped this around for a Connect:Amp and after support altered the STP settings the unit dropped off the network. Only this one dropped off, no others. So both a ZP120 and a Connect:Amp dropped off in the same location so likely interference but baffling as to why the Beam, which is only around 10ft away has no problems. Must be very localised but I can't think of what it would be. The affected unit is under a kitchen unit behind the wooden plinth. Nothing else there and this has been it's location for nearly 10 years. Very odd.

Support certainly caused me huge headaches by fiddling with the switch settings. They were convinced it was related to STP.