Upgrade of WIFI Network (Modem & Router)

  • 17 January 2021
  • 18 replies
  • 238 views

Hi,

I have read in the SONOS community that there are many issues encountered when a user upgrades the home wifi network, say with a new modem/router, for example, an upgrade of google wifi mesh to the next gen Nest wifi mesh.

Every SONOS echo system user will bound to encounter this issue in time, as and when there is a necessity to upgrade the home wifi network with time. I am also thinking of upgrading my current google wifi mesh to the next gen Nest wifi mesh; but have concerns of the problems I would encounter with the wifi network switch on the existing installed SONOS echo speakers system.

Common problems encountered included, SONOS speakers cannot join the new wifi network, all speakers disappeared form the SONOS app.

I am wondering if someone can provide advisory or point to any available knowledgebase to resolve/steps to be taken during new installation of a new wifi network to prevent SONOS issues from surfacing?

Grateful for any advice.

Thank you.

Regards,

zentan69

 

 


18 replies

Userlevel 7
Badge +21

Most problems can be simply avoided by simply using the same SSID and password on the new router as you used on the old router.

zentan69,

A further option for you to also consider…

Wire one sonos device only to the new router. Connect the mobile controller to the new routers WiFi. Open the Sonos App from a fully closed state and wait for all devices to appear in the App... if any do not appear, then reboot them (just the devices that are missing) - but (importantly) be patient and let them search and connect.

The system can be left in this state (with one device wired) (recommended) and is often referred to as a SonosNet setup. The Sonos devices will connect to each other using their own internal wireless/wired connections and not use the routers WiFi signal. The SonosNet channel can be set within the Sonos App (keep it at least 5 channels away from your routers 2.4Ghz WiFi channel).

If its preferred however that all Sonos products run on the new routers WiFi signal instead, then when all devices are present in the App and working, goto “Settings/System/Network/Wireless Setup” and (carefully) reset/enter the new routers 2.4ghz WiFi credentials (SSID & Password) - wait for a few moments for these credentials to propagate to all devices and then un-cable the speaker from the router.

All products should now run on the new routers WiFi signal - if not wire back the Sonos device and check the WiFi credential entered which are cAsE sEnSItiVe. 

Note: If choosing to run the products in SonosNet mode, rather than connected to WiFi, it is ‘good practice’ to reset/remove the WiFi credentials from the Sonos App instead, as that will prevent the speakers hopping between a SonosNet signal and the routers WiFi signal.

Thanks Ken_Griffiths for the advice.

I am running a SONOS Boost. Is the SonosNet you are talking about?

I believe if I am running the Sonos Boost (SonosNet), then my Sonos speakers are not connected via the home wifi network, correct? Or will the Sonos speakers still be able to hope between the SonosNet and the home wifi?

Thanks much for your advice.

Regards,

zentan69

Thanks controlav for your advice.

That sounds logical and practicable…

Regards,

zentan69

 

Thanks Ken_Griffiths for the advice.

I am running a SONOS Boost. Is the SonosNet you are talking about?

I believe if I am running the Sonos Boost (SonosNet), then my Sonos speakers are not connected via the home wifi network, correct? Or will the Sonos speakers still be able to hope between the SonosNet and the home wifi?

Thanks much for your advice.

Regards,

zentan69

Yes, just use the Sonos Boost only, and wire it to the primary hub of your new mesh WiFi system. It will work straight away as outlined - no need to change/add the WiFi credentials in that setup situation.

Yes, just use the Sonos Boost only, and wire it to the primary hub of your new mesh WiFi system. It will work straight away as outlined

… after a full system reboot, by powering all devices off and on again. They need to refresh their IP info. 

 

Yes, just use the Sonos Boost only, and wire it to the primary hub of your new mesh WiFi system. It will work straight away as outlined

… after a full system reboot, by powering all devices off and on again. They need to refresh their IP info. 

Ah okay, thanks @ratty.👍

Hello experts. I have some question related to sonos setup. we have installed Sonos One in our retail showroom and having issues since day one. may be we just not installed it properly.

can someone please guide me if the installation we did is correct: 

we wired one sonos to LAN cable > Switch > router

all other 19 sonos devices are connected to wifi.

the issue is sonos some times not appearing on app and intermittently stops playing etc. can some one help. i know sonos one works on 2.4ghz and our wifi supports this.  is above setup correct ? do we need to do any stp settings on our linksys managed switch ?

all columns show one thing strange: STP undefined. what does this mean?

 

may be below snapshot can be helpful (sorry for zoomed-out) hope colors should tell the initial issue.

 

@TechGuy21 You appear to have disabled "WiFi" on the wired Sonos One. Turn it back on.

@TechGuy21 You appear to have disabled "WiFi" on the wired Sonos One. Turn it back on.

 

thank you very much for you input. do you mean by doing this the MESH will start working?

It will. Give it several minutes to reconnect and sort itself out. 

The "Disable WiFi" option causes no end of confusion. It does no such thing; it disables SonosNet. 

It will. Give it several minutes to reconnect and sort itself out. 

The "Disable WiFi" option causes no end of confusion. It does no such thing; it disables SonosNet. 

 

thanks mate, let me do that straight away and will keep you posted. appreciated!

I tried calling SONOS support, they don't answer anymore, their email is also not monitored any more. was really stuck on this one. thanks again.

It will. Give it several minutes to reconnect and sort itself out. 

The "Disable WiFi" option causes no end of confusion. It does no such thing; it disables SonosNet. 

 

thanks alot. immediately after enabling the WiFi, we noticed the Tertiary node color changed to Yellow.

 

I am monitoring any changes/improvements and will keep you updated:

 

 

The rest still seem to be using the actual WiFi, not SonosNet. You can confirm this by looking in About My System. Node that are on SonosNet (or wired) say WM:0.

If they don’t shift over to the SonosNet mesh then go and power them off, wait 15-20secs, and on again.

We went through the whole ‘upgrade to new mesh router’ process for 3 units. Connect via ethernet etc. etc.

It worked!  For a very short time.

Since it was a real hassle, I am not excited to do it all over again. Especially if the solution doesn’t persist. 

Maybe I’ll reach out to Sonos help….

We went through the whole ‘upgrade to new mesh router’ process for 3 units. Connect via ethernet etc. etc.

It worked!  For a very short time.

Since it was a real hassle, I am not excited to do it all over again. Especially if the solution doesn’t persist. 

Maybe I’ll reach out to Sonos help….

As you are using a mesh WiFi setup, I would also personally recommend you perhaps consider running your speakers on SonosNet, if not doing that already … the difference in the connections and how the setup works are explained in this Sonos Support document:

https://support.sonos.com/s/article/3235

If opting for SonosNet (wired) mode direct to the primary Hub, I would also suggest doing the following:

  • Set the hubs 2.4ghz WiFi to a fixed ‘non-overlapping’ channel 1,6 or 11, if possible.
  • Set the SonosNet channel in the Sonos App “Settings/System/Network” so it is at least 5 channels away from your chosen WiFi channel.
  • Remove the WiFi credentials from the "Network/Wireless Setup” in the App as those are not needed when running on SonosNet and it will stop your devices hopping between SonosNet and your WiFi signal.
  • Ensure all Sonos products, particularly the wired one is at least 3 to 4 feet away from other Wireless devices including the router and other access points.
  • Consider adding the Sonos IP addresses to the local routers DHCP reservation table, as that too will improve stability, particularly during updates and reboots of the local network. This step is optional.

Hopefully those few suggestion will assist to prevent any audio/device dropouts… I also recommend checking out these two ‘hopefully’ helpful links too:

  1. WiFi Interference
  2. Wireless Interference Video: Wireless Interference and Sonos

Appreciate the info, but we cannot run on sonosnet wired to primary hub as that is on different house level from the sonos room units.

 

 

Appreciate the info, but we cannot run on sonosnet wired to primary hub as that is on different house level from the sonos room units.

Then you perhaps have two possibilities I guess, ...maybe try wiring a standalone Sonos device ‘temporarily’ and if it works well for you, then perhaps consider getting the Sonos Boost to put in its place on a permanent basis. Or of course try to run the system on your mesh WiFi maybe using a ‘fixed’ non overlapping 2.4ghz Wifi channel as mentioned in my post, with a channel-width set at 20MHz (if your mesh devices allow this type of manual configuration), to reduce interference, but if Sonos keeps failing, I would look a little further at the suggested SonosNet option.

Reply