Answered

Two Fives (a stereo pair) won't use SonosNet (even though every other compatible device in the house does)

  • 29 March 2022
  • 6 replies
  • 110 views

Badge
  • Contributor I
  • 8 replies

I have an odd problem where all my Sonos devices in the house are (expectedly) using SonosNet, except for my newest Sonos Fives (which I have configured as a stereo pair). Does anyone have any theories as to why this would be the case? I thought that Sonos devices would prefer/use SonosNet when available, and everything in my house (other than a Move which I know only supports WiFi) does use SonosNet. Is there some kind of device limit for SonosNet? In “Sonos System Info,” I do have 16 devices that list WM: 0 (i.e., SonosNet), and so I’m thinking maybe 16 devices on SonosNet is the limit? But looking online, I haven’t found a reference to device limit. BTW that stereo pair seems to be working fine on WiFi, so it’s not a big problem - I’m just curious.

icon

Best answer by Corry P 31 March 2022, 15:47

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

There’s no limit beyond the normal 32 devices for SonosNet. For some reason, it could be that the two Fives found the path to the data to be “shorter” using wifi, rather than SonosNet. You’d have the wifi network data in your controller because of the Move, of course. You could try a simple reboot / power cycle of the Fives, and see if they join SonosNet, but then if they’re working fine, I’d be tempted to leave well enough alone.

In general, the Sonos software looks for the best path to the data, since in the Five’s case, they have both available, they may have chosen the shortest connection. Sometimes, that can cause an issue, as the devices “flap’ between the two connection methods causing disconnects/interruptions, but that may have been an old issue that’s not as applicable these days. 

 

Userlevel 6

32 devices is the system limit so that’s not an issue.

Simply switching SonosNet channel can flip a speaker onto SonosNet. Change channel, leave it for a minute for system to refresh, then switch back to the channel you were on.

If that doesn’t work, you could reboot the Fives to see if the join SonosNet when they reconnect to your system.

Have you tried temporarily switching off the relevant  WiFi band on your router (just temporarily) to force the Fives over to SonosNet and then when they do, just switch the WiFi back on for your Move to use ..

Note when the WiFi is off, you may need to reboot the speakers to force them onto WM:0.

Badge

Thank you all. Bruce, my Fives are actually very close to my WiFi/router (a Unifi Dream Machine wireless router), and so if the Fives are testing for the “better” path I could definitely see that (would be great if someone from Sonos could confirm that the devices try to find the shorter/better path). BTW, I did power cycle them both and they rejoined WiFi again. Based on your theory (and the fact that the Fives are performing well), I think I’ll leave well enough alone. Thanks again to you, Mr T, and Ken for the quick responses.

@GDaz,
FWIW (if you do encounter any issues in the future), then see below:

With the Unifi DM - It mentions these things in various other threads here: 

  • Log into the UniFi controller.
  • In the Settings tab, click Wireless Networks.
  • Click Edit next to the network SSID.
  • Expand Advanced Options.
  • Uncheck Block LAN to WLAN Multicast and Broadcast Data.
  • In the Settings tab, click Sites.
  • Disable Auto-Optimize Network.

Please also enable IGMP Snooping (which is in the Networks settings page).

Maybe check that these settings are present in your UDM setup and perhaps see if it helps.

Userlevel 7
Badge +18

Hi @GDaz 

Thanks for your post!

would be great if someone from Sonos could confirm that the devices try to find the shorter/better path

In this context, not exactly. All Sonos devices (excepting Move and Roam) will prefer to use SonosNet, if there’s a signal strong enough. If the system doesn’t know the WiFi credentials, then speakers have no choice and will connect to the SonosNet signal they find. If the system does know the credentials, the Sonos units will connect to WiFi only if the SonosNet signal is not above a value determined to be high enough for reliable playback (RSSI -19dB).

Once speakers are on SonosNet, they will actively attempt to keep their connection path as short as possible, which is to say they would rather connect to a wired device than a wireless device, and they’d rather connect to a wireless device that connects to a wired device than one that connects to another wireless one (each unit on SonosNet rebroadcasts it in a mesh configuration). 

When connecting to WiFi, however, and when there are multiple access points available, they’ll connect to the one with the strongest RSSI signal.

The only ways of getting your Fives on SonosNet (wirelessly) would be to move the closest SonosNet-connected speaker to the Fives even closer to them (or vice versa), or to have an extra device (Sonos speaker/component or a Boost) located in the middle to bridge the signal reception gap.

I agree with the consensus here, however - if you experience no issues, just don’t worry about it. This basically means your network runs as intended and it doesn’t really matter how devices connect.

I hope this helps.