Sonos not connecting to Three's 5G Home Broadband Zyxel NR5103E router

  • 17 February 2023
  • 13 replies

I have just signed up to their 5G Home Broadband, which I am quite happy with, apart from the fact I cannot get my 4 Play 1’s and Playbase connected to it.  I can get one Play 1 to work if I use an ethernet cable, but as soon as I disconnect it it is no longer detected.   I have called Sonos who said I need to contact Three to sort it out because they couldn’t, so I called them who said I needed to call Zyxel.  I called Zyxel who won’t deal with it as Three have changed the firmware of the router.  Has anyone had similar issue and got the speakers to work?


Best answer by Belly M 20 February 2023, 13:59

View original

13 replies

This is a Wi-Fi 6E device, I don’t have one to hand anymore but it’s the same that EE supply - which may help in Googling. Guessing that the WiFi bands need splitting, have a dig in the menus as you need (for your Sonos devices) 2.4 GHz to be separate.

If you are still stuck head over to ISP review, something like 90 pages of chat but be warned it’s quite technical but someone will still have one to hand and able to look at the menu for you.

As you have found using an Ethernet lead works, if you can do this permanently then you won’t have to worry. If you connect by Ethernet it can take a few minutes for your other Sonos devices to switch to using Sonosnet.

Just to confirm one aspect of @Belly M ‘s excellent advice, it should be sufficient to cable just one of your speakers.  This triggers SonosNet, meaning that wireless data flows between Sonos devices no longer use your WiFi.  This may be by far the simplest way to get round any router limitations.  If it is not convenient to wire any of your speakers, you could wire a Boost instead.

Thanks for the responses.  I thought having the Play 1 hard wired using an Ethernet cable would activate SonosNet, but when I tried to connect the others it wasn’t happening.  I’ll try that with a different speaker maybe.

Try powering off your other Sonos devices, connect an Ethernet lead and when it’s fully working try powering on another Sonos device.

Thanks Belly M.  I’ll give that a try and keep you posted.

And don’t ‘turn off wifi’ on any of your speakers. If you do, that turns off SonosNet as well. 

I tried the above and once I have connected a Play 1 via an ethernet cable I have tried adding the other speakers one by one.  It happens to every speaker I try.  Sonos asks to connect to the speaker so I say yes and it says connection successful.  It then says connecting to your Playbase or Play 1 and after a couple of mins it says there was a problem setting up your Playbase or Play 1.  Let's try something else.  I click continue and after that it says no devices found.  Any ideas?

Unless you have reset your speakers you don’t add them, literally plug one into Ethernet and after a few mins your existing speakers will join Sonosnet.


Best at this point to ring Sonos again but have the one speaker connected and working via Ethernet.

As I was trying any option I could think of I have previously reset the speakers and reinstalled the app thinking I could sort it out like a new install.  Obviously hasn't worked. 


I've now bought a second hand Sonos Boost which is getting delivered tomorrow.  Will this fix my issue?

Userlevel 7
Badge +21

The Boost should solve the connection problem, as would wiring any of your speakers. Make sure you got a Boost, not a Bridge as that old unit brings problems you want to avoid.

Since you reset them you’ll need to do the “New System” setup for the first and then “Add Speaker” for the rest.

It’s no different to connecting one Sonos speaker with Ethernet, so should work well. 

Thank you, 🤞