Sonos Compatibile with Google Nest mesh system?

  • 16 November 2022
  • 9 replies

Hi, I have a Sonos ARC and love it. I have a detached garage and the Wifi signal is erratic at best, even though I have a 1400 sq ft one-story bungalow. I purchased a Google Nest mesh system for my old house (3 floors) before I had the ARC and haven’t been able to figure out how to connect the Sonos and Nest networks. I have AT&T internet and a standard AT&T router. I’ve researched this quite a bit and can’t find any definitive information on how to set up the network(s). I’m not highly technical when it comes to networks but generally comfortable with the basics. Also, I don’t use voice assistants at all. My need is strictly music (Pandora and iTunes) and running my Samsung Smart TV sound through the ARC. Thanks in advance for any info and/or advice. 


Best answer by Jamie A 18 November 2022, 14:51

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

9 replies

Userlevel 7
Badge +16

Hi @Brian933, welcome to the Community!

The Google Nest mesh will work with Sonos, however since you have the AT&T router, you’ll want to set that to modem/bridge mode to prevent having multiple Wi-Fi networks. I’d recommend giving your Internet Service Provider a call as they’ll know exactly how to do this.

Once you have the AT&T router in modem/bridge mode and the Google Nest mesh set up, you may need to change the Wi-Fi credentials in the Sonos app by connecting the system to a new network. After you’ve done this, Sonos will operate on the Google Nest with the rest of your devices.

I hope this information helps!

Thanks Jamie. A knowledgable friend suggested a CAT6 cable to connect to the ATT router to the Google mesh router. Do you agree? I have some older cables around the house if those could serve this purpose.




Userlevel 7
Badge +16

Hi @Brian933,

That’s correct, the wiring should be: Broadband Socket → AT&T Router (in modem mode) → Google Nest mesh router. Make sure the Ethernet cable is going into the WAN/Internet Ethernet port on the Google Nest mesh router as well.

Thank you.

What about with Spectrum? I have a Spectrum modem and set up a Google Nest Wifi mesh today ...and I cannot for the life of me get the my Sonos to connect again. In fact, I also bought a Sonos MOVE and now all the Sonos app wants to do is to get the MOVE set up and configured (which it won’t do since I can’t connect to Wifi). Really frustrating Sonos.

Userlevel 7
Badge +16

Hi @JFischerOnline, welcome to the Community!

Spectrum should work as well, most routers in Bridge/Modem mode should work as long as their DHCP server is turned off to allow the Google Nest mesh to handle that. The easiest way to tell if it’s done correctly is that if you can still see and connect to the Spectrum Wi-Fi network then it’s not in Bridge/Modem mode.

Since the app is stuck on trying to add the Move, you’ll want to delete and re-install the app. You wont lose anything, as the system details are saved on the speakers rather than the app. This should get you out of the Move set-up and allow you to start reconnecting your system. I’d also suggest turning off the Move while you’re trying to get the system connected again, to prevent any unnecessary complications, you can always add the Move after the system is connected to Wi-Fi again.

To connect your system to your Google Nest mesh, follow the steps to connect Sonos to a new Wi-Fi network, temporarily wiring a speaker to the main Google Nest mesh node if needed. If you’re still unable to connect after following the steps above, then I’d suggest reaching out to our support team, as they have the tools necessary to troubleshoot and resolve this issue for you. 

I hope this helps!

Hi, I’ve got a new Google Nest Mesh router system connected to a Spectrum modem, I’ve been through the steps to connect Sonos to a new Wi-Fi network about ten times, every time the system works while one of my speakers is plugged into the router with an ethernet cable, and as soon as I disconnect the ethernet cable the whole system goes offline. I called Sonos support and they told me there was a known issue with Nest Mesh Routers and that I should call Google to change some setting, but Google’s support folks have no idea what I’m talking about. Seems like if Sonos support is going to tell me it’s a known issue with an easy fix then they should be able to tell me what this mythical setting is that needs changing.

Just so you know, I also called Sonos support (which I was actually irritated that I would have to do) - but had a totally different experience. They walked me through the process and everything is working great now. And no, there were no settings or changes to Google or to Spectrum. I’d recommend calling back and getting another person to help you. 

Thanks for the heads-up. I’ll give it another try I guess.