Sonos app can't find devices connected to eero gateway

  • 26 December 2021
  • 13 replies
  • 720 views

I have a Sonos Port and five Sonos: 1 speakers, all connected to an eero pro-6 tri-band. The Port is connected to the gateway eero via Ethernet. None of the speakers are wired (none are connected via Ethernet) but show up in the eero app as if they are wired to the gateway, same as the Port, which must mean they are connected via wifi to the Port, right? (I'm seeing their serial numbers in the list of Ethernet connected devices in the eero app.)

The app says it's unable to connect to Sonos and shows the let's fix it link. I've followed that process a gazillion times to no avail. I've tried the find missing devices instructions a gazillion times. Nothing works.

It all worked fine before I added the eeros. How do I get the Sonos app to find the devices connected to the eero? Again, only the Port is wired. Only two of the speakers are in the same room, but all show as connected in the eero app. 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

13 replies

Is the Port wired to the main Eero hub or one of the satellites?  It needs to be wired to the main hub.

Just to first clarify a couple of things. Is the eero primary hub (where your Sonos port is cabled to) the local network router, or are you perhaps still using your ISP provided router and bridging the eero system off that as an access point, but still have your WiFi running on your ISP router?

What WiFi signal is your mobile device connected to and what WiFi credentials (if any) do you have showing in ‘Settings/System/Network/Manage Networks’ in your Sonos App.

And finally, what WiFi and SonosNet channels are in use across all your devices? 

jgatie: Yes, the Port is wired to the main eero. I think that's why all of the speakers show up as wired despite not being, but I can't find no way to check the speakers to see how they're connected or to what.

Ken_Griffiths: I've tried every way possible to check how my phone's connected. The eero broadcasts the same name as my original (AT&T fiber) router, and that's all my phone shows. I can't tell whether my phone is connected to one of the eero devices partly for that reason and partly because all I see is the phone's name, not the MAC address, and my husband has the same phone. Also, it appears that the phones' MAC addresses are randomly and dynamically assigned.

So that said, after several days of failure after failure, it's suddenly and inexplicably working. Here's what I think:

For whatever reason, all of the Sonos devices finally connected to the main eero: the Port is wired to the main eero (the only eero wired to anything), and because the speakers all appear to be wired to the same eero despite not being wired at all, I have to deduce that they are connected via Sonos wifi to the Port and somehow inherit the Port's connection status.

Also, for whatever reason, my phone has finally, magically, spontaneously connected to that eero after three days of trying to get it to do that.

I believe both conditions are at least somewhat spontaneous and serendipitous and not unlikely to revert to problem status. There needs to be some way to manually select a common network connection for each device. Until that appears, I expect to go through this repeatedly.

Thank you both for responding so quickly. I welcome any further suggestions. 

I would personally choose to disable the WiFi on your AT&T router and just use the eero mesh WiFi.

As you have a device wired to the primary eero hub just check to see if the eero WiFi credentials are stored in your Sonos App network settings - if you do not have any Sonos portable devices (Move or Roam) then remove those stored credentials, they are not needed for SonosNet connected devices and it will stop your speakers hopping between SonosNet and your eero WiFi.

Hope those few suggestions help to stop the issues you have been seeing with your Sonos system.

One further suggestion is to ensure the wired Sonos device (Sonos Port) is set well away from both your primary eero Hub and your router, at least one metre away.

Thanks, Ken. Both AT&T and eero recommended against disabling the AT&T router, but I think you're exactly right.

The only network credentials in the Sonos app are the SonosNet channel (which I'm thinking you're not taking about?) and my wifi network. Because I named the eero wifi network the same as my AT&T wifi network (per instructions from both), I can't tell from the Sonos app which router that is, BUT I can tell by checking the eero app and the AT&T app that the Sonos devices are connected to the eero, not to the AT&T gateway. Do I leave that or remove it? After the trouble I've had, because it's finally working, I'm afraid to remove it though what you say makes sense to me. 

By default the primary Eero contains a router, splitting the local network into two subnets. A Sonos controller connected to the AT&T WiFi won't see the Sonos system. 

Either disable the AT&T WiFi; rename that WiFi and ignore it; or switch the Eero into bridge mode. 

Userlevel 7
Badge +17

You would not be disabling the AT&T router, you would just turn off wifi in it’s settings. 

ratty/106rallye:. Thanks. That makes sense. If I understand all that everyone is saying, as long as the Port remains connected via Ethernet to the eero, it (of course) doesn't need to "know" that I even have wifi; and as long as the speakers are connected to the Port's wifi network, they don't need to know about anything else. And based on what Ken said, if the speakers do "know" about another network (which I guess they do as long as one is registered in the Sonos app?), then they may continue to hop over to it.

I've removed my wifi network from the app. Thanks for your help!

ratty/106rallye:. Thanks. That makes sense. If I understand all that everyone is saying, as long as the Port remains connected via Ethernet to the eero, it (of course) doesn't need to "know" that I even have wifi; and as long as the speakers are connected to the Port's wifi network, they don't need to know about anything else. And based on what Ken said, if the speakers do "know" about another network (which I guess they do as long as one is registered in the Sonos app?), then they may continue to hop over to it.

I've removed my wifi network from the app. Thanks for your help!

Whilst a Good Idea, that’s not related to your problem. 

Unless you’ve deliberately put your Eero into bridge mode it contains a secondary router, in addition to your AT&T router.

Your Port (and hence the Sonos system) is wired to the LAN side of your primary Eero node. 

Your AT&T router is on the WAN side of the Eero primary.

If your phone connects to the AT&T router WiFi it will not be able to locate the Sonos system. There’s a router in the way -- in the Eero primary -- and a router’s job is in part to stop devices on its WAN side from reaching its LAN side.

Either stop your phone from connecting to the AT&T router WiFi, or put the Eero into bridge mode (thereby disabling its router functions). If you go for the latter option you’ll need to reboot everything on the Eero network including all the Sonos devices, so they acquire IP addresses from the AT&T router.

See here: How do I bridge my eeros?

Thanks, ratty. That secondary router is what I bought the eero for. I have two more to extend wifi to areas the AT&T router can't reliably reach. I think putting the eero in bridge mode last week may have started all of this. I understand what you're saying about the phone; I experienced that yesterday. This I did not know: "a router’s job is in part to stop devices on its WAN side from reaching its LAN side." But that could explain a lot of what's been happening. Both AT&T and eero recommended not turning off the wifi signal in the AT&T gateway and say to bridge the eero instead. But when I bridged the eero and wired the Port back to the AT&T router, I lost nearly all of my wemo devices. Now both systems are working, so I won't bridge the eero and start that again. Sounds like I'll have to defy AT&T and disable its wifi instead. I think the only practical effect is that I'll lose some of its wifi diagnostic and maybe its security functions, but eero has security functions of its own, plus I subscribe to a separate security provider. As for the diagnostic functions, it's not as though they've done me any good. 

If you lost devices after bridging the Eero it’s most probably because they’d retained their old local IP addresses, the ones previously handed out by the Eero’s own router. The devices would have needed to be rebooted or reconnected to acquire new IP address info from the AT&T router.

It sounds like you’d prefer to retain the full feature set of the Eeros. In that case either turn off the AT&T WiFi, or rename it to something different and ignore it. 

If you lost devices after bridging the Eero it’s most probably because they’d retained their old local IP addresses, the ones previously handed out by the Eero’s own router. The devices would have needed to be rebooted or reconnected to acquire new IP address info from the AT&T router.

It sounds like you’d prefer to retain the full feature set of the Eeros. In that case either turn off the AT&T WiFi, or rename it to something different and ignore it. 

Thanks. I'll do that. And thanks for the explanations. That's been especially helpful. Understanding the why helps me figure out the what and how.