Solution : Mesh WIFI Sonos components disappearing from the network

  • 7 April 2023
  • 2 replies

Hi, I solve the problem with Sonos components disappearing from the wifi network mesh. To do so, I check in my main router “allow network device to autonomously create port forwarding via PCP or UPnP.”

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Don’t know what you mean @CarlosLU?

Are you saying you just enabled UPnP (auto-port forwarding) in your router configuration? - If so, that’s for opening/closing ‘external’ ports on the fly rather than using manual port forwarding - I can’t see how that might have any relevance to device discovery when ALL are on the local network subnet anyway - You perhaps need to provide some additional detail, maybe with screenshots, which may assist with understanding of what you changed in your router settings.

Just to add, I had to enable UPnP on my router to get Sonos working with the in-built Plex service (as that required remote access to be enabled). It uses NAT loopback to make the Plex service discoverable - I’m not sure why Sonos/Plex do that🤔 other than perhaps it’s a check that a Plex pass is associated to the account, but in my case, it will not work with my chosen router unless I enable UPnP (that’s even with internal TCP port 32400 manually forwarded)  - but clearly that’s not anything to do with the actual discovery of Sonos devices which work fine in my case with UPnP set as disabled.

That said, I have seen Sonos Staff in the past suggest UPnP be enabled on a router whilst some users tend to see it as a bit of security risk and so leave it disabled.