New ASUS ZenWiFi AX6600 Tri-Band Mesh WiFi 6 System (XT8)

  • 27 November 2023
  • 37 replies
  • 492 views

Badge

I am trying to set up a new ASUS ZenWiFi AX6600 Tri-Band Mesh WiFi 6 System (XT8 2PK). However, Sonos devices will not appear on the network and do not show up on the Sonos App, even though they appear to be available.  I tried the 3 different ideas posted in the forum, but still no luck.  Wanted to see if anyone had new ideas on how to get this to work?


37 replies

What are the three things you’ve tried?

My first option would be to wire a speaker directly to the router, and give the all five minutes to recognize the change, or just power cycle them. That depends, of course, on which Sonos speakers you have. Not all of them have Ethernet ports.

Then I’d make sure my router conforms to the Sonos Network Requirements FAQ.

Finally, if the devices still weren’t connecting, I’d call Sonos Support directly to discuss it.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your network and Sonos system.

Badge

I read through the community response and tried the following:  

  1. Ensure to disable QoS feature.   
  2. Ensure that Airtime Fairness defaults to OFF. 
  3. Turn off "Enable Block All Devices"

I have not hardwire a Sonos One Speaker to the Router or the two different sound bars to the wifi router.   I need to find the instructions to do so.  

Also, one additional thought, I have a Sonos Boost device connected to a hub that ultimately connects to the router.  Would this have any impact? I am not sure it would, but thought I should ask.  

You need instructions on how to wire an Ethernet cable to a Sonos speaker (not a surround speaker or Sub) to your router?

That oddity aside, the existence of a BOOST does change the network somewhat. It wasn’t mentioned in your original post. You use the term ‘ultimately’ when describing it. It should be wired directly to this new router, with nothing in between the two. All speakers except Roams or Moves should then connect via SonosNet. If they’re not, do a simple power cycle. 
 

If you’re still struggling, call Sonos Support directly.

Badge

I understand how to plug in an ethernet cable.  I assumed there are instructions to follow to make it work beyond plugging the sonos one via ethernet to the router.  Sounds like just plug the sonos one into the router and go into the app to set it up, no specific instructions.  

As far as the boost, you are correct, I forgot that I had it.  If it is plugged into a hub, your advising that will impact the set up versus if it was directly into the wireless router?

 

Absolutely. 

Power off the Boost. Assuming it’s wired to your internet gateway and the XT8 mesh hasn’t been put into bridge/AP mode your Sonos will be on the wrong subnet.

I have a largish Sonos system on XD6 (2-pack) and it’s been absolutely fine.

Userlevel 3
Badge +3

I have three XT8 nodes and my Sonos system connectivity is great. You have already commented on a few key config changes that should be made for the Asus system.

Have you spotted the Sonos article on WiFi setup? It’s here. You will note that Sonos is moving away from SonosNet and I don’t use it (ie I don’t have a speaker or Boost directly connected to my Asus router). Unfortunately the article doesn’t contain specific instructions for Asus.

Where I diverge from the article’s advice is that I have disabled Smart Connect in the XT8 config. This means I have separate 2.4GHz and 5GHz bands, and all my Sonos speakers are connected to 2.4GHz as I have the older Playbar and Play:1 speakers. My phone also connects on 2.4GHz which I find means a faster connection to Sonos.

After splitting the bands I’ve done the opposite: force all Sonos devices onto 5GHz except for the Home Theatre master players, which can only connect to 2.4GHz.

Also, all Sonos units except for portables are bound to specific AP nodes.

 

Userlevel 3
Badge +3

After splitting the bands I’ve done the opposite: force all Sonos devices onto 5GHz except for the Home Theatre master players, which can only connect to 2.4GHz.

Also, all Sonos units except for portables are bound to specific AP nodes.

 

Yes, agreed. I bind to specific nodes and also use static IPs. 

Badge

Just to clarify, rarity’s comments. When you say plug the boost directly into you your internet gateway, you are referencing the Verizon Fios Modem that brings the internet sign into my house?  

Badge

DGR1 - I tried disabling smart connect and moving Sonos to the 2.4 ghz network. I had my phone on 2.4, but it did not work. In addition after I disabled it, my smart lights and plugs stopped working too.  I reverted back.  It might have been impacted by the boost on the network?  
 

 

Since you didn’t respond to my remark about AP/bridge mode I guess you haven’t selected that mode for the XT8s.

In that case if you’re going to use the Boost at all it needs to be plugged into the main XT8 node. Don’t plug it into any ‘hub’ (switch, I assume) upstream of the XT8 or into the Fios box itself.

But, as noted, you’d probably be better off dispensing with the Boost entirely and connecting your Sonos system to the XT8’s SSID(s).

Badge

I did not make any adjustments for the A/P Bridge mode in the XT8.  I apologize for the confusion.  Just to clarify, i did plug the Sonos Boost into the XT8, I did not plug the sonos boost into the verizon router/ hub that brings the signal into the house.  I worked with Verizon to turn off wireless networking capabilities in the Verizon router / hub before installing the ASUS System. 

Could this be the route cause of the problem? 

 

It sounds like the Verizon unit could be in modem mode then. In that case we’re back to square one. Have you actually tried running the Sonos on the XT8 WiFi instead of using the Boost?

Badge

First, I double checked that the ASUS device and the operation mode is set to Router not A/P Bridge Mode. 

I removed the boost and the Sonos System appears to be working.  However, when I move from Family Room (Beam, and Play 1 L R) to Kitchen (Sonos One) Spotify song skips forward a song when it goes to the kitchen speaker.  The Sonos App shows the previous song playing the Family Room, but no sound.  

Is this something that can be corrected or just live with it?  

However, when I move from Family Room (Beam, and Play 1 L R) to Kitchen (Sonos One) Spotify song skips forward a song when it goes to the kitchen speaker.  The Sonos App shows the previous song playing the Family Room, but no sound.

Are you moving the music, or are you moving yourself? Is this when controlled direct from the Spotify app or with the Sonos app?

Badge

I am using the Sonos App, but have my Spotify account linked to it.  I am moving the music and from one speaker to another speaker when this happens.  

Try with a different source and see if you get a track skip. Also between different pairs of speakers.

When the first (or only) room in any group is changed the stream has to hand off between ‘Group Coordinator’ devices, the new one reconnects to the source, buffers need to recharge, etc. Sometimes it can glitch.

 

You could also look in the Sonos app to check the connection strength and which node each speaker is connected to. If it seems like a poor one has been chosen then reboot the speaker. As noted above I find that binding devices in the ASUS UI is the surest way to guarantee results.

Badge

I am not familiar with binding devices.   Are you saying to change the range of the DHCP address, so there is a group of static addresses and they never change? 

I am not familiar with binding devices.   Are you saying to change the range of the DHCP address, so there is a group of static addresses and they never change? 

 

Most routers have the ability to reserve an IP address to a single MAC address, so the device with that MAC will always get assigned that IP, and that IP will never be assigned to any other device.  Check your router manual for more details.

Badge

Thank you. So you are suggesting that I adjust the dynamic range, so I have static addresses and assign a static IP to each Sonos device?

 

 

I am not familiar with binding devices.   Are you saying to change the range of the DHCP address, so there is a group of static addresses and they never change? 

DHCP reservation is a Good Thing, but I was referring to the ZenWiFi config option which locks a client device to a specific node.

Badge

I am not familiar with that. I will have to call ASUS and inquire about it.  Thank you.  

Userlevel 7

Hi

I have an Asus AI Mesh setup using three (3) ZenWiFi Pro ET12 routers with an Ethernet backhaul.  My ISP is Comcast. My main node is connected to the ISP modem that I placed in Bridge mode.

Setting up the AI Mesh was simple using the step by step setup process provided when clicking on AI Mesh in the ASUS admin page. The process ensures that only the main node has DHCP capability. The only suggestion I have is to turn-off “airtime fairness”. Sonos needs to communicate (gossip) 24/7. They're a chatty bunch...to say the least. 😂

Where I see most people run into trouble is when they decide to change the SSID assuming their Sonos was using Wi-Fi or the SonosNet to connect. I can change my router everyday provided I power down (unplug) all my Sonos before disconnecting the current router and keep the same SSID.

Sonos (or no wireless device) is looking for a “hardware” component...just a familiar SSID. Once the new router (or Mesh is set) and powered on I connect my device first and then power up (plug-in) all my Sonos. Since the SSID is the same...within 30 minutes or less all Sonos is back on-line. *

 * I have 32 Sonos units therefore the 30 minute reference. Fewer units means less time it takes for all Sonos to connect.

I’m not sure what all that has to do with the OP’s query.

 

I am not familiar with that. I will have to call ASUS and inquire about it.  Thank you.  

Here you go: https://www.asus.com/support/FAQ/1046957/

Reply