last played source line-in

  • 19 February 2022
  • 28 replies
  • 292 views

Badge
  • Trending Lyricist I
  • 14 replies

I have an HD radio tuner connected to a Sonos Five, and set to auto play, so I can use without ever going to the Sonos App. I also play this source to speakers in another room. The speakers in the other room remember last played source, so I can simply play radio by touching play button on speaker in other room. However, if I play an airplay source in between, the speaker forgets the airplay source after it ends (as it should). But it does not revert back to the previous played source  (line-in source), unlike it does if I had played any other network source (eg, Amazon music radio station) within the Sonos App before playing from airplay. My question:  is there a setting to make a line-in source to have the same “last-played” behavior as other network sources played from the Sonos app? If not, I would ask Sonos to include this feature in the next update.

 


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

28 replies

Userlevel 7
Badge +18

Hi @RNewf 

Welcome to the Sonos Community!

I’m not 100% sure I understand the situation correctly, but if you have Line-In autoplay enabled then the Five will switch to Line-In whenever something starts playing on the Line-In source. Therefore, if the Line-In source never stops playing while you are listening to the AirPlay source, you’ll need to stop playback on the HD radio tuner for a few seconds and then restart playback - this will trigger the Five to switch over.

I hope this helps.

 

Badge

Thanks for your reply.

I didn’t explain the situation well. 

My question is not about the Sonos Five in the Living Room connected directly to the radio tuner (line-in source). That works beautifully with auto play under all situations. My issue is with speakers (Sonos Ones) in the Dining Room remembering “last played” under some situations. Here’s what I mean.

I turn on the line-in source and it plays automatically on the Sonos Five. I can then use the Sonos App to also play it on the Sonos Ones. I then turn off the source. I can come back later, turn on the source and it plays automatically again on the Five. I can also simply hit the play button on the Sonos One to start playback there. No need to use the app at all! I can do this forever as long as I don’t play from another source on the Sonos One. So far, great. Now comes my issue.

After I finish playing from an airplay source to the Sonos One, the airplay source times out (as it should), and then Sonos One shows “no music selected”, so if you hit the play button on the Sonos, nothing will happen. I would like the Sonos One revert back to the “in-line” network source as last played, rather than showing “no music selected”.
 

I know this works if you play a network source other than line-in on the Sonos One from within the Sonos App. For example, I play Classic FM station from within the Sonos App and then stop. Then I play an airplay source - after it stops and times out, the Sonos One reverts to Classic FM as last played source. That’s what I would like to see for the line-in source.
 

Long winded but my overall goal is to avoid using the Sonos App as much as I can to play the line-in source.

 

Thanks

 

 

Userlevel 7
Badge +18

Hi @RNewf 

Thanks for clarifying all of that - much clearer now.

That’s interesting. I’m not sure if it’s related to the AirPlay timeout or not, but it’s hopefully irrelevant as I believe I have a solution for you.

If the Five is playing, then holding the play button on either of the Ones for one second will tell them to include themselves in any current playback in other rooms (creating a group in the process), regardless of their queue state. If there’s more than one currently playing source on your system, each hold for one second will cycle through the currently playing sources. One more hold will stop the playback in that room only, ie. remove the room from the group.

Of course, if the Five (or another room) is not playing Line-In, then you won’t be able to use the button on the speaker to select Line-In. 

I hope this helps.

 

A further thought.  Airplay doesn’t really use the Sonos system.  You are really just using an Airplay-compatible speaker with a Sonos badge on it.  So Sonos just carries on where it left off after you Airplay to a single speaker. 

However, one way to Airplay to multiple speakers is to group them in the Sonos app. 

Are you playing the line in on the One by specifying it as the Autoplay Room or by grouping and setting “including grouped rooms”?

I think when you Airplay directly to just the One you may be breaking the group that the line-in depends on to play on the One.  Or somehow breaking the link.  This would not be relevant for other sources.

So I suspect everything is working consistently already.

I haven’t played around with this, so not totally sure.

Edit: I don’t think I am totally clear on whether you are using the line in to play just on the One in the first place, or to the Five and One.  Nor am i clear how you are stopping the music before you switch to Airplay.

Badge

I play to the Five first and then switch to the One. I want to have separate control, so I can pause the One for example but keep the Five going. I think when you group, pausing one speaker also pauses the other. Correct? 
 

I stop airplay in the app. I tried also pausing with button on speaker. Doesn’t matter except it takes longer to time out if you pause on the speaker.
 

Thanks, very helpful!

Badge

Grouping in auto play doesn’t work! But I have grouped otherwise, and I cannot pause just one speaker if I do that?

 

Related question. Is there a way to set a default network source for a speaker? That way I could set the line- source as the default.

 

 

Badge

Even more!

The real question is why the speaker treats the line-in source differently than other network sources. As I mentioned before, other network sources become the last played after airplay source times out. Shouldn’t the line-in source do the same?

Thanks.

 

Userlevel 7
Badge +18

Hi @RNewf 

I think when you group, pausing one speaker also pauses the other. Correct? 

Correct.

Grouping in auto play doesn’t work! But I have grouped otherwise, and I cannot pause just one speaker if I do that?

If there’s a playing group, holding Play button for one second in one room will stop playback in that room only. It’s not really paused, as it’s removed from the group, but that’s effectively what happens. Hold for one second again to get it to play with the other room again.

Related question. Is there a way to set a default network source for a speaker? That way I could set the line- source as the default.

No, there’s no way to do this.

The real question is why the speaker treats the line-in source differently than other network sources. As I mentioned before, other network sources become the last played after airplay source times out. Shouldn’t the line-in source do the same?

Line-In isn’t seen by the software as a queued-up item - more of an input selection or mode, so it cannot be restored to the queue once AirPlay has finished. However, I will mark this thread as a feature request and it will be seen by the relevant teams for consideration - perhaps the behaviour can be changed.

 

Even more!

The real question is why the speaker treats the line-in source differently than other network sources. As I mentioned before, other network sources become the last played after airplay source times out. Shouldn’t the line-in source do the same?

Thanks.

 

Line in is different and I would not expect it to behave the same.  It is just playing whatever it is fed as an analog stream from an external device.  The only way to genuinely stop and start the stream is on the external device.  How could it be otherwise?

Grouped speakers does work.  You would set the Five as Autoplay Room, enable Include Grouped Rooms, and group the One to the Five.  It still isn’t going to do what you want though.

You can stop individual speakers rather than all speakers by using long presses rather than taps.  This actually groups and ungroups.

Badge

Thanks very much. Very thorough answers - I appreciate it!

Glad to have contributed.  I find the long press to group and ungroup useful.  You can also transfer audio by stopping it in one room (e.g. tap on the Five) and then a long press on the One to pick up the stream.

Badge

Follow up: If I pause stream on the Five (tap), then the One will not form a group with it. When I begin play on the Five, there is no trouble forming a group by the long pause on the One!

Also, once the group is broken by long pressing on the One, then there is no memory of having played the line-in source. I guess because it’s not really paused?

Follow up: If I pause stream on the Five (tap), then the One will not form a group with it. When I begin play on the Five, there is no trouble forming a group by the long pause on the One!

I think that is what I said and how it is supposed to be. Pause (or think of it as stop) one room by a tap, transfer the audio to another room by a long press. Grouping is only intended to happen when there is a stream actively playing. These are different options and both are useful.

Also, once the group is broken by long pressing on the One, then there is no memory of having played the line-in source. I guess because it’s not really paused?

Line in is a different animal. 

Badge

Sorry to keep going at this. I formed a group with the Five and Dining Room. But in Autoplay for the Five, if  “Include grouped rooms” is on, then no speakers broadcast when I turn on the line-in source. Works perfectly if I turn it off - Five starts playing as soon as line-in source is turned on! Furthermore, Autoplay volume control doesn’t work. Bug in my software? - I do have the latest updates.

Have you actually grouped the speakers?

Edit OK you have confirmed that 

Is the Five 'room' set as the Autoplay room?

Did you form the group by  starting with the Five and adding Dining Room?

Where / how are you creating the group?

Badge

Yes, Five is set as Autoplay room. Yes, start with Five and then add Dining. I did in the App, System Tab, use + sign to create the group, which by the way works fine, if I select in the app as a destination.

That explains it. It sounds like you haven't grouped the speakers. You have merely created a shortcut way of selecting the speakers. You have to actually group them by selecting the radio buttons  and tapping Done. You don't use the plus sign.

Yes, Five is set as Autoplay room. Yes, start with Five and then add Dining. I did in the App, System Tab, use + sign to create the group, which by the way works fine, if I select in the app as a destination.

 

As stated, that just saves the group.  You need to then group by going into the grouping section and choosing that group.

Use a saved group

  1. From the  System tab, tap the  group button on any room.
  2. Tap the group name.
  3. Tap Done.

Although a named group is not needed and is of doubtful value for two speakers. The principle is sound though.

Badge

Got it. Thanks to all responders. 

Badge

John B wrote: You can also transfer audio by stopping it in one room (e.g. tap on the Five) and then a long press on the One to pick up the stream.

This does not work with the line-in source. Once the stream is stopped on the Five, then it is not picked up on the One!

That does not surprise me at all. Line in is different.

I never actually use line in. Perhaps you could use Internet radio instead?

Badge

HD Radio source is higher resolution and more reliable as a source. To end this discussion, I have 2 requests to send on to your engineers:

  1. Program line-in to behave like other network sources after playing an airplay source. Line-in source is currently remembered as last-played source like other network sources so line-in is in a queue of sorts. But line-in source is forgotten in the queue after an airplay source stops, unlike other network sources.
  2. Program so that users can choose to have a default source first in the queue to be played.

Thanks for your help.

 

HD Radio source is higher resolution and more reliable as a source. To end this discussion, I have 2 requests to send on to your engineers:

I shall regard this as addressed to @Corry P,  I am just a fellow user, and I am not employed by Sonos.  

I don’t think you have really understood how line in is different.  Even if the line in source is remembered, you would still have to walk over to the speaker and restart the stream on the external device, over which Sonos has no control.   Which is exactly what you have to do when it isn’t remembered.  It is therefore, IMO, a change of no value.

But I am sure it will be passed on to the development for consideration.