How can I stop random dropouts across large network?

  • 18 December 2021
  • 13 replies
  • 152 views

Hi, turning to community to hope that someone can advise as I’m at end of tether with my Sonos setup.

 

It’s one of those cases where speakers will occasionally disappear from the app, and playback will occasionally stop (prompting error message on app such as ‘Unable to play song - the file cannot be found’ or ‘The file was not encoded correctly’ via Spotify playback).

 

There appears to be no common factor when the errors appear or speaker dropouts happen - can happen two or three times a day, or sometimes it might only happen once in a week.

 

Is getting really frustrating as I use the Symfonisk to play white noise throughout the night for my 6-month-old son, so when the playback stops randomly in the night he can wake up.

 

I have a really good fibre broadband connection, and an Asus XT mesh Wi-Fi system with one extra node at the back of the house, which appears to work perfectly well with all my other devices.

 

I have a Beam plugged in to the main router in the front room, and up until now all the others were unplugged, so a relatively straightforward Sonosnet system. Just today I plugged in the Symfonisk, which is at the other end of the house, into an ethernet port too, just to see if it made any difference, and I’ve already had one playback stop with the usual ‘file cannot be found’ error message.

 

Rebooting the router(s) or power cycling all the speakers appears to fix any immediate issue, and brings any missing speakers back into the app, but obviously having to do this several times a week is getting tiresome.

 

I’ve set up fixed MAC addresses for all speakers, and turned off QoS mode on Asus router, and also ensured that Sonosnet is on a channel (11) with least interference. Still having problems.

 

Have attached screengrab of my network matrix, so hoping anyone may be able to spot anything specific about the setup that could be causing these seemingly random dropouts.

 

 

With many thanks for any advice.

Mark


13 replies

Userlevel 6

Hi Mark,

From your matrix there looks to be a lot of interference:

  • OFDM ANI level is a measurement of how well your Sonos components are coping with interference in your wireless environment. The lower your score the better. 0 is best, 9 is worst.

Take a look at the link here to Reduce wireless interference and see if that helps to reduce dropouts.

Is there any particular speaker that you’re experiencing these errors with or is it happening on all?

I use an Asus ZenWifi XT8 mesh setup. I only have Ethernet connected Sonos devices wired to the main router, rather than any additional nodes.

Userlevel 7
Badge +21

The red blocks may well be your issue, looks like you have one or more devices causing RF interference.

There is a FAQ on reducing RF interference and you could start with that.

https://support.sonos.com/s/article/3286

 

A second option is to run a diagnostic and contact Sonos Support with the number.

Hi Mark,

From your matrix there looks to be a lot of interference:

  • OFDM ANI level is a measurement of how well your Sonos components are coping with interference in your wireless environment. The lower your score the better. 0 is best, 9 is worst.

Take a look at the link here to Reduce wireless interference and see if that helps to reduce dropouts.

Is there any particular speaker that you’re experiencing these errors with or is it happening on all?

I use an Asus ZenWifi XT8 mesh setup. I only have Ethernet connected Sonos devices wired to the main router, rather than any additional nodes.

 

Ahh, thanks, I didn't realise red blocks meant this was a concern - as they were all red, I thought that was just part of the design of the matrix, ha.

 

It's happening mainly with the Symfonisk (Toby's room) and the Bedroom speaker, which are at opposite ends of the house, which is why it's hard to pin down which other device(s) might be causing the interference. But also experience less frequent dropouts on all speakers.

 

I'm not sure how practical that guide is - most of my speakers are placed in pretty much the only place they can go in that room, due to furniture layout, window/door placement etc. But I don't have any metal tables, they're just normal wooden tables / shelves etc that are placed by walls.

 

I've already made sure the Sonosnet channel is distanced from the busier end of the spectrum.

 

The most obvious devices that I can think might be causing the interference are Hive lightbulbs - we've pretty much got one in every room. But I'd hate to have to choose between Hive lights or smooth Sonos functionality! Is there a way of finding out if it's the Hive bulbs causing the issue, other than just unplugging the bulbs for a week (and remembering where the lightswitches are!)?

 

Thanks for your help so far.

 

The most obvious 

The red blocks may well be your issue, looks like you have one or more devices causing RF interference.

There is a FAQ on reducing RF interference and you could start with that.

https://support.sonos.com/s/article/3286

 

A second option is to run a diagnostic and contact Sonos Support with the number.

Thanks Stanley 4,

 

Could the diagnostic help narrow down what exactly is causing the interference?

Userlevel 6

Given that all your rooms are showing Red I would hazard a guess that it is the Hive lightbulbs causing the issue.

You could experiment by just changing or unplugging the bulb in the bedroom, then check your matrix again to see if it improves in the bedroom (no pun intended here lol)

I will add that Sonos devices can show as Red in the matrix and still function perfectly well.

Userlevel 6

Alternatively, during the day when it is light, turn your Hub Hive off, then check your Sonos matrix. If the Red turns to Orange or Green that evidences the interference has reduced.

Also play Sonos when the Hive Hub is off to see if the speakers still appear in the app and whether the dropouts remain an issue.

Userlevel 7
Badge +21

Most WiFi channel monitors don’t look at RF usage, just WiFi and that can be a small part of the actual channel congestion. If you can find a true RF monitor it may give you a cleared picture. I use the one built into Ubiquity access points.

The bulbs may well be your problem but suspect everything, it isn’t necessary for a device to contain a radio for it to be an issue. I had a Western Digital external hard drive that would completely kill any Sonos within a few feet.

You can relocate your speakers while testing, think “Sink the Battleship” and put them in new spots to help you spot where the noise is coming from, or harder multiple sources.

Thanks again for further advice. I'll try some kind of RF scanner to see what's causing the interference.

 

I just had one thought. Would switching off SonosNet (if this is possible) to force each speaker to connect to wi-fi individually, be a possible solution? I have v strong, fast mesh wi-fi in all rooms, so though I know the usual benefits of Sonosnet, perhaps this could dodge whatever is causing the RF interference?

 

Or will doing this make no difference to RF interference (and potentially create new problems)?

Userlevel 6

There are numerous threads on here where users have issues with Asus mesh setups when on WiFi only; blaming incompatible asus firmware etc. Disabling QoS (as you have done) and Airtime Fairness can help, but even with these disabled, the issues can still persist. Other fixes can include factory resets of nodes after firmware updates.

These initially put me off purchasing an Asus ZenWiFi for use with Sonos, but I have absolutely no regrets once I did, albeit I have a SonosNet configuration with it.

 By all means you can try a WiFi only setup but I think that might just create additional problems for you to troubleshoot.

 

Ok thanks again for your advice.

 

I had one more thought - and forgive me if it's a stupid one. Would the addition of a Sonos Boost potentially help matters? Was wondering if just ensuring the Sonosnet signal was *really* strong throughout the house would just counteract the interference I'm getting, and potentially avoid a frustrating game of trial and error with my other devices, for the sake of £80.

 

Thanks again in advance,

Mark

I had one more thought - and forgive me if it's a stupid one. Would the addition of a Sonos Boost potentially help matters? Was wondering if just ensuring the Sonosnet signal was *really* strong throughout the house would just counteract the interference I'm getting, and potentially avoid a frustrating game of trial and error with my other devices, for the sake of £80.

 

It would almost certainly do nothing. Your signal strengths are okay/good. You have excessive interference, as already explained. 

Have you tried changing the SonosNet channel? Is it 5 or more channels away from your router’s 2.4GHz? Is the router 2.4GHz using a 20MHz channel width?

Userlevel 6

@ratty beat me to it as a typed a reply.

The majority of your speakers have good communication with each other (the green blocks in the matrix), so Boost unlikely to fix the overall interference being experienced in each room.

Userlevel 7
Badge +21

I just had one thought. Would switching off SonosNet (if this is possible) to force each speaker to connect to wi-fi individually, be a possible solution?

There is no user accessible switch to turn off SonosNet, it is magically created when you wire your first (non-sub/surround) Sonos device to Ethernet.

Having some speakers on SonosNet and some on WiFi can actually cause issues with playing.

There is a switch to turn off the internal radio, for some reason it is labeled “Turn off WiFi” even though with the radio off SonosNet can’t use it either. 

Reply