Help needed with connection address for external hard drive

  • 3 September 2017
  • 17 replies

Badge +1
Dear Sonos Hive Mind. My extensive music library is on an external Lacie hard drive which is attached to my Apple Time Capsule. This used to mean that I could access this library from any of my devices on my home network. However, I cannot work out how to get Sonos system to access this library. Please can someone help me work out what the file location address is that I need to put into Sonos? The info for my music library folder shows: afp://JKT's AirPort Time Capsule._afpovertcp._tcp.local/LaCie/iTunes but this address isn't acceptable to Sonos.

Best answer by JoannadeTiddles 6 September 2017, 17:05

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

17 replies

Might find some info on this here...
Badge +1
The library isn't on another computer. It's on an external hard drive.
BTW, I don't think any URL will like an ' in the resource, like "JKT's", maybe also rename this resource...
Badge +1
It's not a named resource, that is the system address of the folder on my network
As a check, I would change the system address of JKT's AirPort Time Capsule to a name without an ' (apostrophe). I don't think anything except Apple Proprietary Systems will accept that URL.
Badge +1
That won't help with the address format required by SONOS.
Do you have an iTunes folder inside your music favorites on the Mac you are running the Sonos controller software on? If so, point that iTunes folder to the time capsule folder. Then Update Music Library Now under the Manage menu on the Sonos Controller software.
Badge +1
I run the controller from all my devices and use depends on my location. If I'm downstairs, I use my laptop. If I'm in my office, I use my iMac. If I'm down the garden, I use my phone. All my music lives on an external LaCie hard drive which is connected to my Apple Time Capsule, which also acts as my time machine and as my local network. All my devices, including my central heating and my Sonos system, hook into the local network provided by my Time Capsule. But I am unable to point Sonos to the music folder.
Badge +1
I've tried moving all my music across to my iMac, but when it's switched off I can't access it, which is why I have it all on an external drive. Anyway, there's too much of it to have on my iMac which I need for other tasks, and my old laptop wouldn't be able to cope. But when I try to add the folder within Sonos I am given two options. If I try the "another folder or drive connected to my computer" route, and click 'browse to choose a folder that contains music' and choose my music library folder, which is /Volumes/LaCie/iTunes and hit 'Next' I get the message telling me I cannot select a folder on a network to be shared, and "click Back and choose "on a networked device'" ... so, I do this. I am asked to type the path to the network share. And this is what I cannot fathom because the examples given are: \\MyOtherComputer\Shared\Music and \\MyNetworkedStorage\Shared\Music. If I enter \\Volumes\LaCie\iTunes I am then prompted for a user name and password for the LaCie device. The LaCie device has never had a user name and password. So I skip this bit and hit Next, but then get a Sonos message telling me that the add was not successful. My iTunes can find my folder without any problem whatsoever, but Sonos cannot, and I have wasted so many hours on this and am still no closer to a solution and am only able to listen to a fraction of my music.
You need to enter the network path of the share (which is unique to your network so examples shown by Sonos are not going to work). I have a 4TB RAID redundant NAS and it works fine. I don't know a lot about the time capsule but I think the share path will be something like \\NameOfTimeCapsule\NameOfFolder given what you have said, the network path **could be**

\\JKT's AirPort Time Capsule\LaCie\iTunes

BUT - I recommend you change the name of the time capsule because Sonos (and most OSs) will not like the apostrophe in a network path. You can give it a try but I really don't think it will work with "JKT's" maybe make it JKTsAirPortTimeCap (removing spaces is also recommended).

Also review this post for other share requirements from a Time Capsule as a NAS

Hope this helps.
Badge +1
So, I renamed my time capsule, removing punctuation and spaces. I tried the path suggested by Zebray. Again prompted for user name and password for the device. But which device? The LaCie drive or the Time Capsule? The LaCie drive never has had any user name or password, and I don't have a 'user name' for the Time Capsule, so I put in xYz_Airport_Time_Capsule as the user name and entered its usual password. Natch. Nothing doing.
Badge +1
\\xYz_Airport_Time_Capsule\Lacie\ITunes = Sonos was unable to add the music folder
Do you have a log in for the computer that uses the time capsule? If so, I would try the computer username and log in which presumably already has access/permissions to both the time cap and the USB drive. If this doesn't work, and as a test, I would create a share on your mac and place some music in it (like one album). With the computer booted up and on the network, I would use the network path to the share on the computer and your login credentials to the computer with Sonos and see if you are able to get that working. If so, then the problem is with the network share not Sonos. The next step I would try is to browse to the share from the mac and copy the network path (from the finder) and confirm that it is the same path you are using with Sonos.
Badge +1
All my devices use the time capsule - it's my home network hub and backup device. This is so difficult - it reminds me of the old days when nothing used to speak to each other unless you did hefty tinkering.
Badge +1
Oh, hey, I fixed it!!!! I found on another thread that Sonos doesn't like the length of the name either and that I needed to rename my Time Capsule to something less than 15 characters, which I did - and BINGO. 🆒
Great! Happy listening!
Badge +1
Yay! Now listening to music I've not been able to listen to all year. Thanks for getting me part of the way there Zebray!