Answered

Google wifi and 3rd party router


I have Sonos working fine with my existing network, and I use HomeSeer home automation to control it (things like announcing when someone unlocks the front door).
The wifi is terrible in our house, so yesterday I installed Google WiFi to have the mesh network so we can seamlessly move between them. Now I cannot work out how to have both HomeSeer (running on PC on original network) accessing Sonos AND have it working from my phone (on the wireless).
If I set Sonos up wirelessly it works fine, and is visible for control for my phone, but Sonos desktop and HomeSeer cannot see it.
If I set Sonos up wired (original network) then Sonos desktop and HomeSeer can see it, but the Sonos app on my phone insists it doesn't exist.
Google WiFi won't work in bridge mode and still have the mesh network. My phone (on the wifi) is able to connect back to my main PC (HomeSeer runs on 192.168.1.3@1000), so it looks like it is open in one direction, or has the right port-forwarding set up, but I can't work out how to do the same in the other direction to allow the PC to see my Sonos setup.
It feels like using SonosNet should resolve this, but when I plug into the ethernet I lose the ability to connect from my phone app. Not sure what I'm missing.
Any advice appreciated!
icon

Best answer by ratty 20 April 2017, 14:05

That's the way people have managed to use the Google kit. Put all the wired devices on its LAN side. Most wouldn't know a static route or a port forward if it got up and thwacked them. Likewise the vast majority wouldn't need to bridge the primary router or put the secondary router in the DMZ; they could happily use double NAT.

Yes, Google limits bridge mode to non-mesh operation. Try alternative mesh WiFi solutions if you want.

As for "overly restrictive Sonos discovery broadcast", it uses standard UPnP (SSDP) to locate the players. That's designed to operate within a single subnet. If you want to try and operate across multiple subnets you'd need a pretty involved forwarding arrangement.
View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

10 replies

I'm not sure what you are missing either.. but a couple of bits of further info that might help....
1. When wired, and you can see the system from your PC controller, look in About My Sonos System. Can you see all speakers? The phone controller? Do all the speakers have WM:0 next to them?
2. Is it an Android phone? If so, try enabling its ability to connect to SonosNet (if not already done) and see if you can connect your phone to SonosNet rather than home wifi in the phone's wifi settings

Might also be worth trying the following, while Sonos is wired:
(I) Uninstall Sonos app on phone
(ii) "forget" your home wifi
(iii) Turn phone off and on again
(iv) Reconnect to home network
(v) Reinstall app, selecting "add to existing system"

I'm not wildly optimistic that will fix it but worth a try
1. When wired, I can see the speaker which is wired. If I reconnect the second speaker I can then also see that. It does say WM:0. I can't see the phone controller in About.
2. Yes, it is Android. I can connect my phone to SonosNet and I can then connect to the wired speaker.

From my phone, I can connect to Sonos in any configuration. More of a network problem than a phone problem. Sonos just doesn't seem to appear on uPNP when on the Google WiFi, and when wired/SonosNet doesn't show up on Google WiFi so my phone can't connect to it.
You say that Google wifi cannot operate in Bridge mode. Does that mean you have two devices distributing IP addresses? Have you got two subnets running? Do you need to turn DHCP off on the original router?
Yes. Google WiFI has a WAN IP address which is an internal IP address on the first router. Everything can see the internet, but Google uses the range 192.168.86.x whereas the first router uses 192.168.1.x.

I've just set up port forwarding for every port listed on the FAQ page to 192.168.1.219 (internal IP address of the google wifi box on the first router, but it still says Sonos can't be found from the Windows controller. Is that the right place to port forward?
Beyond my expertise here but I would have thought port forwarding unnecessary and you wouldn't want both devices distributing IP addresses under DHCP. For Sonos to work seamlessly you need everything on the same subnet.

But as I say, my expertise is not sufficient here. I don't know if this thread may shed some light.

https://en.community.sonos.com/setting-up-sonos-228990/google-wifi-working-out-the-box-6764073
To which network device are you wiring a Sonos component?
Google WiFi in mesh mode is a NAT router. Sonos controllers one side won't find players the other side. Port forwarding won't help: the discovery broadcast is restricted to the controller's subnet.
So you're saying there is absolutely no way this can possible work, except for making Google WiFi my primary router, mapping over all it's functions and re-setting all my static routes (and changing my existing router into a basic switch with no DHCP). Is this just the limitation of the Google WiFi not having bridge mode when used in a mesh, or overly restrictive Sonos discovery broadcast? Surely there's a way to widen that broadcast?
That's the way people have managed to use the Google kit. Put all the wired devices on its LAN side. Most wouldn't know a static route or a port forward if it got up and thwacked them. Likewise the vast majority wouldn't need to bridge the primary router or put the secondary router in the DMZ; they could happily use double NAT.

Yes, Google limits bridge mode to non-mesh operation. Try alternative mesh WiFi solutions if you want.

As for "overly restrictive Sonos discovery broadcast", it uses standard UPnP (SSDP) to locate the players. That's designed to operate within a single subnet. If you want to try and operate across multiple subnets you'd need a pretty involved forwarding arrangement.
Thanks for your help. Obviously not what I was hoping to hear, but at least I have a clear solution now.