Constant Connection Issues

  • 26 October 2018
  • 33 replies
  • 1168 views


Show first post
This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

33 replies

Badge +3
3rd time lucky.....
Rik Parr,

Note that the Network Matrix is a static display. If conditions are changing, one must refresh the display in order to view the current results. In your case this is unfortunate because users do not have access to a history of events. I suggest that you submit a diagnostic within 15 minuets of an "event", note the confirmation number, and post it here or contact Support. Fine diagnostic detail scrolls away after about 20 minutes. Sonos Staff can review a log of summaries and breakout specific data points.

Looking at your matrix, your system is struggling somewhat with interference. Amber cells in the left column should be watched. Noise floors below -100 are excellent. In the low -80's you'll often have some trouble if the unit is wireless or supporting a wireless unit. Above -80, wireless operation is usually not practical. (On this scale, -80 implies more noise than -100.) ODFM is a collection of strategies used to deal with interference. The relatively high numbers in the amber cells indicate that these units are forced to use a fairly aggressive strategy -- they are struggling with something.

If there are other devices, such as an access point or a wireless router near the amber units, separate them by a couple feet or more. Microwave ovens, when operating, can cause trouble. Some wireless phone extensions are bad neighbors. The DECT phones don't usually cause trouble. Some of the older 2.4 GHz phone extenders cause lots of trouble as do 2.4GHz baby monitors. 2.4GHz wireless security cameras are another device to keep track of.
Badge +3
Thanks Buzz. Th only device that is close to the router/AP's is the lounge P5. What I don't understand is that this is connected via ethernet direct to the router. Later last night I switched to just the TV Room and Kitchen units and they played pretty much fine for several hours with only 2 drop outs in that time. I'll test the lounge unit again today and when it drops out will submit diagnostics and post the reference. There are no DECT devices in the house and the microwave was not in use.
The Lounge is struggling. There is a noise source nearby. Note that it is supporting more wireless nodes than the other wired units. As an experiment, move the Lounge unit away from the router. You will likely observe an improvement in its noise and interference stats -- and an overall improvement in system stability.
Badge +3
That was my next move 🙂 I can move it, however I will have to remove the ethernet as there is no socket in other locations and don't want to have a long cable running around the room. I will give feedback. Thanks for your time.
Badge +3
OK, update, moved the P5 and was connected via Sonosnet with no CAT5. Played Spotify all Saturday evening with no issues, great stuff. I've come to use the system in the TV Room only tonight (Using Radio by Tunein) and had a couple of drops within first few minutes. Submitted diagnostics 790103991. To be honest there is an AP in the TV room and it's within 3ft of the system in here. The room is small and a 'blackhole' for internet, hence the AP, not sure I can move the AP away without suffering issues for other devices, however, but the Sub in the TV room is connected via CAT5. All devices are still WM:0. Thanks, Rik.
Userlevel 7
Badge +21
Try moving the AP to 4 or 5 feet away, too close isn't good.
Rik Parr,

After the move, has the Network Matrix improved?