Audio compression issues with Line-In vs. Airplay 2

  • 5 January 2019
  • 8 replies
  • 346 views

Badge
This article indicates that there are bandwidth limitations when using uncompressed audio with line-in and many speakers: https://support.sonos.com/s/article/1080

I am trying to use iTunes as my music controller, and currently broadcast to an AirPort using AirPlay, the output being fed into a Connect - creating a "Line-In" to my Sonos system. Doing this, I have to use compressed audio to avoid cutouts. A known issue. The compressed codec (SBC) isn't great, so I'd like to use uncompressed audio if possible.

My question is if I should purchase a new Sonos with AirPlay 2 capabilities (even a Sonos One) and connect that to my system, will I have the same limitation of bandwidth and have to use compressed audio? I would plan to send music from iTunes to a Sonos One that I would then group with my other Sonos speakers. Should I be able to use uncompressed audio in this scenario?

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

JazzSinger,

The auto/compressed/uncompressed setting in the Sonos App, applies to a line-in connection only.

The all new Airplay2 stream is sent to a 'compatible' Sonos device such as a 'Sonos One' etc. and that will buffer your stream for playing on the device itself and other speakers that you 'pair' or 'group, etc. with that device.

It’s really quite difficult to say if all will work well in your particular case, as the data packets still need to transverse a reliable 'wired' or 'wireless' network connection that’s free from interference.

I would perhaps look at doing several things...

Check your premises using a WiFi scanner, like wifiinfoview etc. and set your routers 2.4ghz WiFi signal to a channel that is least-used. Then switchover your Sonos system to SonosNet using the least used non-overlapping channel... one that is at least 5 channels apart from your router channel. See this link:

Switching a Sonos Household between Wireless & SonosNet Mesh mode & vice versa

When running all your devices on SonosNet, remove the local WiFi credentials stored in the Sonos App.

Ensure all your wireless devices are more than 3 - 4 feet apart from one another to reduce possible interference.

Check the community for further information on how to check your Sonos Matrix to ensure your devices are connecting together well with minimum interference and if necessary consider cabling devices that are still having problems.

Another useful feature that may provide additional stability is to store your Sonos IP addresses in your routers DHCP Servers Reservation Table.

It’s also worth reading through the information in these two links below:

Reducing wireless interference

Home Network Stability

If you do not fully understand some of the issues being suggested, then it’s perhaps best to get hold of a friend that can assist you, as mentioned in the second link above.

I also have some further information about how best to setup an Airport Express device with a Sonos line-in. I will dig out the info and I will post that below in due course. You may perhaps find that useful too.
Ah, here is the article on the Airport Express Setup ... see the pasted info below (from step 4 onwards):

Adding an Airport Express to Sonos line-in (Play-5 Speaker).

Firstly, setup the Airport Express (AE) A1264 (or higher) via the iPad. You may want to factory-reset the airport express by holding in the reset button on the bottom of your device till the light starts blinking... About 10 seconds or so. It's worth doing this, if you bought a device second-hand.

Step 1
Install the Airport Utility App on your iPad/iOS device.

Step2
Go to iPad/Settings/wifi and wait a few minutes (it can be a 2 minute wait) and the default name of Airport Express device will appear below the list of wifi networks. Select it and set it to use your wifi and enter password etc. When prompted choose to 'join an existing wireless network' ... Don't create or extend the network...

You can give the Airport Express a name ... I will leave you call it what you want, but ’Sonos'.. or something similar is fine (this will be the name you will see in the AirPlay list on your iPad) ... You can change it later in the Airport Utility App... The app is useful for changing things later and updating firmware etc.

Step 3
Okay once the AE is set up on your wifi network, we can now plug in the 3.5mm to 3.5mm audio cable between the AE and the Play-5 line in.

The speaker and Sonos Controller app will detect the fact the line-in is now connected.
The Sonos Controller will actually set things up automatically ... But we need to then change a few things.

Step 4
In the Sonos Controller go to Settings/Room Settings and select your Play-5 Speaker (Room Name) and then select the Line-In

Now choose 'Line-in Source Name' and change this from 'AirPlay Device' to 'Satellite Receiver' from the list, but then before accepting the settings rename it in the top text box to 'AirPlay' and click the done button (top right hand corner).. You will have to then navigate back to Settings/Room Settings and select your Play-5 Speaker (Room Name) and then select the Line-In again to continue.

Leave the Line-in (Source Level) set to Level 4 (AirPlay) ... This is a voltage adjuster and it's fine set to its default ... The higher the level is set in this list the louder output you can get from the AE, but you may get some distortion at high volume if you set it above the default level 4.

The final option on this particular line-in settings screen is about whether or not to let the Play-5 speaker (or any other Sonos speaker on your network) autoplay the line-in audio in a particular room of your choice. (Great, if you have more than one speaker).

It will play automatically on the speaker/room that you select as soon as it detects audio coming through the line-in port... Personally I disable this feature by selecting 'None' ... but most people like it switched on .. So switch on Autoplay to begin with and choose your Play-5 room.

Step 6
Having chosen to autoplay the line-in audio, you will get some more options appear. The first is a toggle switch to also play the line-in audio on any other Sonos speaker(s) that are grouped with your original Play-5 speaker ... I would switch that on by default. (It may be on already - I can't remember?)

You can also automatically play the line-in source with an automatic start-up volume ... Yes leave that on too ... It defaults to 50% ... You can use the slider bar here to set the volume that you prefer, but leave it at 50% for now. (Something you can easily adjust later, if you want)

Step 7
This is the last step.. It's a change located in a separate area of the Sonos Controller settings ... Go to Settings/Advanced Settings/Audio Compression and set it to 'UNCOMPRESSED'

and that's it.. having saved all the settings, you can now close the Sonos controller.

On your iPad/iOS device open up any AirPlay compatible app such as BBC IPlayer and play a TV show, or radio channel and then choose the AirPlay button and send the Audio etc. to play via your Airport Express (whatever name you gave it in step 2 above) ... The video will play on your iPad and the audio should automatically come out your Sonos speakers in perfect sync. (as near as damn it).

Obviously any audio from any AirPlay app will come out your speaker automatically whenever you select the Airport Express name from the AirPlay list of devices.

Everything will also work on your iPhone/Apple TV etc via their AirPlay list.

Hope that helps ?
Badge
Wow! Thanks for the very detailed replies. I have done some of the suggested steps, but I have some reading to do ....
Wow! Thanks for the very detailed replies. I have done some of the suggested steps, but I have some reading to do ....
That’s okay. Hope you get your AirPlay dropout issues resolved soon.?
Badge
Seems that I've tried much of what you have suggested thus far. One question, though - for those of us on mesh networks (I'm using a Linksys Velop), might we be better off not using SonosNet, since there is strong WiFi signal throughout the home?
Userlevel 7
Badge +21
Seems that I've tried much of what you have suggested thus far. One question, though - for those of us on mesh networks (I'm using a Linksys Velop), might we be better off not using SonosNet, since there is strong WiFi signal throughout my home

Not necessarily. Sonosnet is also a mesh network and pretty reliable. If you have two or three speakers, and they are located far from each other, your Velop may be a better option. If you have speakers located close to each other, it might be better to be on their own network, separate channel from the Velop. Lots of factors come into play in the decision, but a good wifi network definitely does not mean you should put everything on your router's wifi.
Badge
If it helps, I currently have 2 Play:1s, 1 Play:3, 2 Connects, 1 Connect:Amp, and 2 Boosts - 8 devices total.
Personally I would always opt to use SonosNet as it is 'exclusive' to Sonos devices, just one Sonos device connected to the main hub. That’s my preference and works well for me.

I keep the non-overlapping separation between the SonosNet channel and the WiFi channels and remove my WiFi credentials from the App. Seems to work well for me.