ASUS RT-AC88U

  • 4 September 2016
  • 44 replies
  • 16162 views

Userlevel 3
I recently bought a new wifi router/access point an ASUS RT-AC88U

Once I switched over to it I found that I had sporadic access to my Sonos speakers (Play 3, Playbar + Sub).
Sometimes I could connect to the speakers, sometimes I couldn't. When I could connect I'd sometimes be able to see all the rooms and other times only 1.

I played with a bunch of wifi settings and finally tracked down the culprit.
Wireless menu >> Professional Tab >> Airtime Fairness
This setting is enabled by default. When I disabled it my access to my Sonos was restored to it's former fully functioning glory.

44 replies

I have this router and have been having the same issues. I'll try this out and see if it works for me. Thanks!
Works great, thanks so much for sharing!
This solution worked perfectly, thanks for your help!
I recently bought a new wifi router/access point an ASUS RT-AC88U

Once I switched over to it I found that I had sporadic access to my Sonos speakers (Play 3, Playbar + Sub).
Sometimes I could connect to the speakers, sometimes I couldn't. When I could connect I'd sometimes be able to see all the rooms and other times only 1.

I played with a bunch of wifi settings and finally tracked down the culprit.
Wireless menu >> Professional Tab >> Airtime Fairness
This setting is enabled by default. When I disabled it my access to my Sonos was restored to it's former fully functioning glory.
Thanks All. I spent 8 hours of my weekend trying to resolve my Sonos connectivity problems- including 1:20 on the phone to the UK support guys from Singapore. I will try the fix as soon as I get home.
New playbar and sub wouldn't configure until I changed this setting. THANK YOU!!!
Wish I'd seen this thread 2 hours ago. Worked like a charm!
Worked for me too. Thanks!
OMG! I spent two days attempting to set up Sonos system with new ASUS RT-88U router. This worked!!!! Happy New Year now since I missed it working on this.
thanks man, that worked for me as well! Just created an account here to post this. Surprisingly even the cable setup did not work with this setting enabled.
So glad to have found this. I was having the same problem which was also occurring with a heos system--took forever to connect the app to the speakers and several minutes later speakers would disappear from the app an no longer controllable. It started happening when I introduced the rt-88u router so I knew it was related. I played around with a lot of settings. Disabling airtime fairness fixed both the sonos and heos systems immediately. thanks again!
SO happy I found this. Lifesaver. Part of the problem is the Controller app SUCKS at telling you what is going on. It just doesn't find the network but gives you zero info. Ugh.
O.M.G.. I've been racking my brain trying absolutely everything I could think of to try and get my SONOS to work.. Made that one single change and it connected and set up the new SONOS instantly.. Thank you @ianlimn!!
😃
Oh my god.... it was driving me nuts... I cannot believe someone figured it out!!! thank you so much
Thanks!!!
worked great thanks
I recently bought a new wifi router/access point an ASUS RT-AC88U

Once I switched over to it I found that I had sporadic access to my Sonos speakers (Play 3, Playbar + Sub).
Sometimes I could connect to the speakers, sometimes I couldn't. When I could connect I'd sometimes be able to see all the rooms and other times only 1.

I played with a bunch of wifi settings and finally tracked down the culprit.
Wireless menu >> Professional Tab >> Airtime Fairness
This setting is enabled by default. When I disabled it my access to my Sonos was restored to it's former fully functioning glory.
Worked great for me! Thx so much. Been trying to fix this fir a week!!
Just bought an Asus AC5400, had the exact same issue with it. Thanks!
This message should be pinned somewhere.

Had problems connecting speakers to the network and when I changed the settings, everything worked perfectly.

Thank you very much.
This message also caused me (a dedicated lurker) to create an account to post.

It also stopped me moving away from Sonos products. I have 2 Play:1 devices which have been a little random in terms of connecting and this had caused me to put on hold any additional purchases (I had planned on replacing the 5.1 setup in the Living Room and adding speakers to other rooms). More importantly the family has lost trust in them and were pushing me to seek alternatives.

All of a sudden I can connect to my speakers again in a (so far) reliable way. No more firing up the controller app and wondering "Will I be lucky this time".

Will see how things go for a few weeks and if all goes well, and the family learn to trust it all again I will be able to reinstate my original "Sonos Everywhere" policy.
This was driving me crazy. Once I disabled Air fairness, we are up and running. I was getting concerned I had to replace the new router or get another just for the Sonos. I really enjoy the speakers and would have hated to move to something else.

Thanks for figuring this out.
make sure that you set it for both your bands (2.4 and 5ghz) !
Be sure to set it for all bands!
Thanks a lot, you made my weekend. @Sonos Staff: please include this in your FAQ!

Reply