Question

AirPlay from Mac no longer working after Pause

  • 16 January 2021
  • 3 replies
  • 68 views

When I stream a movie from Netflix onto my MacBook Pro in the Safari browser, then pause the movie, then unpause it, the sound is no longer playing on my Sonos Amp connected via AirPlay. I found numerous other people with the same problem on the Internet but no solution. This is obviously not acceptable.


3 replies

Userlevel 5
Badge +16

Hi @Daniel_NYC

Thanks for reaching out to the Sonos community and letting us know about your concern. We appreciate you for sharing your feedback with us.

You can use AirPlay on your iPhone, iPad, or Mac to stream your favorite music, movies, podcasts, and other audio directly to your Sonos. Sonos is only compatible with AirPlay 2. Check if your Apple devices can play AirPlay 2 audio in Apple’s AirPlay article.

To help you out with this, allow me to ask a few questions to isolate the issue.

  • Is your MacBook wired to your router or WiFi connected?
  • Is your Sonos Amp wired to your router?
  • Do you experience the same if you stream movies on other sources on your MacBook?
  • How about streaming via AirPlay using your mobile device, did you encounter the same problem?
  • Have you tried rebooting all your network devices and your MacBook?

 

Please start streaming via AirPlay on your MacBook. If you encounter the issue again, submit a diagnostic report for us to check.  Just include the confirmation number in your response. 

If you need help with any other information, please be sure to let us know. We’ll wait for your reply.

Hi Rowena,

Thank you for your response!

  • My MacBook Pro is compatible with AirPlay 2. I’m on the latest version of MacOS too.
  • My MacBook Pro is connected to the ASUS router via Wi-Fi (latest Firmware)
  • My Sonos Amp is connected to the same router via LAN cable.
  • I tried streaming from Vimeo.com (within the Safari browser), and I encounter the same problem.
  • When streaming music from Apple Music, I do not encounter the problem as much. The audio reconnects after 3-5 seconds after pausing it for an hour. Slow, but not as terrible.
  • I tried streaming a self-recorded video from my Photos app on an iPhone 12 Pro, but my Sonos Amp wasn’t available as an option to select in the AirPlay menu. Only my neighbor’s Apple TV showed there.
  • I have tried rebooting all devices involved. It didn’t make any difference.

According to this thread, it is a problem that very many other Sonos customers are facing:
https://en.community.sonos.com/troubleshooting-228999/airplay-cuts-out-on-pause-6828388?postid=16509782#post16509782

I submitted my System Diagnostics. The confirmation number is: 70457172.

Thank you,

Daniel

Userlevel 5
Badge +16

Hi @Daniel_NYC

Thanks for your response and for updating us. 

Based on the diagnostic, an audio dropout was detected due to sync errors, and this may cause audio playback failure. This could be the reason why your Sonos Amp wasn’t available as an option to select in the AirPlay menu.

Let me suggest the next troubleshooting steps you can do. 

  • Sequential reboot to refresh your network and all your Sonos devices connection.
    1. Unplug your network devices (modem, router, any wireless access points on the network) from the power and wait for 60 full seconds before you plug it back in.
    2. Once the router is back online, unplug all your Sonos devices from the power.
    3. Please wait 15 seconds before you plug back them back in.
    4. Force close the Sonos app from your iOS or Android device.
    5. When the status light on your Sonos speakers are solid white, get back on the Sonos app and check if you're connected.
    6. Test playback from and observe Sonos performance.

 

If you're still facing the same issues, I recommend contacting our phone support team with your full network setup including the make and model to further look into this and to check why AirPlay no longer works after a pause on your Mac. 

Let us know how it goes and if you have any other questions or run into any issues, please do not hesitate to reach out.

Reply