Question

Play:5 Gen2 with a S1 fw cannot upgrade to S2

  • 18 October 2020
  • 3 replies
  • 112 views

Got a play 5 from a friend inside SOnos,the device info show as below:

Sonos OS:S1

Version:5.5

After I initiated the device and include it by S2 (whatever iOS or Mac)I can do nothing but update it first.But! But! But! Failed every time with code 10(I can not find out the code 10 meaning from sonos support) Sonos engineer guess maybe the device using a test FW …which god can save me and the play 5?


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 5
Badge +16

Hi @Timber1979, thank you for reaching us out and welcome to the Sonos Community. I appreciate you for providing us your concern and for providing your feedback. Let me help you with this.

Error code10 occurs when there is an issue upgrading your Sonos system firmware. This can happen when the Sonos S2 app tries to perform an update. To resolve this error, you need to reset your Play 5 to its factory settings. 

After the factory reset, you will get a flashing green light from your Play 5. This indicates that your Play 5 is ready to be setup.

  • If you only have the Play 5, you need to create a new Sonos system.
    • Reset App - Settings > App Preferences > Reset App
    • Launch Sonos App > Set up a new system 
  • If you have other Sonos devices, you set up your Play 5 in the Sonos app.
    • Settings > System > Add Product
  • Once you have completed the setup, please run an update to your system.
    • Settings > System > Check for updates

If encounter problems while setting up your Play 5, please try to connect it directly to your router using an ethernet cable.

Let us know how you get on with the advice above and submit a diagnostic report for us to check. Just include the confirmation number in your response so that we can look up the information.

If you have any questions about this. We and the community are always here to help.

First of all ,send my thanks to U Rowena, Unfortunate ,my device(PLAY:5) doesn’t work still.What I have done:

1-cable connect to router driectly

2-reset hardware follow your way

3-setup and update follow your way step by step, but failed with code 10

4-diagnostic NUM=849688803 (UID=*****************)

5-some other info important:I got the PLAY:5 form a friend who was a SONOS employee.So I guess the device installed a beta version firmware

cut from system info as below:

SN: **-**-**-**-**-**

Sonos OS: S1

Version: 5.5(internal version 30188220ci10iMX6_Alpha178638)

HW Version: 1.13.1.5-1

S ID:(Unknown)

IP : 10.10.10.18

WM: 0

OTP:

 

*Moderator Note: Please censor personal information when posting.*

Userlevel 5
Badge +16

Hi @Timber1979, thank you for your detailed response and for submitting the diagnostic report. Let me check on it for you.

Upon checking the diagnostic, you were able to set up your Play 5 in the S2 system. You're getting the error code 10 because your speaker failed to update. 

Let me suggest the following basic troubleshooting steps if this will work for you by setting up your Play 5 in the S1 system.

  1. Download the Sonos S1 app (black app background) from the App store.
  2. Factory reset your Play 5.
  3. When your Play 5 is giving you a flashing green light, you can set it up
    • Launch Sonos App > Set up a new system 
  4. Once you have completed the setup, please run an update to your system.
    • Settings > System > Check for updates

If you still getting the same error after performing the steps above, it would be best for you to continue working with us over the phone to expedite the process. 

To further assist you with this, I recommend contacting our Sonos Customer Care support for more in-depth troubleshooting steps to provide you the best option.

Please let us know if you still have further questions or concerns. We are always here to help.