Question

can’t connect to wifi

  • 26 June 2024
  • 8 replies
  • 103 views

Hi I’ve recently changed my WiFi and can’t connect my Play 5 to the new router (BT Smart Hub 2). I’ve done a factory reset, after which I get as far as entering the WiFi password, then it says connecting to the WiFi but after a few minutes it says your product has been connected but might not show in your system, in which case unplug the product, plug back in and complete the process on System Settings. When I try this it doesn’t find my Play 5 ?


8 replies

I too have problems with BT Smart Hub 2. I needed help from Sonos Support to get Roam 2 working - and they did get it going. I recently bought a Ray soundbar, that will connect via ethernet just fine, but  I have the exact same problem as you when trying to connect to BT Smart Hub 2 by WiFi. I wasted an hour with chat support, before they recommended I telephone support. I recommend you contact Sonos telephone support directly.

Thanks for the feedback. I have tried ringing support but gave up after being on hold for an hour. I’ll try again and hope they aren’t as busy !

Userlevel 7
Badge +13

Have you tried installing the Sonos desktop app for Windows or Mac from the Sonos website, and see if the speaker shows up there? 

AFAIK, Sonos support only list iOS, Android and Web App. According to the support chat technician, the Web App cannot be used to install devices/modify device settings. Could it be that the desktop Apps were deprecated at the same time the mobile S2 was ‘improved’?

Userlevel 7
Badge +13

AFAIK, Sonos support only list iOS, Android and Web App. According to the support chat technician, the Web App cannot be used to install devices/modify device settings. Could it be that the desktop Apps were deprecated at the same time the mobile S2 was ‘improved’?

 

Nope. Let Google into your life. 😉

https://support.sonos.com/en-gb/downloads

;) - isn’t it so Sonos to require Google to find information on their site …. I followed your link & downloaded App. Launched App but couldn’t find my system. Checked my Firewall settings (Sonoma 14.5) were set to ‘Allow incoming connections’, but still could not connect. Disabled ExpressVPN to get it to work. AFAIK, it’s a tool to manage a Sonos radio subscription/music queues, etc.

Preferences(sic) clearly state “Open the Sonos app on a mobile device to manage your system”.

After two hours on an online chat with Sonos Support we didn’t resolve it but did establish that it looked like it was the BT hub not allowing Sonos to connect wirelessly. Then I found a post on the Community advising to change wireless mode on the Hub from 1 to 3. Tried this and sure enough success. After connecting I changed mode back to 1 and it’s still working 👍

Good catch, and thanks for coming back with that.

For others: go to 192.168.1.254 => Home => Advanced settings => Advanced wireless {admin password} => ‘Change settings’. Click (?) for description of Modes.

Mode 3 - Change to this mode if your wireless devices don’t perform well using mode 1 or 2. Selecting this mode will reduce the latest features as well as wireless range and throughput compared to Mode 1 and 2. This will allow for the broadest range of devices to operate on the wireless. The features that are reduced include: power saving procedures, traffic aggregation methods and Multiple Concurrent data streams.

Click ‘Mode 1’ to open options menu. Select Mode 3. Select ‘Save’ to save changes.

Reply