Only playing half a song before skipping to the next song

  • 14 July 2014
  • 7 replies
  • 10702 views

I just purchased my sonos system today and was excited to set it up. I downloaded the sonos controller from the App Store for my iPhone 5S. I have a bridge and a play 1. I started playing music through the "on this phone" option. I added one of my playlists to the queue and started listening, however, each song only plays half way through before it skips to the next song. Is there a setting somewhere that I'm missing? Not a happy camper right now 😞

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

7 replies

Userlevel 7
Badge +22
Have you tried or setup to play music from any sources other than "on this iphone"  With "on this iphone" you are relying on the wifi connection your iphone has more than the Sonos system.  Just curious if your having other skipping problems with any other sources.

It is some type of interference most likely causing.  As far as interference goes - make sure the bridge you have hooked to your router is as far from router as possible (space/cable wise).  You don't want the bridge unit right up against your router.

Do you know what channel Sonos is on compared to your home system.  I like to keep Sonos on Channel 1 and home system wifi channel 6 or above.
Hi Chris, Thanks for your reply. I haven't tried any other controlling sources yet, I was too excited to get started. I am streaming through pandora right now and not having any issues with song skipping. My sonos wireless channel is on 6 (not sure about my home network...I'm not too tech savvy) and my router and bridge are separated by at least three feet. It's most likely operator error but most of my music is stored on my iPhone so I'd like to figure out which piece of the puzzle I'm missing.
Userlevel 7
Badge +22
Try your Sonos on Channel 1 and see if you can play from iphone better.
Userlevel 7
Badge +22
No its not operator error - It just sounds like you have a little wifi interference hopefully changing channel will clear up before have to dig further.
Userlevel 7
Badge +22
See the difference with Pandora is that Sonos is connecting directly to Pandora via the wired bridge to your router. 

However, when you play from your iphone you are sending the music via your home wifi to your router (where then it goes to Sonos).  The interference is effecting the link between your iphone and router and therefore causing it to lose the stream.   Also when playing music that resides on your iphone you need to make sure the iphone stays connected to your home wifi (that you don't take it to a part of house that has week wifi signal where it loses connection).

That is why it is preferred to link Sonos to the iTunes database on computer in your home that doesn't wander on and off your network.  Then you have access to all the same songs that are on your phone without having to rely on streaming from the phone itself.
After four years and the problem still persists intermittently...guess it's too bad for us consumers.
Not so much. The great majority of people who have posted a diagnostic and conversed with Sonos have been able to rectify their issues with the local wifi signal.