Answered

Sonos voice control with Deezer (as only service) will not play Deezer playlists.

  • 21 December 2023
  • 8 replies
  • 96 views

As topic says, using voice control on Sonos ROAM will not play a playlist that is saved on Deezer.

The command instead seem to be searching for the playlist name as a search term, and then playing those songs.

Example:

Hey Sonos, play ‘My Favourites’ [and various variations inclusive of service name etc]

 

The playlist is saved in Deezer as My Favourites, and still successfully add to the list via voice command to add a song to ‘My Favourites’

This featue has been the most used and why I used Sonos, as it use to work.

Any suggestions? Anyone else having same issue?

 

I found a near matching topic here [closed] 


I did update to latest firmware.

icon

Best answer by Ken_Griffiths 21 December 2023, 18:20

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

8 replies

It seems to be working okay for me - I have a Deezer playlist called “Local top tracks” … if I say “Hey Sonos play local top tracks from Deezer” then it plays that chosen playlist. 

I think if the playlist is new, it can sometimes take a while for it to be registered with SVC, so maybe give it 24 hours and try it again.

It seems to be working okay for me - I have a Deezer playlist called “Local top tracks” … if I say “Hey Sonos play local top tracks from Deezer” then it plays that chosen playlist. 

I think if the playlist is new, it can sometimes take a while for it to be registered with SVC, so maybe give it 24 hours and try it again.


Hey, thanks for your reply. Is good to know it works for others, so looks like it may be a unique issue on my setup/linkage.

It is not a new playlist, and woked for all of last year, and stooped around feb this year. just not gotten into it, as Flow was good enough a replacement until now.

 

The end user here is my 10 yr (autistic) daughter, who has become emotionally attached to the sonos voice system / device. And gets quite upset her favourites will no longer play.

I tested/investigated fo quite a bit, seems for me, playlists will not lay, it doe s a search instead.

I will res-etup everything, see what happens.

 

It maybe easier to reproduce the issue and then submit a Sonos system diagnostic report from within the Sonos App, note it’s reference and then contact/chat with Sonos Support Staff via this LINK and see what the Staff can perhaps suggest to resolve the matter.

Thanks @Ken_Griffiths, i just did that, as I still cannot get the sonos roam to play any playlists from deezer, or it’s own internal playlist.

 

I have tried all forms of voice commands, as well as what you suggested.

 

The roam has become a brick, unused as my child cannot get her music to play.

Thanks @Ken_Griffiths, i just did that, as I still cannot get the sonos roam to play any playlists from deezer, or it’s own internal playlist.

What did the Staff discover/say about the matter ..?

waiting for a return message. Off hand they not sure what issue is, but it *may* be related to fact I use a family deezer account, and her login is a sub account. Links up fine in sonos, used to work fine. just something.


I cannot let my child use my account, as her (hectically different to mine) music then plays under random plays / gets mixed in with my own, when I code, and it completely breaks my zone!

 

waiting for a return message. Off hand they not sure what issue is, but it *may* be related to fact I use a family deezer account, and her login is a sub account. Links up fine in sonos, used to work fine. just something.


I cannot let my child use my account, as her (hectically different to mine) music then plays under random plays / gets mixed in with my own, when I code, and it completely breaks my zone!

I guess you may have to wait for the Sonos Staff to perhaps resolve it and then see what happens when they get back to you,  or follow-up the case reference with a further call to see how the matter is progressing.

Just spend about 4 hours on a call with their support. Went through all the troubleshooting steps, and they could not determine issue.

 

They acknowledge there is an issue, as it *should* work. The issue has been passed to the voice control team now.

 

At present the best guess is that it may be the family account setup that is not handled correctly