Answered

Roam stops working and disappears from app

  • 24 May 2023
  • 5 replies
  • 315 views

Userlevel 1
Badge +1

Roam stops working, assistant says can’t connect to wifi, Roam not visible in Android app.

In Windows desktop app Roam is visible and works normally, check for update and desktop app reports that an update is required, Roam is updated, after update Roam appears in Android app.

This has happened on a number of occasions, I wonder why?

icon

Best answer by Corry P 25 May 2023, 14:44

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Userlevel 7
Badge +18

Hi @Steerpike 

Thanks for your post!

I’m glad to hear that you got this fixed by yourself, but it certainly shouldn’t be happening.

I’d be tempted to look at the differences in how your Android device and your PC connect to the network - are they using different WiFi access points, is the PC using ethernet, etc.

If your router was supplied to you for free by your Internet Service Provider, I recommend you reboot it by switching it off for at least 30 seconds several times a year as a matter of course, or spend at least about £50-60 on a third-party router to replace it as the hub of your network - you do, after all, get what you pay for.

These are guesses though - if you experience further issues, I recommend you get in touch with our technical support team who have tools at their disposal that will allow them to give you advice specific to your Sonos system and what it reports.

I hope this helps.

Userlevel 1
Badge +1

@Corry P thank you for the response.

I have other Sonos speakers that do not have problems, I also have Alexa and Google speakers that do not have issues, and all of these are on the same network as the Roam.

The Roam has other issues from time to time with the Google assistant failing to work correctly, and swapping to Alexa does not help.

I have long suspected that the cause may be that the Roam is set to switch off to conserve battery and that therefore it misses updates and then simply doesn’t work until it is opened in the Windows app and provided with the update.

Sometimes the Android app fails to see the Roam even when it is playing music started by the Windows app, and even more strangely, if the Windows app is used to group one of the other speakers with the Roam then that speaker disappears from the Android app as well.

Userlevel 7
Badge +18

Hi @Steerpike 

That certainly sounds like network issues to me! Please be aware that Sonos utilises your network in ways that many other devices do not, and the Roam can behave a little differently than most other Sonos devices, depending on your setup.

I don’t know your setup or your network topography, so anything I say at this point would be a guess, but I’m fairly confident that if you were to get in touch with our technical support team they would be able to find out the source of the problem, if not fix it outright.

If you happen to have a UniFi WiFi system, I know a few steps that will probably help - please let me know if so.

I hope this helps.

Userlevel 1
Badge +1

@Corry P Thanks again. I have considered UniFI but not invested, and currently just have a simple system using a TP Link AC5400 router. If I can summon the enthusiasm I will contact support...

Userlevel 7
Badge +18

Hi @Steerpike 

Yeah, I’m not a fan of phone calls either 😁

If you see any more strange behaviour, please submit a support diagnostic soon afterwards (if the Roam goes missing again, please submit once from your Android device and again from your PC) and post the given numbers here - I’ll be happy to take a look for you.