Answered

Roam audio drop-out when grouped to Beam (TV)

  • 10 February 2023
  • 12 replies
  • 442 views

Hi All,

I am having a problem with audio drop-out when my Roam is grouped to my Beam (TV).

The system is:

3 x Play 3

1 x Beam

1 x Sonos One

1 x Roam

 

Controller on smart phone Sonos S2

All are WM:1 (WiFi, nothing wired).

Network shows SonosNet Channel 6 (greyed out)

WiFi is old-ish, 2.4 GHz only

Nothing is in surround sound or stereo pair set-ups.

TV is a Sony Bravia. HDMI / ARC connection to Beam

No voice control or services in use

 

I have used the system for several years without hitch. The Sonos One and Roam are new additions. Set-up went as expected and these 2 new units work normally when playing music from my Laptop / Music Library and  from mobile phone  “On this mobile device” and from mobile phone “BBC Sounds”. (I don’t have any music streaming accounts)

 

The main use of my Sonos system is to hear whatever is playing on the TV throughout the house.  Mainly Digital  Freeview TV / Radio by aerial and BBC iPlayer via internet. Our family demographic is one where everybody can use the TV remote to select Radio / DVD/ Hard Disk recorder, but not everybody can work a smart phone / navigate apps, so grouping the Sonos speaker system to the TV /Beam is important. This has always worked very well in the past.

 

My new problem is when I group to the  “TV : Everywhere”, all the speakers are working as expected except for the Roam , which suffers from audio “drop-out” such as to make it un-listenable. The drop-out is always present and has silent periods ranging from a few tens to a few hundreds of milliseconds in a random way.

 

I have read several community references to this problem, stuttering and skipping etc., and have tried some of he recommendations, such as moving the Roam next to the WiFi router, near the Beam, resetting the Roam, pressing pause then run on the Roam, turning off the other Play 3 speakers but to no avail. Our house is quite remote so no neighbours WiFi  intrusion, no doorbell cameras or much other load on the WiFi. I am somewhat reluctant to tweak anything in the (rented) WiFi Router settings as this is outside of my comfort zone.

 

I have tried adjusting the Beam “Group Audio Delay” (GAD), as recommended by Ken_Griffiths in a similar problem report from BenDrieze.

Default 75 msec  and  113 msec and 150 msec all show the same drop-out problem.  When set to “Max” 2000 msec, the dropouts do indeed stop but they are replaced by  a long  silent period of 6.45 seconds which shows up randomly after anytime from  1 to 25 minutes, yes, very infrequently but annoying. Unfortunately using the Max Group delay of 2.000 seconds  does not work in our household set-up as the long pre-echo / delay  heard as people move to and  from the TV room to other parts of the house causes confusion.

 

Tried the TV Dialog Sync, but no effect here.

 

For interest, I checked the duration of the dropouts by setting the TV to play a YouTube video called 1kHz Sinus tone and placing a microphone next to the Roam and capturing the signal on a Laptop using Audacity.  This displays the dropout / silent periods to good effect. On the shorter GAD settings the Roam sounds like a morse code signal; all other speakers give the constant 1 kHz tone. The  puzzle is the 6.45 second silence which shows up on the  Max GAD setting during several test runs; why such a fixed and repeatable value? I have tried to attached a couple of screen shots showing the Audacity display.

 

If anyone can make any suggestions as the why the Roam is not correctly picking up the TV / Beam audio when all the other speakers are happy , yet the Roam is working just fine when playing the Music Library, I am keen to listen.

Thanks !

 

icon

Best answer by Corry P 17 February 2023, 10:30

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

12 replies

Userlevel 7
Badge +18

Hi @Silurian 

Welcome to the Sonos Community!

Although grouping for TV audio generally works, it’s unsupported as we are aware that it heavily depends on network health and available bandwidth. When a Home Theatre device plays to a Sub or Surrounds, dedicated, low-latency 5GHz WiFi links are used so the satellite speakers can stay in-sync with the HT device, and it can in turn stay in sync with the picture. When playing to other rooms, however, the normal network must be used and this can cause the interruptions you describe as the HT device doesn’t normally try to buffer as much of the audio, as would happen with music sources, in order to attempt to stay in sync. This can be adjusted with the Group Audio Delay, but you have already tried this without success.

Therefore, the only thing left to try is seeing what the speaker says about it - please recreate the issue and then submit a support diagnostic, replying here with the number given, and I’ll take a look for you. Please be aware, however, that you may simply be reaching a limit of how much your WiFi can do in an amount of time. For this reason, it may help to wire the Beam to ethernet permanently - although this won’t change the way the Roam connects to the network, it will change the way other devices do and thus may free up WiFi bandwidth for the Roam. It’s also possible the Beam is reaching the limit of what it can do with it’s 2.4GHz link, so ethernet would improve things there too. 

If you can’t wire the Beam to ethernet, try wiring another speaker instead, but wiring the Beam would be preferential. I know you don’t have any surrounds, but I’ll say not to wire a surround to ethernet just in case someone else reads this.

I hope this helps.

Hi Corry P,

Thanks for the reply.

The Roam was still showing my drop-out problem when I submitted diagnostic request and the following number was received.

 

1794457629

 

Best regards.

Userlevel 7
Badge +18

Hi @Silurian 

Well, the good news is that you don’t need to worry about your neighbour’s WiFi! 

All your speakers (barring the Roam, ironically) are reporting interference - I recommend reading our Reducing wireless interference help page and looking to reduce sources near your speakers. Please make sure no sources are near your router either.

I also recommend you switch off your router for at least 30 seconds. Please repeat this several times a year.

It does look like the best thing you can do is permanently wire a Sonos product to the router with an ethernet cable, as I suggested before - it should make your speakers stay connected more reliably (they are reporting multiple disconnects) as the wired speaker will create a private WiFi for the other speakers to use. If you do so, please ensure all rooms are visible in the app, then change the channel Sonos uses to channel 11: Settings » System » Network » SonosNet Channel » 11. After doing so, please ensure all rooms are still present - if any go missing, revert to channel 6 to retrieve them and try again. Please keep the wired unit at least 1m away from the router.

I hope this helps.

Hi Again Corry P.

Many thanks for your suggestions. I have connected the Sonos One speaker to my WiFi router and this now allows me to set the channel to 11. After  a few interruptions the system came back to life but I’m afraid the Roam still has the audio dropout problem, just on grouping to the Beam /TV., playing music “from this device” is still perfect on the Roam and all other speakers. It seemed to take a few mins for the system info to show WM:0 on all the speakers ( except the Roam of course).

I then tried  the 30 seconds power OFF/ON to the router, but after a bit of settling down, the system ( now on channel 11) works pretty much as before. I notice the IP addresses for each speaker have changed, but guess this is normal. The Beam seems to show WM: 1, whereas the PLAY:3’s and  Sonos 1 are now at WM:0. Power cycled the Beam, but no change, all rooms still present and working OK except for the Roam  audio drop-out.

I sent another diagnostic request which replied with the number:

1312447433.

Hope that might give another clue to my problem.

Best regards.

 

Userlevel 7
Badge +18

Hi @Silurian 

Thanks for the diagnostics - after a big change like that, a new one really does help.

According to the previous diagnostics, your Beam should have no trouble connecting to SonosNet (as in, it’s within signal range), though at the time of the more recent diagnostics, it was still using the WiFi connection, as you report - I can’t see why it’s doing this, but I recommend trying another reboot of the Beam to resolve it. Please try unplugging the Beam from power for a minute or so as it really should be reporting WM:0. The usual reason for this happening is if the Beam didn’t get the message about switching to channel 11, but the diagnostics indicate it did. If a longer power-off doesn’t fix it, please try moving channel to 6 and then back again - it doesn’t fit what I see, but worth a try.

As I alluded to in my first reply, even if we get the Beam onto SonosNet, you may still not get issue-free playback of TV audio in other rooms. This becomes more likely with each room added to the group. What happens if you group only the Beam and Roam together, leaving the rest of the system out of the group?

Something else you can try once Beam is reporting WM:0 is to get the Roam connected to 5GHz, though I don’t see any 5GHz WiFi reported in the WiFi scan list - perhaps you have it turned off in your router’s settings? With SonosNet active, the Roam should be the only speaker attempting to connect to WiFi (and is happy to connect to 5GHz), so if you have 5GHz disabled in an attempt to get your Sonos system working better, I think with SonosNet now active, it may be time to try the Roam on 5GHz. 5GHz has a higher bandwidth and lower latency than 2.4GHz WiFi, though it also has a fundamentally lower range and less ability to penetrate objects/walls. Settings » System » Network » Manage Networks » Update Networks and follow the on-screen prompts.

I hope this helps - if not, please provide an updated diagnostic number once more.

 

Hi Corry P.

Thanks for the fast reply.. Coincidentally with your message the Beam changed it’s status to WM:0 all by itself ( there was also  a brief message on the Sony Bravia referring to TV speakers, but too quick to read). Perhaps I was too impatient.

I grouped the Roam and Beam together and tried with the other speakers grouped to play music “On this device”, but the Roam still drops-out.. Then tried disconnecting the power from 2 of the 3 Play:3 ‘s, (they now show as  status : not connected). but Roam still drops out. I take your drift that with fewer speakers  “loading” the WiFi we might expect things to improve from bandwidth available to the Roam, but this isn’t quite delivering as yet.. I tried setting the Group Audio Delay to Med and High, but still no improvement,

As to the WiFi , my system is 6 years old and from what I can see in the handbook / spec., the box is just 2.4 GHz only, no option for 5 GHz.. Perhaps that is my problem !!

I tried walking around with the roam but found no changes when near / far from the router and / or Beam.

I don’t suppose that the Roam can connect to the Beam as a surround?. Might complicate things  !!

In the above condition I received another  Diagnostic number:

802497052

Thanks again for all your help

Beas Regards

 

Userlevel 7
Badge +18

Hi @Silurian 

Even at 6 years old, I would expect your router to have 5GHz capability - did it come free from your Internet Service Provider? If so, you may be able to get a free upgrade. Free routers in the UK tend to be worth what you pay for them, however - if looking to upgrade, I’d recommend just purchasing a router for no less than around £50-£60 (you can get a router for about £25, but it would not be worth the effort).

While it’s easy to blame the router (until a new router behaves the same way, at least), it doesn’t really explain why it’s only the Roam being affected - especially if other rooms aren’t involved. The Roam is reporting near constant underflows (running out of data as it plays), but indicates no transmission errors to explain them. Please try holding the power button on the Roam for approximately 12 seconds to force a full reboot.

For what it’s worth, I just checked my own Roam (which I’ve forced onto 2.4GHz for range) grouped with TV audio and it played without issue (though my TV-connected Amp is wired with ethernet).

As a test, what happens if you play some music to a Play:3 and group-in the Roam?

Hi Corry P

I checked the router,, which did indeed come  from my ISP, first use was  2015, so  getting on for 8 years old,, Spec sheet says 2.4 GHZ only,. Looks like I’m a bit out of date in that area.

I tried the reboot and then a full reset + add new product  sequence, but the Roam still has the audio drop-outs..

Also  played some  music from “on this device” on one of the Play3, then grouped the Roam to this Play 3, and as usual the Roam is working without problem, clean sound, no drop-outs. As soon as I  add the Roam back to the TV / Beam group the drop-out returns, all other speakers are working well. Tried the same thing with the (Wired) Sonos One, same result

At least my problem is not intermittent !!!

I think I may need to try and buy a 20 m RJ45 cable and connect the router into the Beam (as you suggested at the start), just to see if that changes anything. even on a temporary basis.

Best regards.

Userlevel 7
Badge +18

Hi @Silurian 

WiFi 4 (IEEE 802.11n) came out in 2009, and that’s the earliest standard in which the 5GHz frequency band was used - I would be very surprised if your router did not support at least it. Note that WiFi 4 is a retroactive name and at the time, it was just called IEEE 802.11n. If you’re quoting the spec sheet above, however, then I guess it is what it is. Given it’s lack of ability in this regard, it’s also entirely possible the router doesn’t have enough CPU/RAM resources to cope with the amount of devices you have connected to it. Even if it does not resolve the reported issue, I think replacing your router would be money well spent (your ISP should really do it for you, but they will try to be cheap about it). With the amount you’ve obviously spent on your Sonos system over the years, it’s counter-intuitive to make it rely on a router that wouldn’t fetch £5 in a car-boot sale!

To be honest, I’m no longer convinced that wiring the Beam will help - the Beam will group with the other speakers, and will not group to the Roam alone, so it doesn’t seem the issue is with the Beam’s connection (it could still become an issue with a large group, however). But, if you can get a cable along with a promise of a refund if it doesn’t help, sure - give it a try.

At the end of the day, however, TV audio sharing was never intended to be a feature - we never really presented it as such, but were aware that for some it would work so didn’t prevent it from being done. As a fair few people are using their systems in such a way anyway, we did recently add the Group Audio Delay function to mitigate any playback issues. Basically, that option is there to solve this exact issue, but it does have it’s cost, as you’ve found.

I just found something. Earlier, I was relying on a diagnostic summary table for the Roams connection performance. Looking closer at the actual data, I now think I see the issue, and I’m reporting the summary table to someone who can do something about it for the future. Anyway, the Roam is experiencing about 80% PER (Packet Error Rate), suggesting that something is getting in the way of a healthy connection to the router. It is not distance, as the signal strength is nicely in the green. Could you please describe what devices are within 1m of either the router or the Roam? Also, if the Roam or router are sitting on glass or metal surfaces, that could the problem. Immediately next to a window wouldn’t be ideal either.

I hope this helps.

Hi again Corry P.

Thanks for your efforts. The router is mounted on a plasterboard “stud” wall with no other electrical or electronic kit within 1 metre. AC adaptor for the router is plugged into house mains  just below , and the phone  connection  lead  for landline / ASDL, (No fibre optics here).  Not near any windows or metal furniture or radiators / plumbing pipes. The router is on the 1st floor, Beam / TV on ground floor about 6 metres  across and below. House is traditional stone / block build with wood / chipboard floors.

On the nearby (2 - 3 metres)  desk are the laptop, mobile phone and landline Dect. phone. This where I have the Roam for tests. I have an HP Printer ( Envy 6234) on the desk which is internet connected, but I have this disconnected at the mains supply during our recent tests, just in case. If I use the printer / phones, it does not seem to have any effect on the audio drop-out.

As mentioned, walking around with the Roam in hand has no noticeable effect on the sound; if I go outside the house by 10 metres or so, the Roam  goes quiet when it loses signal range..

I tried  placing a large metal oven  grill pan in front of  the router box, and then  behind the stud wall, but again no change. I was hoping to find a way to make the problem worse to give a clue as to the cause, but it’s still beating me!

Best regards. S

Userlevel 7
Badge +18

Hi @Silurian 

You are most welcome!

The printer could indeed cause problems - they tend to transmit WiFi - as could the DECT phone (the handset and the base), but as you’ve tested away from these devices, my current best theory is that a replacement of your router is the best chance of fixing this issue. Please understand that I can’t promise anything, but it certainly sounds like even if it didn’t fix this specific issue, a new router would still be more than worth while - the advantages of a modern router are numerous.

To ease the transition, make the new router’s WiFi credentials the same as your current one’s - this will minimise the amount of setup needed to get all your devices back online, and I’d recommend going back to a wireless Sonos configuration with a new router. If you get a third-party router (as opposed to one from your ISP), you’ll need to copy over the Internet Connection (ADSL) settings to the new device (be sure to get an ADSL router!). If your current router has a “modem mode”, you could get any router (or mesh WiFi system) to operate in-between the old one and your devices (rather than replacing your current router).

I hope this helps.

Hi Corry P.

Thanks for the steer; yes I think I will check out availability  of better quality / dual band routers  and skill-up on home WiFi set-up procedures.

Best regards for now, S