Answered

Problems Updating Roam

  • 28 February 2023
  • 3 replies
  • 1502 views

I’ve been unable to install an update on my Roam. Keep getting error 30 which has 2 suggestions. First - move it closer to the router. Tried that, got the same error. 2nd plug in Ethernet cable. Can’t do that on a roam. Any other ideas please?

icon

Best answer by GuitarSuperstar 1 March 2023, 03:39

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 7

Try rebooting the Roam by following these steps:

  1. Disconnect Roam from charging cables and remove it from wireless chargers.
  2. Hold the button on the back of Roam for at least five seconds until you hear the power-off tone and the light above the Sonos logo turns off.
  3. Wait 10 seconds.
  4. Press the button on the back of Roam to turn it back on.
     

Also reboot your router and phone. If this doesn’t work, delete and reinstall the Sonos app.

Thanks for the reply. I’ve tried rebooting everything but it still hasn’t worked. Can I ask another stupid question please?  If I uninstall the app, will I have to set all my speakers up again or will the data still be there when I reinstall it?  I’m on an iPhone if that makes any difference.  Don’t want to lose my other speakers by uninstalling it when I don’t have time to do a full set up. Many thanks 

All data is stored at the speaker level, and not on the controller device itself, so you’d be safe tips uninstall the app, then install it again. Just be certain, when prompted, to ‘join existing system’. If you set up a new system, you’ll erase the data.