Answered

NAS drive.

  • 19 August 2020
  • 6 replies
  • 327 views

Cannot add to queue from Nas drive share 

icon

Best answer by rcdunnii 21 August 2020, 21:30

Removing NASDrive and reinstalling it in Sonos fixed i , plus selecting music from Music Library rather than from NASDrive service works!!!

Thx

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

6 replies

Most frequently, this is due to SMB v1 not being on.

Userlevel 6
Badge +17

Hi @rcdunnii.

Welcome to the Sonos community and thanks for reaching out to us.

I would like to ask some questions to better understand how to help.

  • What is the operating system of the computer you are using to set up Nas drive as a music library on the Sonos app?
  • What Nas drive are you using(make and model)?
  • Has this ever worked in the past or this is the first time you are setting up a Nas drive on your Sonos system? (if this worked before what changes happened prior it was still working and the moment it stopped working?
  • Were there any changes in the network? (router, modem, Wifi extenders, repeaters, boosters or mesh system)
  • May I also ask what is the error message on the Sonos app?
  • What issues are we having every time we are adding the Nas drive on the Sonos app?

The more information and details you provide, the more we can better understand how to help.

Please let us know if you still have further questions or concerns. We are always here to help.

Thanks,

Removing NASDrive and reinstalling it in Sonos fixed i , plus selecting music from Music Library rather than from NASDrive service works!!!

Thx

Userlevel 6
Badge +17

Hi @rcdunnii.

Thanks for the update and immediate response.

I’m glad everything is now working as expected and thank you for sharing the solution on how the issue was fixed so others in the community who may have the same issue would be able to find your solution handy.

Please let us know if you still have any further questions or concerns you can always create a new topic. We are always here to help.

Thanks,

Most frequently, this is due to SMB v1 not being on.

I have just installed a Synology DS418 NAS drive and was struggling to get my Sonos system to connect to the music folder. After a lot of web trawling I found this comment. In the File Services section of the Control Panel select Advanced Settings and change the Minimum SMB protocol to SMB1. It was set to SMB2.

After that … no problem :grinning:

 

Userlevel 6
Badge +17

Hi @garybw.

Welcome to the Sonos community and thanks for sharing your input on this situation and specific NAS drive model. We appreciate it a lot. This thread will serve as a helpful tip to other members of the community who might have the same set up as yours and is looking for answers here in the community. 

Please do not hesitate to share any additional input or recommendation by reaching out to us or creating a new topic. Here in the community, everyone is always here to help out.

Thanks,