Answered

ATV autoplay through Airplay2 instead of HDMI

  • 25 September 2019
  • 14 replies
  • 571 views

Badge
Hi,

I'm using an AppleTV 4K and a Beam connected to my TVs HDMI ARC. When I start my Apple TV it choose to play the sound on Airplay 2 in on my Sonos One in the kitchen instead of just playing through HDMI. I've chosen HDMI as the default output on my ATV. Anyone got any sugestions?
icon

Best answer by Ken_Griffiths 25 September 2019, 17:42

nordstiern

Bruce is correct, this is an Apple, not Sonos, issue.

Assuming you're using tvOS 13, goto Settings/Video and Audio/Audio Output and actually go into the device list itself, where you need to remove the check mark from your Kitchen Sonos One Speaker... you can play to more than one audio output from Apple TV and you obviously have more than one output selected. See example screenshot from my ATV.
View original

14 replies

You might get better info from an Apple forum, but I have never found a method on iOS (not looked on my Apple TV) to define a default speaker to send AirPlay 2 to, it always defaults to itself.
Badge
I believe it’s a Sonos issue though. Because the ATV can’t transmit to airplay 2 as I understand, just receive. It’s the beam that is transmitting to kitchen as far as I know. Guess I just want a possibility to ungroup airplayCompatible speakers when hdmi is input on beam.
Frankly, I am confused. Sonos, when used in AirPlay 2 mode, is merely a receiver of data, it doesn’t have the ability to make choices in an Apple device. The only thing it can do is choose to change the situation it has within the Sonos ecosystem, I.e. what speakers it is grouped with. Sonos is not involved with what choice Apple makes as to what device is being sent to.

I am curious as to why it is even using AirPlay 2 when your Sonos Beam is connected to your TV via HDMI-ARC. I would certainly consider a reboot (power cycle) of the Apple TV. But ultimately, what output is being used by the Apple TV is within the Apple TV’s OS, and not part of Sonos.

Have you updated to TVOS 13.1?
nordstiern

Bruce is correct, this is an Apple, not Sonos, issue.

Assuming you're using tvOS 13, goto Settings/Video and Audio/Audio Output and actually go into the device list itself, where you need to remove the check mark from your Kitchen Sonos One Speaker... you can play to more than one audio output from Apple TV and you obviously have more than one output selected. See example screenshot from my ATV.

I have a similar issue. Except my AppleTV will default to AirPlay to my Beam (which is setup for surround) and it will also play through HDMI to the same Beam at the same time. 
 

It’s annoying because I’ll have to hold down the play button at the home screen and uncheck the Beam from airplay every single time. If I don’t do that, then I won’t get the surround experience and the dialog will come out of all of the speakers.
 

I’ve erased my AppleTV and set it up as new but it’s still occurring. I’ve also gone into settings > audio output on my AppleTV and made sure its output is HDMI and I’ll uncheck the Beam from AirPlay. But the issue still occurs.

 

 

the_chris,

What happens if you check/select the Beam Device in “Video & Audio/Audio Output” for AirPlay purposes and then uncheck/deselect HDMI instead?

the_chris,

What happens if you check/select the Beam Device in “Video & Audio/Audio Output” for AirPlay purposes and then uncheck/deselect HDMI instead?

It will not give the surround experience at all. It’ll play the exact same audio through all of the speakers as if it music. 

In the tvOS AirPlay settings.. is your HomeKit “room” name, the same as the name of your Beam?
Does it help if you give it a different ‘room’ name and then set the Audio Output back to HDMI? (Unchecking all the other options).

The room name is “my bedroom” and my beam name is “my Sonos” so unfortunately it hasn’t made a difference. 

The room name is “my bedroom” and my beam name is “my Sonos” so unfortunately it hasn’t made a difference. 

Maybe try the Apple TV support Forum see if anyone there may know the answer, perhaps? In my case the ATV just sticks to the HDMI audio output for my TV 5.1 playback. Beam is connected to the TV’s HDMI ARC port and ATV is cabled to one of the TV’s other HDMI ports (HDMI-4) and it works fine. 

the_chris,

As another thought, have you tried toggling off AirPlay altogether on the ATV in its AirPlay Settings?

I’m having the same issue. As i remembered this was not an issue before tvOS 13, I hope this will be fixed trough a software update. 

… the ATV can’t transmit to airplay 2 as I understand, just receive ...

I always transmit sound from my Apple TV 4K to a Sonos Beam via Airplay 2.

That way I don’t need a TV to provide HDMI ARC and manage the volume control.

Just the best 4K HDR monitor I could find.

 

 

Hi,

I'm using an AppleTV 4K and a Beam connected to my TVs HDMI ARC. When I start my Apple TV it choose to play the sound on Airplay 2 in on my Sonos One in the kitchen instead of just playing through HDMI. I've chosen HDMI as the default output on my ATV. Anyone got any sugestions?

 

This might sound a bit off the wall but…

Have you connected the Apple TV to the Beam with an ethernet cable?

If so, try removing it.

Type your message here.

Reply