Answered

surround sound

  • 31 January 2024
  • 5 replies
  • 133 views

Not able to get 5.1 only stereo pcm. Sonos beam and one sl’s connected. 
I have a Sony tv that supports hdmi arc. Have used hdmi and optical line to connect sound. 
just no 5.1 

any help much appreciated - very frustrating 

 

cheers 

Paul

icon

Best answer by Ken_Griffiths 31 January 2024, 22:11

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

5 replies

Ensure the Sony TV settings are correct …

  • eARC: Auto
  • Digital Audio Out: Auto 1
  • Dolby Digital Plus Output: Dolby Digital/Plus (if available)
  • Pass Through Mode: Auto

Also see if this may help too (if present in your TV settings)…

Turning on IP Simple Control
Open Settings
Go to Network and Internet
Go to Home network
Go to IP control
Go to Simple IP control
Toggle On 

https://youtu.be/VXDYspxEClg

Userlevel 7
Badge +19

You’ll also need a program that’s being broadcast in 5.1 format - much of what’s broadcast is only stereo. 

Thanks guys, really appreciated! 
I’ve tried doing the above and still only stereo pcm. I tried watching different things such as Avatar from Apple TV and Elvis on Netflix. I checked and they both do Dolby. 
 

I also can’t find the ‘Pass through mode’ on my tv. The others suggestions  I have found as found such as Dolby plus. I can’t see a selection for eARC either. My tv has optical line in. I’m using the hdmi and linked it through Sonos app. 
 

Thanks again for your help! 
 


 

 

Try changing the audio-out on your Apple TV - set the ‘change format’ to ‘On’ and then select the Dolby Digital 5.1 audio format and see if that perhaps fixes your issue.

Mate, you are a legend!!!! Thank you so much, it’s working!!!!!!

I owe you one for the hours of frustration you’ve saved me. Thank you sir!