Answered

Sonos system keeps disconnecting from TV

  • 29 June 2023
  • 1 reply
  • 1393 views

I just bought my whole Sonos sound system a few months ago when the era 300s launched! About a month ago the system started randomly disconnecting and reconnecting to my TV in the middle of watching things. The sound will just randomly cut out, the light on my Arc and Sub will turn white, and then 45 seconds later the lights will turn green and it will reconnect. The system is connected via eARC to my TV, and my wifi is not going out. I have tried everything at this point… turned the router on and then off, powered off the arc/sub/my 2 era 300 surrounds to try and recconnect, and changed the HDMI cable. I’m not sure how to fix this issue! 

icon

Best answer by Airgetlam 29 June 2023, 04:25

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Have you tried checking the TV for updates, then rebooting the TV by unplugging it from the wall for five minutes?

Alternately, you could submit a system diagnostic within 10 minutes of experiencing this problem, and call Sonos Support to discuss it.

There may be information included in the diagnostic that will help Sonos pinpoint the issue and help you find a solution.

When you speak directly to the phone folks, they have tools at their disposal that will allow them to give you advice specific to your Sonos system and network.