Answered

Sonos Beam 2 and Samsung Q70 Not Allowing To Change Audio Source

  • 15 August 2023
  • 2 replies
  • 119 views

We have a Beam Gen 2 and 2019 Samsung Q70 tv that are connected via the arc cable. The sound works great, but the issue comes when changing the source of audio. When we turn on the TV it auto connects to HDMI receiver for sound (which is the Sonos connected via arc), but if you select any other audio source (TV speakers/optical/bluetooth) it will switch to that source for a couple seconds and then switch back to HDMI receiver. One of us will often use the TV with headphones on, but the only way to use the bluetooth connection is to manually unplug the ARC cable from the TV or Sonos. 

 

Is there a setting(s) that I need to change on the TV and/or Sonos to enable us to leave the ARC cable plugged in and allow us to change the sound source without immediately defaulting back to the HDMI receiver (Sonos)? One solution I keep seeing is disabling the Anynet+ option, but this means each time we have to go into the settings and enable/disable. If this is the only solution then we can do that, but I was hoping we might be missing another setting that is causing this issue :)

icon

Best answer by GuitarSuperstar 15 August 2023, 19:52

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

Userlevel 7

Try disabling Anynet+ on the TV before switching to use Bluetooth.

Userlevel 7
Badge +17

Nope. This is HDMI-CEC doing it’s job. If you do not want that it needs to be disabled.