sonos arc SL not working with LG remote

  • 30 March 2021
  • 1 reply
  • 251 views

  • Contributor I
  • 0 replies

Hi, here is my set up.

LG CX OLED connected to the sonos arc SL from Costco via HDMI through the eARC port. Previously everything worked well until I had to unplug things today to mount the arc onto the wall.

After reconnecting I can no longer control the volume using the LG remote. I have tried the Philips method, setting up universal remote, reconnecting, powering off and trying different hdmi cables, trying to setup remote with the sonos app. Seems my issue isn't isolated after some research online but there is no consistent or reproducible fix.

I realized the following

1. The arc responds to the remote, blinking indicator light when the TV is turned off each time I press volume down.

2. The sonos app states my eARC is not connected, although I'm getting appropriate sound, my TV states it is using ARC out and eARC turned on.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

1 reply

Userlevel 6
Badge +15

Hi @TLin, welcome to the Sonos Community!

Lets try some basic steps first. Mind fully powering the TV off at the wall, and disconnecting the Arc, along with any other HDMI connected devices  from the back?

If you then wait a minute or so, power the TV back on, and then reconnect the Arc first, are you able to control the volume using the remote control again? If not, it may also be worth cycling eARC on the TV off and then back on, or going through the remote control setup once more before reconnecting any other HDMI devices.

Let us know how you get on :)