Answered

Occasional connection problem

  • 18 November 2022
  • 2 replies
  • 64 views

I've had my Beam 2  Samsung tv, and sat box, for a few months and it all starts up as it should. 

Occasionally though  I do not get any sound out of the Beam it connects to the TV speakers instead

I have to turn off tv and sat box and unplug TV ( not sat box), wait 20 seconds, plug back in and all is ok again.

Anyone? 

icon

Best answer by buzz 19 November 2022, 16:29

View original

This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

2 replies

That sure sounds like an issue in the TV’s CEC chip, which is assigned to handle the handshake between it and all “sink” devices such as the Sonos. I’d definitely be checking to see if there are any updates to the TV’s software/firmware. 

Samsung has had a history, at least on specific TVs, of having issues, so you may want to reach out to Samsung’s CS as well. 

Make sure that the TV firmware is up to date. Unfortunately, the “latest” will sometimes break things and you’ll need to wait for a newer version.

I recommend that you disconnect all HDMI connections to the TV, then reboot the TV and BEAM. Note that you need to remove power from the TV for at least two minutes before it will reboot. Next, power up both units, then connect only BEAM to the TV and get BEAM operating. Finally, connect other units to the TV.

This is your best shot, not a guaranteed fix.