Nintendo Switch Controllers Lag When SONOS is Connected

  • 7 February 2021
  • 3 replies
  • 295 views

When my SONOS Beam is connected to the TV, the controllers for the Nintendo Switch lag a split second, enough to make many games unplayable. It is NOT an audio lag, but a controller input lag. As soon as I unplug the speaker from the TV, the controls are responsive again. And when I plug the speaker in again, the controls start lagging again. This happens whether I’m using a wireless controller or a USB controller.

I don’t think it has to do with the Beam’s wifi. I have it set up on ethernet from the router and it’s not connected to a wifi network. I’m using a TCL ROKU TV (49S405). FYI, this is the same problem experienced in an earlier posted question that was never resolved (“Nintendo Switch Controller Connection Issues” by Mattr767). 

What’s going on? Is there anyway to fix this? I can’t use the Beam when gaming, which is half the use the TV gets.


This topic has been closed for further comments. You can use the search bar to find a similar topic, or create a new one by clicking Create Topic at the top of the page.

3 replies

Userlevel 7

How close is your Switch to the Beam? If you move the controller closer to the Switch, does it make a difference? Have you tried moving the Switch to a different location? Are there any other devices near the Switch that could be causing interference?

It’s usually about a foot away. I moved it a few more feet away and it has the same problem. 

The issue happens when we’re using either wireless or wired controllers, and the Beam is connected via ethernet, so I don’t think this is a wireless signal interference issue.

Userlevel 7

A device doesn’t have to be connected to Wi-Fi to cause interference. Is your Beam connected to your TCL via HDMI? Do you have the option to connect it to your TV via optical? Does this make a difference? Does your TV have a Game Mode setting?