LG - sonos arc occasionally no sound

  • 12 February 2024
  • 5 replies
  • 63 views

Badge +1

Hi everyone, so I still have an issue with my LG C2 in combination with my Sonos arc. The arc occasionally stops playing sound. Before it only happened after switching from HDMI source (with Dolby enabled ps5 or Xbox) back to an internal app like YouTube. Problem is solved by changing the sound source on the tv (hdmi to tv speaker to hdmi). But now I’m surprised that even when I watch a tv show on the internal app of the tv itself, it still happens occasionally. When I’m watching a tv show in stereo or 5.1, when the next episode is loaded after the one I was watching was finished , there is no sound. The same trick as before solves the issue. The HDMI inputs have never been turned on in this case. All my setting are correct. I use passthrough and eArc. I have read every topic here and Reddit but couldn’t find a solution. Sonos sends me to LG and LG tells me silly thing like turning of auto power sync etc. Doesn’t solve the issue. Anyone else having this problem? If not, I’m starting to think it’s a handshake issue??


5 replies

Userlevel 7

Try this:

Disconnect everything from the TV and unplug the Arc and TV from power for a couple of minutes. Plug everything back in but keep everything disconnected. Make sure Simplink is enabled in the TV settings. Run TV Setup in the Sonos app and follow the app instructions. When the app instructs you, connect the Arc to the TV’s HDMI ARC/eARC port using the Sonos-supplied HDMI cable. After the Arc has been successfully connected, connect the other devices to the TV.

Badge +1

I also have two era 300 speakers in the surround set. Do I do anything with them? 

Userlevel 7

I also have two era 300 speakers in the surround set. Do I do anything with them? 

No. They are slaves to the Arc.

Badge +1

Hi,

 

I did everything u said but it didn’t help. As soon as a switch a few times from hdmi input to internal app, I could trigger the problem. Any other ideas? 

It seems like you're facing a recurring issue with your LG C2 and Sonos Arc, where the sound occasionally stops playing. Despite trying various solutions, the problem persists, and you suspect it might be a handshake issue. You've sought help from both Sonos and LG, but haven't found a definitive solution. If others are experiencing a similar problem or have found a solution, you'd appreciate their input.

 

 

 

 

 

I also think you have a problem with your HDMI cable.

Some cables have problems with the correct handshake.

So, if you have a different cable, I would change this.

Reply