LG C1 + Sonos Arc + PS5 = no Dolby Atmos

  • 5 August 2021
  • 4 replies
  • 3365 views

Hi all,

 

New to the world of Sonos. Treated myself to an Arc + Sub, connected to my LG C1 via the eArc HDMI port. I’m also using a PS5 for gaming and watching 4k discs. 
 

My issue is I can’t get the Arc to play any of my 4k discs with Dolby Atmos. The ‘best’ settings I can get are Multichannel PCM 7.1. These are the settings I have on my C1:

 

HDMI Input Audio Format: Bitstream

Digital Sound Output: Pass Through

eARC support: On

 

And on the PS5:

HDMI Device Type - Soundbar (have tried having this as TV and Amp too, results still the same)

Audio Format Priority: Dolby

Audio Format (from menu when watching 4k disc): Bitstream

 

Im getting a bit flustered by not being able to figure out what I’m doing incorrectly! Any guidance, tips or suggestions to get Dolby Atmos working would really be appreciated. 
 

Thank you for your time. 


4 replies

Userlevel 7

Try setting Digital Sound Output to Auto.

Userlevel 7

Also try pressing the Options button on your PS5 joystick while playing a film disc, then click the ‘three dots’ icon and choose the Bitstream option under Audio Format.

Also try pressing the Options button on your PS5 joystick while playing a film disc, then click the ‘three dots’ icon and choose the Bitstream option under Audio Format.

Thank you for both your suggestions. I already have Bitstream selected under Audio Format.
 

I tried changing Digital Sound Output to Auto per your other comment and sadly that hasn’t helped. It made the sound coming from the Arc from Multichannel PCM 7.1 to Stereo PCM. 

Userlevel 7

What specific 4K discs are you testing?

Reply